Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.7.2] Building mod with dependency on another mod


WildBamaBoy
 Share

Recommended Posts

Trying to build MCA using Gradle. It now uses another separate "mod" that contains core functions, interfaces, etc. that I plan to reuse. When building, Gradle can't find any references to this other mod. How do I point it in the right direction?

 

My file setup is probably very weird. I'm not sure what it's generally supposed to be with multiple mods, plus I'm using Git and I'm not very experienced with it.

 

Gradle

|_src

  |_main

      |_ java

          |_ mca

              |_ [mca's packages]

  |_ radixcore (this is the other mod's repository from GitHub)

 

 

My Eclipse workspace is as follows:

 

Minecraft

|_ src/main/java

    |_ [mca's packages]

|_ src/main/resources

    |_ [mca's resorces]

|_ radixcore (Shortcut to the src/main/java folder of the radixcore project)

Link to comment
Share on other sites

Something like this? It can't find the core. It's in a completely separate folder with another copy of gradlew, the minecraft source, etc. and its src/main/java is a linked folder in MCA's eclipse workspace. I don't understand how it is supposed to know where "com.radixshock.radixcore" is supposed to be, or how to tell it that.

 

The core's relevant build.gradle section:

[...]
apply plugin: 'forge'

version = "1.0.0"
group= "com.radixshock.radixcore"
archivesBaseName = "RadixCore"
[...]

 

MCA's relevant section

[...]
    dependencies {
        classpath 'net.minecraftforge.gradle:ForgeGradle:1.1-SNAPSHOT'
	classpath 'com.radixshock.radixcore:RadixCore:1.0.0'
    }
[...]

Link to comment
Share on other sites

I really appreciate your help. This is all new to me, remember. I'm not familiar with gradle, maven, or anything like that. The core was published, apparently, but gradle still doesn't know where it is when building MCA. I'm not sure what else to tell it, or how.

 

This is a lot more frustrating than it has to be, but I'm probably making it more complicated than it really is. I may end up modifying my original build script to copy the core's source where it needs to be and then build, if that would work. Although I'd like others to know how to implement the core correctly since it's open source.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hello Everyone! I created a Minecraft Forge Server the other day, had no issues running it. (version 1.16.5) (vanilla) I updated my Java today, because I had a prompt on my desktop to update and I did. Now when I run the Bat file I get a sting of errors I am not too sure how to combat. I have read that Minecraft Forge only runs on certain versions of Java and I cannot find a source to resolve or change my Java version. Below is the string of errors in the cmd. Thank you for taking the time to read this!    C:\Users\Zenoh\Desktop\Minecraft Server LFG>java -Xmx4096M -Xms4096M -jar forgeserver.jar nogui 2022-01-23 16:55:45,757 main WARN Advanced terminal features are not available in this environment [16:55:45] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.23, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui] [16:55:45] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 17.0.1 by Eclipse Adoptium Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0xadd0edd) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0xadd0edd         at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:41)         at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95)         at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:41)         at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55)         at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708)         at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52)         at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47)         at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62)         at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55)         at cpw.mods.modlauncher.Launcher.main(Launcher.java:66)         at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63)         at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60)         at net.minecraftforge.server.ServerMain.main(ServerMain.java:57) C:\Users\Zenoh\Desktop\Minecraft Server LFG>PAUSE Press any key to continue . . .
    • nope it doesnt exist in all GuiUtils class (im in 1.16.5 MCP)
    • oh well then thats nice, with the name you gave me i can try it by myself
    • omg thanks so so much!! you're the best!!!
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.