Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[Solved] Red exclamation


Marcel1202
 Share

Recommended Posts

Hey,

I've started all my Projects with gradlew setupDevWorkspace, but so I can't see the Minecraft methods.

But when I start a Project with gradlew setupDecompWorkspace then I get a red exclamation mark on the Project Folder (in Eclipse)

Can I fix this?

Link to comment
Share on other sites

I think this should fix it, since I have the red exclamation mark frequently when updating. (For me, it means that the forgeBin is missing)

 

1. gradlew --refresh-dependenceis
2. gradlew eclispe
3. gradlew setupDevWorkspace
4. gradlew setupDecompWorkspace

Kain

Link to comment
Share on other sites

How about going with those commands:

gradlew clean
gradlew cleanCache
gradlew setupDecompWorkspace --refresh-dependencies
gradlew eclipse

It's basically how I do it everytime.

Don't ask for support per PM! They'll get ignored! | If a post helped you, click the "Thank You" button at the top right corner of said post! |

mah twitter

This thread makes me sad because people just post copy-paste-ready code when it's obvious that the OP has little to no programming experience. This is not how learning works.

Link to comment
Share on other sites

gradlew setupDecompWorkspace --refreshDependencies

 

--->

 

wDslxTN.png

 

Only gradlew setupDecompWorkspace eclipse "Build Succesfull" But a exclamation mark.

gradlew setupDevWorkspace eclipse works but I can't see classes of the minecraft code.

Link to comment
Share on other sites

Try again till the "gradlew setupDecompWorkspace --reresh-dependencies" builds successful. (<-I had mistaken too;)

It might have some random errors, I also frustrated with them.

But it finally built successful when I tried 4~5 times.

I. Stellarium for Minecraft: Configurable Universe for Minecraft! (WIP)

II. Stellar Sky, Better Star Rendering&Sky Utility mod, had separated from Stellarium.

Link to comment
Share on other sites

gradlew setupDecompWorkspace --refreshDependencies

 

--->

 

Only gradlew setupDecompWorkspace eclipse "Build Succesfull" But a exclamation mark.

gradlew setupDevWorkspace eclipse works but I can't see classes of the minecraft code.

 

whoops, I meant --refresh-dependencies instead of --refreshDependencies  :-[

Don't ask for support per PM! They'll get ignored! | If a post helped you, click the "Thank You" button at the top right corner of said post! |

mah twitter

This thread makes me sad because people just post copy-paste-ready code when it's obvious that the OP has little to no programming experience. This is not how learning works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.