Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

EntityListMapping Query


Recommended Posts

So, I've created a spawner block that uses the TileEntitySpawner, however it only works when I pass the name of Vanilla mobs in, and not my custom (and registered ones) using the registerModEntity.

 

Edit:

Okay, so using:

EntityList.addMapping(MyMob.class, "MyMob", 75);

fixes the issue.

 

However, I don't really want to use Vanilla IDs (like the 75, even though it;s a mod-registered mob) so is there any way around that?

Link to post
Share on other sites

So, I've created a spawner block that uses the TileEntitySpawner, however it only works when I pass the name of Vanilla mobs in, and not my custom (and registered ones) using the registerModEntity.

 

Edit:

Okay, so using:

EntityList.addMapping(MyMob.class, "MyMob", 75);

fixes the issue.

 

However, I don't really want to use Vanilla IDs (like the 75, even though it;s a mod-registered mob) so is there any way around that?

 

you need to change logic of spawners , beacos they using only vanillas mobs...The same as spawning egg - they just dont know what you entity exists.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.