Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

{1.7.10 pre4} Failing to launch Client in workspace


 Share

Recommended Posts

I have setup a workspace for the 1.7.10 pre4 version of forge. I ran the command:

 

gradlew.bat setupDecompWorkspace --refresh-dependencies

 

and

 

gradlew.bat eclipse

 

When I open eclipse, everything is as it should be. I can edit my code, look into the referenced libaries to read through vanilla code. But when I hit the run button, I get this error and it fails to start the client:

 

 

 

[23:26:58] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker

[23:26:58] [main/INFO]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker

[23:26:58] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker

[23:26:58] [main/INFO]: Forge Mod Loader version 7.9.30.1141 for Minecraft 1.7.10-pre4 loading

[23:26:58] [main/INFO]: Java is Java HotSpot 64-Bit Server VM, version 1.7.0_07, running on Windows 7:amd64:6.1, installed at C:\Program Files\Java\jre7

[23:26:58] [main/INFO]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation

[23:26:58] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker

[23:26:58] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker

[23:26:58] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker

[23:26:58] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker

[23:26:58] [main/INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper

[23:26:58] [main/ERROR]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!

[23:26:58] [main/ERROR]: The minecraft jar file:/C:/Users/Lars/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.10_pre4-10.12.2.1141-prerelease/forgeSrc-1.7.10_pre4-10.12.2.1141-prerelease.jar!/net/minecraft/client/ClientBrandRetriever.class appears to be corrupt! There has been CRITICAL TAMPERING WITH MINECRAFT, it is highly unlikely minecraft will work! STOP NOW, get a clean copy and try again!

[23:26:58] [main/ERROR]: FML has been ordered to ignore the invalid or missing minecraft certificate. This is very likely to cause a problem!

[23:26:58] [main/ERROR]: Technical information: ClientBrandRetriever was at jar:file:/C:/Users/Lars/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.10_pre4-10.12.2.1141-prerelease/forgeSrc-1.7.10_pre4-10.12.2.1141-prerelease.jar!/net/minecraft/client/ClientBrandRetriever.class, there were 0 certificates for it

[23:26:58] [main/ERROR]: FML appears to be missing any signature data. This is not a good thing

[23:26:58] [main/INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper

[23:26:58] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker

[23:26:59] [main/INFO]: Launching wrapped minecraft {net.minecraft.client.main.Main}

[23:27:00] [main/ERROR]: Unable to launch

java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.7.0_07]

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.7.0_07]

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.7.0_07]

at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.7.0_07]

at net.minecraft.launchwrapper.Launch.launch(Launch.java:134) [launchwrapper-1.9.jar:?]

at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]

Caused by: joptsimple.MissingRequiredOptionException: Missing required option(s) ['userProperties']

at joptsimple.OptionParser.ensureRequiredOptions(OptionParser.java:447) ~[OptionParser.class:?]

at joptsimple.OptionParser.parse(OptionParser.java:437) ~[OptionParser.class:?]

at net.minecraft.client.main.Main.main(Main.java:89) ~[Main.class:?]

... 6 more

 

 

 

This even happends when I remove all my own code from the workspace. I have tried with Forge 1139 and 1141 and both gave this issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.