Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Compiling against 2 versions of an API


Parker8283
 Share

Recommended Posts

I am working on a mod that compiles against two versions of the BuildCraft API, mostly because they changed a lot between 5.x and 6.0.x. However, I am having problems making Gradle work to do this. I can't get it to download both APIs from the Forge Maven (it just downloads the newest one), and after putting one of the APIs in src/api/java and keeping the other one in the dependencies block in my build.gradle, my IDE said that all was good, but Gradle failed on recompile. The API in src/api/java compiled correctly, but Gradle still used the API defined in the dependencies block to compile against. Is there any way that I can accomplish this, or should I just drop the 5.x API support?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.