Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.7.10] Latest build not starting from eclipse


BlackCrafer666
 Share

Recommended Posts

Hi

I have downloaded latest forge build forge-1.7.10-10.13.0.1208-src.zip

i type in windows 7 console:

gradlew setupDecompWorkspace
gradlew eclipse

No errors are arise.

Next, i run MC client from eclipse kepler and get this:

[14:05:46] [main/INFO] [GradleStart]: No arguments specified, assuming client.
[14:05:46] [main/INFO] [GradleStart]: Extra: []
[14:05:46] [main/INFO] [GradleStart]: Running with arguments: [--userProperties, {}, --assetsDir, C:/Users/RAIN/.gradle/caches/minecraft/assets, --assetIndex, 1.7.10, --accessToken, {REDACTED}, --version, 1.7.10, --tweakClass, cpw.mods.fml.common.launcher.FMLTweaker, --username, ForgeDevName]
[14:05:46] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
[14:05:46] [main/INFO] [LaunchWrapper]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
[14:05:46] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
[14:05:46] [main/INFO] [FML]: Forge Mod Loader version 7.10.25.1208 for Minecraft 1.7.10 loading
[14:05:46] [main/INFO] [FML]: Java is Java HotSpot(TM) Client VM, version 1.8.0_20, running on Windows 7:x86:6.1, installed at C:\Program Files (x86)\Java\jre1.8.0_20
[14:05:46] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
[14:05:46] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[14:05:46] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
[14:05:46] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[14:05:46] [main/ERROR] [LaunchWrapper]: Unable to launch
java.util.ConcurrentModificationException
at java.util.ArrayList$Itr.checkForComodification(Unknown Source) ~[?:1.8.0_20]
at java.util.ArrayList$Itr.remove(Unknown Source) ~[?:1.8.0_20]
at net.minecraft.launchwrapper.Launch.launch(Launch.java:117) [launchwrapper-1.9.jar:?]
at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_20]
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_20]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_20]
at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_20]
at GradleStart.bounce(GradleStart.java:107) [start/:?]
at GradleStart.startClient(GradleStart.java:100) [start/:?]
at GradleStart.main(GradleStart.java:55) [start/:?]
Exception in thread "main" java.lang.ArrayIndexOutOfBoundsException: 0
at GradleStart.main(GradleStart.java:59)
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release

What is wrong?

Link to comment
Share on other sites

Can we just tell diesieben to make the header of the sub-forum Modder Support "If you are using Java 8, switch to Java 7, because if that's the case when you give us an error log, we won't help you." or something like that? Because the amount of people saying I HAVE A PROBLEM and then having their problem solved with a simple "Use Java 7 noob" is getting ridiculous.

I am the self-nominated Lord of the Mastodons and don't you dare deny it. ;) Also, check out my YouTube channel: https://www.youtube.com/user/DerpDerp44/

Link to comment
Share on other sites

Can we just tell diesieben to make the header of the sub-forum Modder Support "If you are using Java 8, switch to Java 7, because if that's the case when you give us an error log, we won't help you." or something like that? Because the amount of people saying I HAVE A PROBLEM and then having their problem solved with a simple "Use Java 7 noob" is getting ridiculous.

 

Questions such as those are very common in any programming board(or any board handling any topic for which you have to learn things for that matter). Any such action would not really help.

For one the foruminfo says this isn't a java tutorial yet how many people ask questions that would be easily solved if they knew more than 'first week OOP introduction' level java.

So I believe that, in the end, if you want to help people by answering questions on forums you will, and have to be always confronted with questions of very low level. That's simply how it works and unless beginners suddenly realise that they should read the errorlogs, use google optimally and use their brain they'll keep coming(and everyone knows that won't happen).

I guess you could say it is part of 'the job'.

 

Disclaimer: Reading the above can be harmful for your health if you are a budding programmer.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • When i run data i get this error  Exception in thread "main" java.lang.RuntimeException: java.lang.reflect.InvocationTargetException     at MC-BOOTSTRAP/cpw.mods.modlauncher@9.0.7/cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:39)     at MC-BOOTSTRAP/cpw.mods.modlauncher@9.0.7/cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:53)     at MC-BOOTSTRAP/cpw.mods.modlauncher@9.0.7/cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:71)     at MC-BOOTSTRAP/cpw.mods.modlauncher@9.0.7/cpw.mods.modlauncher.Launcher.run(Launcher.java:106)     at MC-BOOTSTRAP/cpw.mods.modlauncher@9.0.7/cpw.mods.modlauncher.Launcher.main(Launcher.java:77)     at MC-BOOTSTRAP/cpw.mods.modlauncher@9.0.7/cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:26)     at MC-BOOTSTRAP/cpw.mods.modlauncher@9.0.7/cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:23)     at cpw.mods.bootstraplauncher@0.1.17/cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:90) Caused by: java.lang.reflect.InvocationTargetException     at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)     at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:77)     at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)     at java.base/java.lang.reflect.Method.invoke(Method.java:568)     at MC-BOOTSTRAP/fmlloader@1.18-38.0.16/net.minecraftforge.fml.loading.targets.ForgeDataUserdevLaunchHandler.lambda$launchService$0(ForgeDataUserdevLaunchHandler.java:41)     at MC-BOOTSTRAP/cpw.mods.modlauncher@9.0.7/cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:37)     ... 7 more Caused by: net.minecraftforge.fml.LoadingFailedException: Loading errors encountered: [     fml.modloading.failedtoloadmod ]     at LAYER PLUGIN/fmlcore@1.18-38.0.16/net.minecraftforge.fml.ModLoader.waitForTransition(ModLoader.java:235)     at LAYER PLUGIN/fmlcore@1.18-38.0.16/net.minecraftforge.fml.ModLoader.lambda$dispatchAndHandleError$21(ModLoader.java:200)     at java.base/java.util.Optional.ifPresent(Optional.java:178)     at LAYER PLUGIN/fmlcore@1.18-38.0.16/net.minecraftforge.fml.ModLoader.dispatchAndHandleError(ModLoader.java:200)     at LAYER PLUGIN/fmlcore@1.18-38.0.16/net.minecraftforge.fml.ModLoader.lambda$gatherAndInitializeMods$11(ModLoader.java:177)     at java.base/java.lang.Iterable.forEach(Iterable.java:75)     at LAYER PLUGIN/fmlcore@1.18-38.0.16/net.minecraftforge.fml.ModLoader.gatherAndInitializeMods(ModLoader.java:177)     at TRANSFORMER/forge@38.0.16/net.minecraftforge.data.loading.DatagenModLoader.begin(DatagenModLoader.java:52)     at TRANSFORMER/minecraft@1.18/net.minecraft.data.Main.main(Main.java:65)     ... 13 more Caused by: java.lang.reflect.InvocationTargetException Caused by: net.minecraftforge.fml.LoadingFailedException: Loading errors encountered: [ > Task :runData FAILED :runData (Thread[Execution worker for ':',5,main]) completed. Took 38.808 secs. Execution failed for task ':runData'. > Process 'command '/Users/YusufIsmail/Library/Java/JavaVirtualMachines/corretto-17.0.1/Contents/Home/bin/java'' finished with non-zero exit value 1   The full log is  https://gist.github.com/RealYusufIsmail/f598cbf87bee3923f665ec3ebfff1932 and the build.gradle is here https://github.com/Dungeon-Makers/Armour-and-Item/blob/V2/1.18/build.gradle
    • im trying to run a modern rlcraft server but it wont even start. this is the log C:\Users\soto5\Downloads\Modern+RLCraft+Server+Pack-1.12.2-1.5.2\Modern RLCraft Server Pack-1.12.2-1.5.1>java -Xmx4096M -Xms4096M -jar forge.jar nogui A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException         at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)         at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:78)         at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)         at java.base/java.lang.reflect.Method.invoke(Method.java:567)         at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:70)         at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:34) Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap')         at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)         at net.minecraft.launchwrapper.Launch.main(Launch.java:28)         ... 6 more    
    • Is there a way to "override" an entity's texture to something else without creating a "dummy" item when using ThrownItemRenderer? I tried creating a Renderer that extends it with a ResourceLocation override but this does not change the entity's 2D texture. Any help would be appreciated. Render class: public class BulletEntityRenderer extends ThrownItemRenderer { private static final ResourceLocation TEXTURE = new ResourceLocation(ExampleMod.MOD_ID, "textures/entity/bullet.png"); public BulletEntityRenderer(EntityRendererProvider.Context context) { super(context); } @Override public ResourceLocation getTextureLocation(Entity entity) { return TEXTURE; } } Render registry: public class ModRender { public static void registerRender() { EntityRenderers.register(ExampleMod.BULLET, BulletEntityRenderer::new); } } Entity class: public class BulletEntity extends ThrowableItemProjectile { private float damage = 12.0F; private int pierceLevel = 0; private int ticksAlive = 0; private final int lifespan = 60; public BulletEntity(EntityType<BulletEntity> type, Level world) { super(type, world); } public BulletEntity(Player player, Level world, float damage, int pierceLevel) { super(ExampleMod.BULLET, player, world); this.damage = damage; this.pierceLevel = pierceLevel; this.setNoGravity(true); } public DamageSource causeBulletDamage(BulletEntity bullet, Entity attacker) { return (new IndirectEntityDamageSource("bullet", bullet, attacker)).setProjectile(); } public void tick() { super.tick(); Vec3 vec3d = this.getDeltaMovement(); double d1 = vec3d.x; double d2 = vec3d.y; double d0 = vec3d.z; if (this.isInWater()) { this.level.addParticle(ParticleTypes.BUBBLE, this.getX(), this.getY(), this.getZ(), -d1, -d2, -d0); } else { this.level.addParticle(ParticleTypes.SMOKE, this.getX(), this.getY(), this.getZ(), -d1, -d2, -d0); } if (ticksAlive > lifespan) { this.discard(); } ticksAlive++; } @Override protected void onHitEntity(EntityHitResult hitResult) { LivingEntity target = (LivingEntity) hitResult.getEntity(); Entity shooter = getOwner(); double armor = target.getArmorValue() * (1 - (0.2 * pierceLevel)); double toughness = target.getAttribute(Attributes.ARMOR_TOUGHNESS).getValue(); float finalDamage = (float) (damage * (1 - (Math.min(20, Math.max((armor / 5), armor - ((4 * damage) / (toughness + 8))))) / 25)); target.hurt(causeBulletDamage(this, shooter).bypassArmor(), finalDamage); } @Override public Item getDefaultItem() { return ModItems.BULLET; } }
    • Which version of Forge did you use? Post debug log
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.