Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Eclipse can't find the '.project' file for Minecraft


pinkyboy9102
 Share

Recommended Posts

Hi all,

 

Before 1.7.10 forge was released, I used the older, non-gradle version of forge to code. Recently I decided to update my mods but then decided it would be better to start from scratch instead of all the effort, so I followed some basic tutorials on setting up forge gradle. I have run all the commands correctly and the builds were all successful, but when I attempt to link my Eclipse to the 'eclipse' folder in the forge source folder, it just has minecraft as a package with no drop down and says:

 

'The project description file (.project) for 'Minecraft' is missing.  This file contains important information about the project.  The project will not function properly until this file is restored.'

 

I have looked around but can't find solutions anywhere. Help would be GREATLY appreciated!

 

Many thanks,

pinkyboy9102

 

EDIT: Nevermind, I just re-ran 'gradlew setupDecompWorkspace eclipse' then double-clicked the empty package and it...un-emptied

Link to comment
Share on other sites

  • 1 month later...
  • 3 months later...
  • 3 months later...

I ended up with this exact same error. I'd been happily following Wuppy's new tutorials for 1.8 (http://www.wuppy29.com/minecraft/modding-tutorials/forge-modding-1-8/) and decided in my infinite wisdom to rename the location of my root Forge folder from c:\minecraft-1.8 to c:\forge-1.8 (I'm on Windows).

 

Well, after doing that the project sort of loaded but it couldn't find any of my source files. More frustrating was that it was still broken after renaming the folder back to c:\minecraft-1.8!

 

Cue several hours of totally deleting all directories and instances of Forge and Eclipse, including those pesky .gradle and .eclipse folders on your user and AppData directories. Still no joy. Completely rebuild using

gradlew cleancache --refresh-dependencies setupDecompWorkspace eclipse

. Nope, still not working. I even tried setting up Forge 1.7.

 

But then I had an epiphany. I'm a NodeJS developer for a living and use the Git Bash console for git actions (it's a MINGW32 console). I re-ran the

gradew

command in the Git Bash terminal, which took a few minutes longer than from the standard CMD terminal, and voila! All working again.

Link to comment
Share on other sites

  • 7 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.