Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Problems by downloading forge


Recommended Posts

Hello.

 

I have a big problem: Since about 3 weeks now, I'm not able to download forge.

 

So to describe it a bit better, I tried to download the latest Forge 1.5.2 version, the latest 1.6.4 version, the latest 1.7.2 version and the latest 1.7.10 version. Nothing will work.

I tried to download the installer for playing with mods in Minecraft and the src to create forge mods, but nothing is working. I tried to run the gradlew.bat from that files I have downloaded before the problem appeared, but there nothing is happening, after about 30 minutes only around 11Kb's where downloaded and after 5 hours it's still saying the same.

 

I tried to download the files with and without an anti-virus tool, I tried it on a different Pc...Not working. Oh and I asked my internet provider if its a problem with them, but they can't find a problem. I tried it the download in Firefox, Google Chrome and Internet Explorer (without addons).

 

And now I'm out of ideas and my friends are out of ideas, too. But for some reason my friends are able to download it, but I'm not.

 

Here an example of what happens with forge 1.7.10:

And here my internet connection: http://www.speedtest.net/my-result/3884028504

 

The download is starting and after around 30 minutes its failing and if I'm setting up the gradle workspace then its stopping after around 30 minutes and doing nothing then.... And in that 30 minutes its downloading around 15KB's...

 

I hope someone can help me, I want to download Forge!!!!!

 

Bektor

Developer of Primeval Forest.

Link to post
Share on other sites

So, yeah, i got the same problem. Since yesterday I'm trying to download the Forge source, but i got the same problems as the Threadopener.

 

I got to download the ZIP with a trick - i paused and resumed the download (direct, not adfly) every 2 - 5 minutes (otherwise it will fail, see Openers pic).

But downloading the source, with

gradlew setupDecompWorkspace --refresh-dependencies

will work for the first few minutes, but fail after some time.

 

 

38d73e80e8.png

 

 

As you can see in this picture, it starts downloading the files, but will pause/crash after some time (it's on 22 KB since over 20 minutes now).

 

I'm running Windows 7 64 bit, having no internet connection problems (tested both, connection and installation of forge thw whole day). While i have a quite good speed with other downloads (minecraft-server.jar from Mojang, about 500kb/s - 1,5Mb/s), the speed of the download of the forge-src zip (recommended version, 1.7.10) was only about less than 100kb/s.

 

Edit:

 

So, i tried it again today, and got to about 50 KB, and got this error:

 

2560bcc945.png

 

 

Currently I'm running the same command with the additional "--stacktrace" parameter, as the message said.

I'll post the result as soon it's completed.

 

Edit 2:

 

I ran the command now with the "--info" parameter and saved the log into a file.

The console showed the same error as previously.

 

I don't think the log can really help, though i found no stacktrace, etc. But here it is:

 

 

 

 

Link to post
Share on other sites

So, yeah, i got the same problem. Since yesterday I'm trying to download the Forge source, but i got the same problems as the Threadopener.

 

I got to download the ZIP with a trick - i paused and resumed the download (direct, not adfly) every 2 - 5 minutes (otherwise it will fail, see Openers pic).

But downloading the source, with

gradlew setupDecompWorkspace --refresh-dependencies

will work for the first few minutes, but fail after some time.

 

 

38d73e80e8.png

 

 

As you can see in this picture, it starts downloading the files, but will pause/crash after some time (it's on 22 KB since over 20 minutes now).

 

I'm running Windows 7 64 bit, having no internet connection problems (tested both, connection and installation of forge thw whole day). While i have a quite good speed with other downloads (minecraft-server.jar from Mojang, about 500kb/s - 1,5Mb/s), the speed of the download of the forge-src zip (recommended version, 1.7.10) was only about less than 100kb/s.

 

Edit:

 

So, i tried it again today, and got to about 50 KB, and got this error:

 

2560bcc945.png

 

 

Currently I'm running the same command with the additional "--stacktrace" parameter, as the message said.

I'll post the result as soon it's completed.

 

Edit 2:

 

I ran the command now with the "--info" parameter and saved the log into a file.

The console showed the same error as previously.

 

I don't think the log can really help, though i found no stacktrace, etc. But here it is:

 

 

 

 

The picture in the error is exact the same error I got the first time where I tried it. (Currently it won't give the error, the task manager says nothing is happening with the network, but gradle won't give me the error anymore, it tries to download it for over 5 hours with no progress change :( )

 

So anyone who can help here?

 

EDIT: Ok, I tried now to restart the Router/FritzBox, didn't help and I tried it now again with different browers:

 

Firefox: Download failed (DE: Download fehlgeschlagen)

Google Chrome: Unknown Network Error (DE: Unbekannter Netzwerkfehler)

Internet Explorer: Over 10 hours remaining with 0% progress after 1 hour (DE: über 10 Stunden verbleiben mit 0% Fortschritt nach 1 Stunde)

 

So anyone who can help?

Developer of Primeval Forest.

Link to post
Share on other sites

First of all, thank you for your reply, Overmind.

 

So, to download the zipped "Src"-version of Forge for modding purposes (thats at leat what I am trying), I am using the gradle wrapper included into the zip.

 

1.: Downloading the Recommended-Src-Package from http://files.minecraftforge.net/

The first problem is, that the connection between the files.minecraftforge.net server and Europe (or Germany, as i see that Threadopener seems to be german too) is just horrible. Average download speed for me: 1kb/s at a maximum. So, i am able to download like 12KB of the ZIP, then i have to pause the download and resume it, to "refresh the connection" (don't know if thats technicly correct, but it seems to), otherwise the download will cancel with the messages posted by Bektor ("Download failed" in FireFox).

 

2.: Getting the actual src with the gradle wrapper

Next Problem: Getting the actual forge source with the gradle wrapper. I'm following this guide on installing forge for development purposes and the problem is in step 3. Due to the latency (if thats the problem) the wrapper wont complete the download of the first file (it seems to be that file Overmind posted the link to) and hang on after a variable amount of data (highest until now: 155KB after like half an hour or so). Sometimes it's failing after several minutes (See my recent post in this thread). And thats the main problem, i guess. since I don't know (no guide for this found) how to manually download/install all of the required files for Forge since Minecraft version 1.7 (with this "new installer"), I have to use the gradle wrapper which isn't working for me (as you can see).

 

So, here is the (with google translator) translated traceroute from Windows tracert command:

 

 

Traceroute to files.minecraftforge.net [192.95.32.52] with a maximum of 30 sections:

 

  1  120 ms    3 ms    3 ms  fritz.box [192.168.178.1]

  2    28 ms    37 ms    28 ms  217.0.118.19

  3    29 ms    33 ms    32 ms  217.0.83.118

  4    37 ms    33 ms    57 ms  217.239.39.22

  5    *        *      43 ms  fra-1-6k.de.eu [94.23.122.153]

  6    41 ms    42 ms    41 ms  rbx-g2-a9.fr.eu [91.121.131.130]

  7    43 ms    *        *    ldn-5-6k.uk.eu [91.121.128.192]

  8    *        *        *    Request timed out.

  9  127 ms  130 ms  130 ms  bhs-g2-6k.qc.ca [198.27.73.207]

10  132 ms  128 ms  242 ms  bhs-3a-6k.qc.ca [198.27.73.14]

11  125 ms  132 ms  125 ms  files.minecraftforge.net [192.95.32.52]

 

Trace completed.

 

 

 

I hope, this problem can be solved :)

 

Link to post
Share on other sites

Well, thats interesting. Maybe it's just again some <insert a random insult here> from Telekom Germany ...

Hopefully not. The interesting thing is, that I'm trying to do that since several days now, my Downloadspeedin general was at every try at least over 8Mbps and my downloadspeed from files.mineraftforge.net is just that slow. :/

 

Do you guys have any idea what could be the issue?

 

Edit: So, i just tried to download the Latest build (src) of forge (1235) - first, the download was again slow (under 500 B/s) then it just finished while only 50% were downloaded. I opened the archive and got an error, that the archive is corrupted ("Unexpected Archiveend" or something similiar).

 

I'll just restart router, computer and clear/flush my dns's. I'll reply, if that helped.

Link to post
Share on other sites

Hm, thats interisting:

 

 

The pic in English (only in my opinion important parts of the pic):

 

 

8          *      *            *    timeout of the requesting

10    57ms    *            *    ldn-5-6k.uk.eu [91.121.131.182]

11        *      *            *    timeout of the requesting

13    142ms  135ms    *    bhs-3a-6k.qc.ca [198.27.73.14]

 

 

 

And my internet connection:

http://www.speedtest.net/my-result/3893398563

 

Here the speed test of the files.minecraftforge.net website:

 

And @Th3Br1x the problem is not from Telekom Germany because I'm by Versanet (Germany) and I have the same problem. (and versanet itself wasn't able to find a problem in my connection)

 

Any idea?

Developer of Primeval Forest.

Link to post
Share on other sites

Well, I'm gonna restart my PC now.

I flushed the DNS cache of fritzbox and pc, maybe that will help.

 

Edit: Well, no. It didn't worked. Same results as before after DNS cache flush (PC & Router) and restart (PC & Router).

That's strange. So the issue is probably not on my side...

Link to post
Share on other sites

IT doesnt appear to be anything on our side, something in your ISP is screwing the routing to our servers.

Make sure you get a full route trace.

There isn't much we can do on our end.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to post
Share on other sites

None that is supported. It would be better for you to figure out why you are having issues connecting to parts of the rest of the internet.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to post
Share on other sites

None that is supported. It would be better for you to figure out why you are having issues connecting to parts of the rest of the internet.

Ok, figured it out: seems to be that I'm getting from Germany to the Servers of files.minecraftforge.net a read time out exception on 3 unknown points... (So my route trace isn't full)

Any idea how to fix it?

Developer of Primeval Forest.

Link to post
Share on other sites
  • 2 weeks later...

Ask your ISP.

Ok, I asked my ISP and well, they are saying they fixed the problem, but its still unfixed, so after the fourth try to get them on fixing the issue I gave up.

So is there a way to download the files manually, that I can pause the download and then resume it, because thats the only way that is working for me and I want not to wait 2 month to hope that the new provider I have in 2 month is better then the old one.

Developer of Primeval Forest.

Link to post
Share on other sites

Ok, but how can I use a proxy that the gradlew.bat file can download all needed files from the files.minecraftforge.net servers without getting a timeout?

 

EDIT:

By downloading the forge src with help from free-proxyserver.com the download is working and really fast, click and finished ;)

Now I need only to know how to do this with the things that the gradlwe.bat needs to download or if I need to download them manually where I need then to put this files that the gradlew.bat finds them and can work with them.

Developer of Primeval Forest.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • I am trying to make a Biome(and plan to make multiple more) But I can't figure out what's wrong with my registry, It gives me a red line for this code BIOMES.register("chocolate_forest", ChocolateForest::new); it tells me that "no instance(s) of type variable(s) exist so that ChocolateForest conforms to Biome inference variable I has incompatible bounds: equality constraints: Biome lower bounds: ChocolateForest" here's the full code public class ModBiomes { public static final DeferredRegister<Biome> BIOMES = DeferredRegister.create(ForgeRegistries.BIOMES, chocolate.MODID); public static void init() { BIOMES.register(FMLJavaModLoadingContext.get().getModEventBus()); } public static final RegistryObject<Biome> CHOCOLATE_FOREST = BIOMES.register("chocolate_forest", ChocolateForest::new); } I have tried to extend Biome to my ChocolateForest class as was shown in an 1.15 tutorial, but I guess something was switched around since then as it tells me that Biome doesn't have a default constructor to take from. I have also tried looking for something similar and possibly renamed in the code but without any luck. And heres my ChocolateForest class just in case you need it. public class ChocolateForest{ protected ChocolateForest() { super(); } protected void configureBiome(Biome.Builder builder) { builder.precipitation(Biome.RainType.RAIN).category(Biome.Category.FOREST).depth(-0.1F).temperature(0.6F).downfall(0.9F); builder.setEffects((new BiomeAmbience.Builder()).setWaterColor(329011).setWaterFogColor(329011).setFogColor(12638463).withSkyColor(5).withGrassColor(0x85CE71).withFoliageColor(0x63BF66).build()); } protected void configureGeneration(BiomeGenerationSettings.Builder builder) { builder.withSurfaceBuilder(ConfiguredSurfaceBuilders.GRASS); DefaultBiomeFeatures.withOverworldOres(builder); DefaultBiomeFeatures.withCavesAndCanyons(builder); DefaultBiomeFeatures.withLavaAndWaterLakes(builder); DefaultBiomeFeatures.withMonsterRoom(builder); } protected void configureMobSpawns(MobSpawnInfo.Builder builder) { builder.withSpawner(EntityClassification.MONSTER, new MobSpawnInfo.Spawners(EntityType.SHEEP, 12, 4, 4)); builder.withSpawner(EntityClassification.CREATURE, new MobSpawnInfo.Spawners(EntityType.PIG, 10, 4, 4)); builder.withSpawner(EntityClassification.CREATURE, new MobSpawnInfo.Spawners(EntityType.CHICKEN, 10, 4, 4)); builder.withSpawner(EntityClassification.CREATURE, new MobSpawnInfo.Spawners(EntityType.COW, 8, 4, 4)); builder.withSpawner(EntityClassification.AMBIENT, new MobSpawnInfo.Spawners(EntityType.BAT, 10, 8, 8)); builder.withSpawner(EntityClassification.MONSTER, new MobSpawnInfo.Spawners(EntityType.SPIDER, 100, 4, 4)); builder.withSpawner(EntityClassification.MONSTER, new MobSpawnInfo.Spawners(EntityType.ZOMBIE, 95, 4, 4)); builder.withSpawner(EntityClassification.MONSTER, new MobSpawnInfo.Spawners(EntityType.ZOMBIE_VILLAGER, 5, 1, 1)); builder.withSpawner(EntityClassification.MONSTER, new MobSpawnInfo.Spawners(EntityType.SKELETON, 100, 4, 4)); builder.withSpawner(EntityClassification.MONSTER, new MobSpawnInfo.Spawners(EntityType.CREEPER, 100, 4, 4)); builder.withSpawner(EntityClassification.MONSTER, new MobSpawnInfo.Spawners(EntityType.SLIME, 100, 4, 4)); builder.withSpawner(EntityClassification.MONSTER, new MobSpawnInfo.Spawners(EntityType.ENDERMAN, 10, 1, 4)); builder.withSpawner(EntityClassification.MONSTER, new MobSpawnInfo.Spawners(EntityType.WITCH, 5, 1, 1)); builder.withSpawner(EntityClassification.MONSTER, new MobSpawnInfo.Spawners(ModEntities.CHOCOLATE_SLIME.get(), 100, 3, 7)); } } I haven't completely finished it as of yet because I've been trying to work out the registry problem.  
    • Hey! When logging onto my new Valhelsia server I got this error message. Unexpected custom data from client. Please help. Here is the console data. It is on apex server hosting. Please help.   14.04 18:59:12 [Server] Netty Epoll Server IO #8/INFO [co.li.co.ConfigSyncManager/]: Skipping config sync, No mods have registered a syncable config. 14.04 18:59:13 [Server] User Authenticator #3/INFO UUID of player Julesiac669 is fbbbf514-f3d4-49f1-8847-134097e88ddd 14.04 18:59:13 [Server] Netty Epoll Server IO #8/ERROR [ne.mi.fm.ne.si.IndexedMessageCodec/SIMPLENET]: Received empty payload on channel fml:handshake 14.04 18:59:13 [Server] Netty Epoll Server IO #8/INFO Disconnecting com.mojang.authlib.GameProfile@41363519[id=fbbbf514-f3d4-49f1-8847-134097e88ddd,name=Julesiac669,properties={textures=[com.mojang.authlib.properties.Property@4e635308]},legacy=false] (/67.180.183.224:56122): Unexpected custom data from client 14.04 18:59:13 [Disconnect] User com.mojang.authlib.GameProfile@41363519[id=fbbbf514-f3d4-49f1-8847-134097e88ddd,name=Julesiac669,properties={textures=[com.mojang.authlib.properties.Property@4e635308]},legacy=false] (/67.180.183.224:56122) has disconnected, reason: Unexpected custom data from client
    • How do you make sure the same mods are installed on your client? I have the same issue please help.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.