Jump to content

Forge 1230 causes 4 gig server to struggle


danners68
 Share

Recommended Posts

on 1230 i tried without any mods, the server struggles to run on 4 gb, i assign 4.5 of 16gb to client and 4 to server running on the same machine, until i try to join the world everything is fine, SSP seems to work normally (in that i haven't seen any significant issues come up) as soon as i join the MP world the TPS drops to peak at 5 and the console is spammed with "[server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 6502ms behind, skipping 130 tick(s)" if you need logs to back this up lemmie know which ones you need, untill recently i was running an old version of Cauldron without any issues, since running default forge removes the spigot/bukkit additions i figured if anything i'd get more power, from it,

 

just to clarify, Can't Keep Up Message Comes From 4 of 16gig local host MOD FREE server,

 

the main issue with 1230 that made me look at mod free was an 80 mod 4 gig dedicated modpack server (links for witnessing can be provided)

 

Again, if logs are needed please tell me which you want and ill get them for you

 

This Issue is similar to http://www.minecraftforge.net/forum/index.php/topic,24296.0.html

Link to comment
Share on other sites

Sorry for the newby question, Profiler?

 

Unfortunatly the FML log from the server is just a little bit too big for pastebin,

 

Server Latest Log: http://pastebin.com/9X2iYcBn

 

As I've been going i've been playing about trying to see if its me doing something wrong........apparently the /debug command isn't a reliable measure in 1.7 as it spams its profile stuff in vanilla so it looks like i may have been wrong to blame forge and its could actually be a mod update that had hidden itself away,

 

the log is also from 1236 on the dedicated as i figured i'd also try a newer version just to see what might happen,

 

sorry if i've wasted important time, i've just never come across this issue with cauldron and i misinterpreted the debug bumpf, at the same time it might be something forge can rectify....

 

 

EDIT: Seeing What Happens When I Remove The 4 main updated mods since dropping cauldron - watch it be one of them

 

for the record the mods are: Thaumcraft 4.2.1.4 (and thaumic tinkerer due to dependancy), Applied Energistics2 RV1 S 1, Spawn Commands and Server Tools (The Last 2 added to provide some degree of bukkit in forge)

 

 

EDIT2: Having Removed All Changed Files (Save Forge) it still seems to struggle which as i've already said cauldron never made a fuss about, an avenue i havent yet looked at is possibly the host doing something different on the back end, For peice of mind on my part i've just removed all mods from the server and am attempting to rule out forge as the cause

Link to comment
Share on other sites

mod free on the host DOES cause this issue, acquireing Pastebins of logs Now!!

 

FML Latest: http://pastebin.com/2KTJvq4q

 

Not overly sure what can be pulled from that so heres the vanilla accompanying latest log: http://pastebin.com/jpkCm5Tb

 

unfortunatly on the local host i was relying on the vanilla debug command and learnt my lesson from that,

 

if forge is not actually at fault i will of course appologise and hide my face from these forums untill i can cleanse my guilt of false accusations and will instead focus on my host provider

 

thank you so much for sticking with me this far despite my apparent lack of  knowledge of what I'm doing... i assure you its not true......much

Link to comment
Share on other sites

the world was wiped prior to that log being acquired,

 

i apologise for any confusion, i dont actually control how much ram is assigned, the 4 of 16 was for the initial comments of local host to remove the first responce i saw coming of "How much ram are you trying to run the system with?"

 

I pay for 4gig from my dedicated host so i replicated on my local machine and figured that since the dedicated would benefit from the tests that i would utilise the files and what not from there,

 

as for why they're on windows.... I never asked them, Never had a reason to...

 

suppose then now would be a good time to apologise for any and all false accusations, actual, implied or otherwise, my head is hung in shame and I will begin my queries of the GSP and see what they can't decipher,

 

 

Thank you for your time and putting up with me, I don't think there are enough sorry's in the world to make up for me

Link to comment
Share on other sites

all recent tests (tonights) point to be hosted only, but it did lagg last night on my local (i swear!!!) though with all these repeat tests that's beginning to look like a hiccup rather than an actual lag spike, which couple with all the assistance points to this being a redundant thread cause by a lack of testing on my part :/

 

if you could point me to a profiler I can provide that, but as above...it looks more like this is a GSP issue rather than a forge problem...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.