Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Problem with Vanilla server Modding


Sweetz
 Share

Recommended Posts

Hello

 

First, sorry for my bad English, and second, I've got a problem with my vanilla server, downloaded from minecraft.net/download ... I don't know what's the matter, but when i want to use mods into the server, the "mods" folder doesnt appear, and I put the "minecraftforge-universal-4.1.1.251"! If someone can help me, answer soon :) If you respond in Spanish, better

 

My Forge version:

Forge Version: 4.1.1

Minecraft Version: 1.3.2

Link to comment
Share on other sites

Just use the jar, You can execute it like the exe file. Don't use the minecraft_server.exe for anything when you're trying to mod the server.

Don't ask for support per PM! They'll get ignored! | If a post helped you, click the "Thank You" button at the top right corner of said post! |

mah twitter

This thread makes me sad because people just post copy-paste-ready code when it's obvious that the OP has little to no programming experience. This is not how learning works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • I am running forge-1.16.1-32.0.108-mdk and all my code SEEMs to be legit but when I run, the loading screen pops up and gets through the Mojang intro but immediately closes  Java 8 minecraft 1.16.1    ---- Minecraft Crash Report ---- // I feel sad now :( Time: 10/19/21 10:50 AM Description: Rendering overlay net.minecraft.util.ResourceLocationException: Non [a-z0-9_.-] character in namespace of location: .DS_Store:sounds.json at net.minecraft.util.ResourceLocation.<init>(SourceFile:38) ~[?:?] {re:classloading} at net.minecraft.util.ResourceLocation.<init>(SourceFile:50) ~[?:?] {re:classloading} at net.minecraft.client.audio.SoundHandler.prepare(SoundHandler.java:56) ~[?:?] {re:classloading,pl:runtimedistcleaner:A} at net.minecraft.client.audio.SoundHandler.prepare(SoundHandler.java:34) ~[?:?] {re:classloading,pl:runtimedistcleaner:A} at net.minecraft.client.resources.ReloadListener.func_215270_b(SourceFile:11) ~[?:?] {re:classloading} at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1590) ~[?:1.8.0_111] {} at java.util.concurrent.CompletableFuture$AsyncSupply.exec(CompletableFuture.java:1582) ~[?:1.8.0_111] {} at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289) ~[?:1.8.0_111] {} at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056) ~[?:1.8.0_111] {} at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692) ~[?:1.8.0_111] {} at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:157) ~[?:1.8.0_111] {} A detailed walkthrough of the error, its code path and all known details is as follows: --------------------------------------------------------------------------------------- -- Head -- Thread: Render thread Stacktrace: at net.minecraft.client.renderer.GameRenderer.updateCameraAndRender(GameRenderer.java:473) -- Overlay render details -- Details: Overlay name: net.minecraft.client.gui.ResourceLoadProgressGui Stacktrace: at net.minecraft.client.renderer.GameRenderer.updateCameraAndRender(GameRenderer.java:473) at net.minecraft.client.Minecraft.runGameLoop(Minecraft.java:951) at net.minecraft.client.Minecraft.run(Minecraft.java:582) at net.minecraft.client.main.Main.main(Main.java:184) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at net.minecraftforge.userdev.FMLUserdevClientLaunchProvider.lambda$launchService$0(FMLUserdevClientLaunchProvider.java:55) at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:37) at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:54) at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:72) at cpw.mods.modlauncher.Launcher.run(Launcher.java:81) at cpw.mods.modlauncher.Launcher.main(Launcher.java:65) at net.minecraftforge.userdev.LaunchTesting.main(LaunchTesting.java:105) -- System Details -- Details: Minecraft Version: 1.16.1 Minecraft Version ID: 1.16.1 Operating System: Mac OS X (x86_64) version 10.16 Java Version: 1.8.0_111, Oracle Corporation Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation Memory: 469098616 bytes (447 MB) / 948961280 bytes (905 MB) up to 1908932608 bytes (1820 MB) CPUs: 4 JVM Flags: 1 total; -Xss1M ModLauncher: 6.1.3+75+master.851120a ModLauncher launch target: fmluserdevclient ModLauncher naming: mcp ModLauncher services: /mixin-0.8.jar mixin PLUGINSERVICE /eventbus-3.0.3-service.jar eventbus PLUGINSERVICE /forge-1.16.1-32.0.108_mapped_snapshot_20200514-1.16-launcher.jar object_holder_definalize PLUGINSERVICE /forge-1.16.1-32.0.108_mapped_snapshot_20200514-1.16-launcher.jar runtime_enum_extender PLUGINSERVICE /accesstransformers-2.2.0-shadowed.jar accesstransformer PLUGINSERVICE /forge-1.16.1-32.0.108_mapped_snapshot_20200514-1.16-launcher.jar capability_inject_definalize PLUGINSERVICE /forge-1.16.1-32.0.108_mapped_snapshot_20200514-1.16-launcher.jar runtimedistcleaner PLUGINSERVICE /mixin-0.8.jar mixin TRANSFORMATIONSERVICE /forge-1.16.1-32.0.108_mapped_snapshot_20200514-1.16-launcher.jar fml TRANSFORMATIONSERVICE FML: 32.0 Forge: net.minecraftforge:32.0.108 FML Language Providers: javafml@32.0 minecraft@1 Mod List: client-extra.jar Minecraft {minecraft@1.16.1 NONE} forge-1.16.1-32.0.108_mapped_snapshot_20200514-1.16.jar Forge {forge@32.0.108 NONE} resources Example Mod {examplemod@NONE NONE} Launched Version: MOD_DEV Backend library: LWJGL version 3.2.1 build 12 Backend API: Intel(R) Iris(TM) Plus Graphics OpenGL Engine (1x6x8 (fused) LP GL version 2.1 INTEL-16.5.2, Intel Inc. GL Caps: Using framebuffer using ARB_framebuffer_object extension Using VBOs: Yes Is Modded: Definitely; Client brand changed to 'forge' Type: Client (map_client.txt) Resource Packs: Current Language: English (US) CPU: 4x Intel(R) Core(TM) i3-1000NG4 CPU @ 1.10GHz  
    • Currently, I have a init package with my ModBlocks, ModItems, ModEntityTypes, etc. abstract classes that initialize the registry objects as class fields. Does it suffice to use @ObjectHolder("modid") above the class name in each class? My runClient has worked so far without these annotations... are these necessary for build, then? All of my registry objects are currently public static. Should I use final on all objects? Also, regarding the original topic, I updated my last post with the inheritance issue I am running into.
    • Guys HELP!! I get an error message when i launch minecraft Forge 1.17.1 . it only happens with this version and this problem never happened to me in any other versions. I tried to update this version till last one 37.0.97. Can anyone help me?? i would be so glad.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.