Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Eclipse wont open the minecraft project.


Recommended Posts

I installed forge following these instructions:




However, when I open eclipse, and point the workspace folder to "forge-1.7.10-\eclipse", I only see this:




The \eclipse folder only contains a .metadata folder, which then contains these files:




After trying to do a troubleshoot myself, I found out that the whole forge folder does not contain any of the decompiled minecraft files. After searching a bit, I found them in a tmp folder which suggests to me that those files were only meant to be temporary.


In the folder "forge-1.7.10-\build\tmp\expandedArchives" I found these two folders, which then contained the source files of minecraft (at least I think they did).



So my idea is that gradlew can not copy those files to the right place, or something similar. I'm not an expert in this, so it is of course possible that I'm completely wrong.


Could anyone help me please?

Link to comment
Share on other sites

The decompiled minecraft files do not end up in your forge directory, they are stored in the central gradle cache so they can be shared across different workspaces.

If you followed the steps exactly (do not delete anything from the extracted download, run gradlew eclipse) then this will not happen.


Edit: Just tried it out, it works just fine.

Link to comment
Share on other sites

I'm not sure what I did wrong then. Let my write down the steps I went through.


I downloaded the 1.7.10 latest src from here: http://files.minecraftforge.net/


After that, I extracted the downloaded package, went into the extracted folder, and opened a command prompt there.


Then, I wrote in "gradlew setupDecompWorkspace --refresh-dependencies", and after it completed, I typed in "gradlew eclipse".


After that, I opened eclipse, pointed the workspace to the eclipse folder in the extracted forge folder, and then I got that error.


Am I doing something wrong?

Link to comment
Share on other sites

I tried it again and again countless times, still no luck.


The weird thing is, that the wiki say the process might take up to 10 minutes, but for me it only takes about half a minute.


This is how my cmd window looks after running the command you suggested:




It say SKIPPED for a lot of things, that might be a problem, I'm not sure.

Link to comment
Share on other sites

The SKIPPED is normal and is actually a feature. When gradle has done a task already in the past, it does not need to do it again in the future, making the process faster.


The problem here is probably your username (or rather the file path). Choose a path that does not contain non-ascii characters.

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.