Jump to content

[1.8] Having trouble setting up a forge development environment


Recommended Posts

I used gradle to install the forge development environment  but when i try to run Minecraft through eclipse this happens:



[pre][19:35:33] [main/INFO] [GradleStart]: Extra: []

[19:35:33] [main/INFO] [GradleStart]: Running with arguments: [--userProperties, {}, --accessToken, {REDACTED}, --assetIndex, 1.8, --assetsDir, C:/Documents and Settings/Eric/.gradle/caches/minecraft/assets, --version, 1.8, --tweakClass, net.minecraftforge.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.GradleStartCommon$GradleStartTweaker]

[19:35:33] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker

[19:35:33] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker

[19:35:33] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.GradleStartCommon$GradleStartTweaker

[19:35:33] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker

[19:35:33] [main/INFO] [FML]: Forge Mod Loader version for Minecraft 1.8 loading

[19:35:33] [main/INFO] [FML]: Java is Java HotSpot Client VM, version 1.7.0_71, running on Windows XP:x86:5.1, installed at C:\Program Files\Java\jdk1.7.0_71\jre

[19:35:33] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation

[19:35:34] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.GradleStartCommon$GradleStartTweaker

[19:35:34] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.fml.relauncher.FMLCorePlugin

[19:35:34] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin

[19:35:34] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker

[19:35:34] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLDeobfTweaker

[19:35:34] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker

[19:35:34] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker

[19:35:34] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper

[19:35:34] [main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!

[19:35:37] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing

[19:35:37] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper

[19:35:37] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLDeobfTweaker

[19:35:38] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.TerminalTweaker

[19:35:38] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.TerminalTweaker

[19:35:38] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}

[19:35:39] [Client thread/INFO]: Setting user: Player822

[19:35:44] [Client thread/INFO]: LWJGL Version: 2.9.1

[19:35:46] [Client thread/INFO] [MinecraftForge]: Attempting early MinecraftForge initialization

[19:35:46] [Client thread/INFO] [FML]: MinecraftForge v11.14.1.1320 Initialized

[19:35:46] [Client thread/INFO] [FML]: Replaced 204 ore recipies

[19:35:46] [Client thread/INFO] [MinecraftForge]: Completed early MinecraftForge initialization

[19:35:46] [Client thread/INFO] [FML]: Searching C:\UselessThings\eclipse\mods for mods

[19:35:51] [Client thread/INFO] [FML]: Forge Mod Loader has identified 4 mods to load

[19:35:52] [Client thread/INFO] [FML]: Attempting connection with missing mods [mcp, FML, Forge, examplemod] at CLIENT

[19:35:52] [Client thread/INFO] [FML]: Attempting connection with missing mods [mcp, FML, Forge, examplemod] at SERVER

[19:35:52] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Example Mod

[19:35:53] [Client thread/INFO] [FML]: Processing ObjectHolder annotations

[19:35:53] [Client thread/INFO] [FML]: Found 384 ObjectHolder annotations

[19:35:53] [Client thread/INFO] [FML]: Configured a dormant chunk cache size of 0

[19:35:53] [Client thread/INFO] [FML]: Applying holder lookups

[19:35:53] [Client thread/INFO] [FML]: Holder lookups applied

[19:35:54] [sound Library Loader/INFO]: Starting up SoundSystem...

[19:35:54] [Thread-7/INFO]: Initializing LWJGL OpenAL

[19:35:54] [Thread-7/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)

[19:35:55] [Thread-7/INFO]: OpenAL initialized.

[19:35:55] [sound Library Loader/INFO]: Sound engine started

[19:35:59] [Client thread/INFO]: Created: 512x512 textures-atlas

[19:36:01] [Client thread/INFO] [sTDOUT]: [com.example.examplemod.ExampleMod:init:18]: DIRT BLOCK >> tile.dirt

[19:36:01] [Client thread/INFO] [FML]: Forge Mod Loader has successfully loaded 4 mods

[19:36:01] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Example Mod

[19:36:01] [Client thread/INFO]: SoundSystem shutting down...


# A fatal error has been detected by the Java Runtime Environment:


#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x53be213a, pid=3428, tid=3496


# JRE version: Java SE Runtime Environment (7.0_71-b14) (build 1.7.0_71-b14)

# Java VM: Java HotSpot Client VM (24.71-b01 mixed mode windows-x86 )

# Problematic frame:

# C  [CT_OAL.DLL+0x1213a]


# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows


# An error report file with more information is saved as:

# C:\UselessThings\eclipse\hs_err_pid3428.log


# If you would like to submit a bug report, please visit:


# The crash happened outside the Java Virtual Machine in native code.

# See problematic frame for where to report the bug.




I'm running Windows XP 32 Bit with 4GB RAM and Java 7 if that matters.


Please help

Link to comment
Share on other sites

Try re-installing your Java JDK and JRE, it seems like your Current OpenAL driver is either incompatible or something else on your PC is causing a conflict.


Don't know about you, but I'd consider upgrading to Windows 7 or 8.1, Windows XP support is long gone :(


Googling a bit Further it seems like that the Driver is Proprietary of CreativeTechnologies, so if you have a Creative Sound card look for updated drivers or re-install your current drivers.

I require Java, both the coffee and the code :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hello! I have recently purchased a new computer and cannot download Optifine or Forge. The issue I am having is that the Java program 'javaw.exe' does not seem to open .jar files for me. As far as I can tell, I cannot open .jar files at all. The trouble-shooting I have tried so far is that I have un-downloaded and re-downloaded Java and that has not fixed it. I have followed the pathway to 'open with->choose another app->choose an app on your pc->Program Files (x86)->Java->jre-1.8->bin. and from inside bin I have tried opening these programs with each and every java application in there assuming I may have been wrong about which one I need to use. Still no luck. From there I checked to make sure that Java was allowed through my firewall and have seen no instances of any application with Java in the name anywhere in the list of apps to let through fire wall. I'm unsure of what to try next, so I would absolutely love help figuring out why my computer is not letting me open .jar files. Specifically these ones that I know are meant to open as installers. Any ideas are appreciated. Thanks in advance!
    • Thanks again for your anwsers, I tested without practical_plushies_mobs, practical_plushies_animals and dark-waters and now red forge loading screen appears however few seconds later it crashed again.  How I could put my file codes in my minecraft folder? log crash report
    • I have a modded mob that when I try to spawn it, it won't spawn and a crash happens (doesn't crash whole game though) and it says "Duplicate id value for 16!" and points to the mob's defineSynchedData method. Anyone know what's going on? Here's the method it was pointing to: @Override protected void defineSynchedData() { super.defineSynchedData(); this.entityData.define(MY_BOOLEAN_DATA, false); }  
    • Click Here -- Official Website -- Order Now ➡️● For Order Official Website - https://sale365day.com/get-restore-cbd-gummies ➡️● Item Name: — Restore CBD Gummies ➡️● Ingredients: — All Natural ➡️● Incidental Effects: — NA ➡️● Accessibility: — Online ✅HUGE DISCOUNT ! HURRY UP! ORDER NOW!✅ ✅HUGE DISCOUNT ! HURRY UP! ORDER NOW!✅ ✅HUGE DISCOUNT ! HURRY UP! ORDER NOW!✅   Restore CBD Gummies is a strong contender for the top gummy of the year. Due to its strong concentration of CBD and purity, you will achieve excellent results while using it if you stick with this solution. Most people who suffer from constant pain, anxiety, depression, and insomnia are currently solving these problems, and you can be the next one. All you need to do is give Restore CBD Gummies a chance and let this fantastic product change your life. Visit the official website to order your Restore CBD Gummies today! After reading Restore CBD Gummies reviews, we now know that knee replacement surgeries are not the only option to treat knee pain, inflammation, joint discomfort, and stiffness. These CBD gummies can heal your joints and provide you relief from pain and stress so that you can lead a happy life. Prosper Wellness Restore CBD Gummies can improve joint mobility and improve knee health so that you can remain healthy. Exclusive Details: *Restore CBD Gummies* Read More Details on Official Website #USA! https://www.facebook.com/claritox.pro.unitedstates https://www.facebook.com/illudermaUCAAU https://www.facebook.com/awakenxtusa https://groups.google.com/a/chromium.org/g/chromium-reviews/c/8NMUVKgd-FA https://groups.google.com/g/microsoft.public.project/c/0UZQQKOZF58 https://groups.google.com/g/comp.editors/c/r_BcRRrvGhs https://medium.com/@illuderma/illuderma-reviews-fda-approved-breakthrough-or-clever-skincare-scam-36088ae82c3e https://medium.com/@claritoxpros/claritox-pro-reviews-legitimate-or-deceptive-dr-warns-of-potential-dangers-d5ff3867b34d https://medium.com/@thedetoxall17/detoxall-17-reviews-scam-alert-or-legit-detox-solution-customer-report-inside-1fd4c6920c9e https://groups.google.com/a/chromium.org/g/chromium-reviews/c/RONgLAl6vwM https://groups.google.com/g/microsoft.public.project/c/TgtOMRFt6nQ https://groups.google.com/g/comp.editors/c/fUfg0L2YfzU https://crediblehealths.blogspot.com/2023/12/revitalize-with-restore-cbd-gummies.html https://community.weddingwire.in/forum/restore-cbd-gummies-uncovered-fda-approved-breakthrough-or-deceptive-wellness-scam--t206896 https://restorecbdgummies.bandcamp.com/album/restore-cbd-gummies-uncovered-fda-approved https://my-restore-cb.clubeo.com/page/restore-cbd-gummies-reviews-customer-alert-drs-warning-genuine-or-wellness-hoax.html https://my-restore-cb.clubeo.com/page/restore-cbd-gummies-reviews-scam-alert-or-legit-relief-solution-customer-report-inside.html https://medium.com/@restorecbdgum/restore-cbd-gummies-reviews-warning-2023-update-real-or-a-powerful-relief-hoax-caution-350b61472a3f https://devfolio.co/@restorecbdgum https://restore-cbd-gummies-9.jimdosite.com/ https://devfolio.co/project/new/restore-cbd-gummies-reviews-scam-or-legit-custo-7bd6 https://groups.google.com/a/chromium.org/g/chromium-reviews/c/R0enUCvfs8s https://groups.google.com/g/microsoft.public.project/c/miJma2yOMDQ https://groups.google.com/g/comp.os.vms/c/S_HG94aaKFo https://groups.google.com/g/mozilla.dev.platform/c/qb6WpMUYLu0 https://hellobiz.in/restore-cbd-gummies-reviews-warning-2023-update-genuine-wellness-or-another-hoax-caution-211948390 https://pdfhost.io/v/ir5l.cseV_Restore_CBD_Gummies_Reviews_WARNING_2023_Update_Genuine_Wellness_or_Another_Hoax_Caution https://odoe.powerappsportals.us/en-US/forums/general-discussion/7c8b3f62-6d96-ee11-a81c-001dd8066f2b https://gamma.app/public/Restore-CBD-Gummies-ssh57nprs2l6xgq https://restorecbdgummies.quora.com/ https://www.facebook.com/RestoreCBDGummiesUS https://groups.google.com/g/restorecbdgum/c/9KHVNp3oy3E https://sites.google.com/view/restorecbdgummiesreviewsfdaapp/home https://experiment.com/projects/pjyhtzvpcvllopsglcph/methods https://lookerstudio.google.com/reporting/e5e9f52d-ae52-4c84-96c6-96b97932215f/page/XtkkD https://restore-cbd-gummies-reviews-is-it-a-sca.webflow.io/ https://colab.research.google.com/drive/1xZoc6E2H-jliBSZRVl0vnVqrkc3ix4YU https://soundcloud.com/restore-cbd-gummies-821066674/restore-cbd-gummies https://www.eventcreate.com/e/restore-cbd-gummies-reviews https://restorecbdgummies.godaddysites.com/ https://sketchfab.com/3d-models/restore-cbd-gummies-reviews-fda-approved-7cfe1fb8b003481c81689dd9489d2812 https://www.scoop.it/topic/restore-cbd-gummies-by-restore-cbd-gummies-9 https://events.humanitix.com/restore-cbd-gummies https://communityforums.atmeta.com/t5/General-Development/Restore-CBD-Gummies/m-p/1113602
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.