Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

1.8 Custom Flower not rendiring when placed...looks like block


Recommended Posts

Need to see your main mod file, too.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites

And oh yeah, the block's .json model file.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites

@Override

public EnumFlowerColor getBlockType() {

// TODO Auto-generated method stub

return BlockFlower.EnumFlowerColor.YELLOW;

}

 

When it's yellow it shows this  message: [09:01:17] [Client thread/ERROR] [FML]: Model definition for location expansion:Blue_Flower#type=dandelion not found

 

 

When yellow is replaced with RED it shows 9 error "Type" with different vanila flowers definition plus it shows in creative inventory 8 additional Flowers that have same name but looking at code they look like they are vanila ones.

When is changed to yellow it just shows that errow asking for dandelion type....it maybe have some issues with this :return BlockFlower.EnumFlowerColor.YELLOW;

 

 

 

 

Link to post
Share on other sites

I think this is about metadata...since when i use BlockFlower.EnumFlowerColor.YELLOW; i get my flower with this error :

[Client thread/ERROR] [FML]: Model definition for location expansion:Blue_Flower#type=dandelion not found

 

When it's changed to RED it gives me more errores for vanila flowers with my same name.

 

HOw to go around that?

Link to post
Share on other sites

You're using vanilla's BlockStates and not using the same model definitions.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hi! I had this mod that adds new chest, and when i launch it in a single player world it works good. But when i try to load it on a server, i receive this error: 13.05 11:48:37 [Server] modloading-worker-11/INFO [ne.mi.co.ForgeMod/FORGEMOD]: Forge mod loading, version 36.1.13, for MC 1.16.5 with MCP 20210115.111550 13.05 11:48:37 [Server] modloading-worker-11/INFO [ne.mi.co.MinecraftForge/FORGE]: MinecraftForge v36.1.13 Initialized 13.05 11:48:37 [Server] modloading-worker-2/ERROR [ne.mi.fm.ja.FMLModContainer/LOADING]: Failed to create mod instance. ModID: tenchest, class com.ike.tenchest.TenChest 13.05 11:48:37 [Server] INFO java.lang.BootstrapMethodError: java.lang.IllegalAccessError: no such constructor: com.ike.tenchest.minichest.MiniChest.<init>()void/newInvokeSpecial 13.05 11:48:37 [Server] INFO at com.ike.tenchest.Blocks.<clinit>(Blocks.java:63) ~[tenchest:1.0] {re:classloading,pl:runtimedistcleaner:A} 13.05 11:48:37 [Server] INFO at com.ike.tenchest.TenChest.<init>(TenChest.java:54) ~[tenchest:1.0] {re:classloading} 13.05 11:48:37 [Server] INFO at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at java.lang.Class.newInstance(Class.java:442) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at net.minecraftforge.fml.javafmlmod.FMLModContainer.constructMod(FMLModContainer.java:81) ~[forge:36.1] {re:classloading} 13.05 11:48:37 [Server] INFO at net.minecraftforge.fml.ModContainer.lambda$buildTransitionHandler$4(ModContainer.java:120) ~[forge:?] {re:classloading} 13.05 11:48:37 [Server] INFO at java.util.concurrent.CompletableFuture$AsyncRun.run(CompletableFuture.java:1640) [?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at java.util.concurrent.CompletableFuture$AsyncRun.exec(CompletableFuture.java:1632) [?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289) [?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056) [?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692) [?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:175) [?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO Caused by: java.lang.IllegalAccessError: no such constructor: com.ike.tenchest.minichest.MiniChest.<init>()void/newInvokeSpecial 13.05 11:48:37 [Server] INFO at java.lang.invoke.MethodHandleNatives.linkMethodHandleConstant(MethodHandleNatives.java:483) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO ... 15 more 13.05 11:48:37 [Server] INFO Caused by: java.lang.NoClassDefFoundError: net/minecraft/tileentity/IChestLid 13.05 11:48:37 [Server] INFO at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at java.lang.ClassLoader.defineClass(ClassLoader.java:756) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:138) ~[modlauncher-8.0.9.jar:?] {re:classloading} 13.05 11:48:37 [Server] INFO at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:98) ~[modlauncher-8.0.9.jar:?] {re:classloading} 13.05 11:48:37 [Server] INFO at java.lang.ClassLoader.loadClass(ClassLoader.java:351) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at net.minecraftforge.eventbus.EventSubclassTransformer.buildEvents(EventSubclassTransformer.java:62) ~[eventbus-4.0.0.jar:?] {} 13.05 11:48:37 [Server] INFO at net.minecraftforge.eventbus.EventSubclassTransformer.transform(EventSubclassTransformer.java:44) ~[eventbus-4.0.0.jar:?] {} 13.05 11:48:37 [Multicraft] Skipped 83 lines due to rate limit (30/s) 13.05 11:48:37 [Server] main/FATAL [ne.mi.fm.ModLoader/LOADING]: Failed to complete lifecycle event CONSTRUCT, 1 errors found 13.05 11:48:37 [Server] main/FATAL [ne.mi.co.ForgeMod/]: Preparing crash report with UUID 449cf277-bc9c-4a21-b16a-3f07d0d4e0c4 13.05 11:48:37 [Server] main/INFO [STDOUT/]: [net.minecraft.crash.CrashReport:func_85057_a:196]: Negative index in crash report handler (16/18) 13.05 11:48:37 [Server] main/FATAL [ne.mi.fm.se.ServerModLoader/]: Crash report saved to ./crash-reports/crash-2021-05-13_11.48.37-fml.txt 13.05 11:48:37 [Server] INFO ---- Minecraft Crash Report ---- 13.05 11:48:37 [Server] INFO // Daisy, daisy... 13.05 11:48:37 [Server] INFO Time: 5/13/21 11:48 AM 13.05 11:48:37 [Server] INFO Description: Mod loading error has occurred 13.05 11:48:37 [Server] INFO java.lang.Exception: Mod Loading has failed 13.05 11:48:37 [Server] INFO at net.minecraftforge.fml.CrashReportExtender.dumpModLoadingCrashReport(CrashReportExtender.java:85) ~[forge:?] {re:classloading} 13.05 11:48:37 [Server] INFO at net.minecraftforge.fml.server.ServerModLoader.load(ServerModLoader.java:51) ~[forge:?] {re:classloading} 13.05 11:48:37 [Server] INFO at net.minecraft.server.Main.main(Main.java:95) ~[?:?] {re:classloading} 13.05 11:48:37 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_292] {} 13.05 11:48:37 [Server] INFO at net.minecraftforge.fml.loading.FMLServerLaunchProvider.lambda$launchService$0(FMLServerLaunchProvider.java:51) ~[forge_1.16.5.jar:36.1] {} 13.05 11:48:37 [Server] INFO at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:37) [modlauncher-8.0.9.jar:?] {} 13.05 11:48:37 [Server] INFO at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:54) [modlauncher-8.0.9.jar:?] {} 13.05 11:48:37 [Server] INFO at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:72) [modlauncher-8.0.9.jar:?] {} 13.05 11:48:37 [Server] INFO at cpw.mods.modlauncher.Launcher.run(Launcher.java:82) [modlauncher-8.0.9.jar:?] {} 13.05 11:48:37 [Server] INFO at cpw.mods.modlauncher.Launcher.main(Launcher.java:66) [modlauncher-8.0.9.jar:?] {} 13.05 11:48:37 [Server] INFO at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63) [forge_1.16.5.jar:?] {} 13.05 11:48:37 [Server] INFO at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60) [forge_1.16.5.jar:?] {} 13.05 11:48:37 [Server] INFO at net.minecraftforge.server.ServerMain.main(ServerMain.java:57) [forge_1.16.5.jar:?] {} 13.05 11:48:37 [Server] INFO A detailed walkthrough of the error, its code path and all known details is as follows: 13.05 11:48:38 [Multicraft] Server shut down (running) 13.05 11:48:38 [Multicraft] Restarting crashed server in 300 seconds 13.05 11:48:38 [Multicraft] Server stopped 13.05 11:50:33 [Multicraft] Received kill command 13.05 11:50:33 [Multicraft] Server stopped What can i do?
    • This is wrong, they still ship J8 for <1.17 So for any of the versions that arnt the latest snapshot use J8.
    • Post your debug.log if it is crashing when you are trying to play. If it crashes when you are downloading mods, well, that's a computer issue, not a MC/forge issue, and you probably need a computer tech, or someone to help you.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.