Jump to content

1.7.10 - Help starting to mod for servers


mainsheep
 Share

Recommended Posts

Hello,

 

First of, let me introduce myself. I'm new to modding, but extremely motivated to walk the long mile and learn. I'm a 35 year old guy from Norway, who has been playing Minecraft on and off since alpha. I've also hosted a few FTB servers, but now I want to develop :)

 

Ive been trying to find tutorials on how to mod server side mods (like home, teleportation, protection, etc), but so far I've been unable to find anything that will get me on the right track. I'm not interested in learning how to create in-game blocks, items and such.

 

Any help to get me on the track to become a great java programmer and forge modder is much appreciated.

 

I've done tutorials from thenewboston + some others, and done the basic server command tutorial on forge, and I'm really pumped to learn more.

 

Thanks alot in advance :)

Link to comment
Share on other sites

It's good that you have put in effort to learn, and the desire is there. However, for server-side modding, Bukkit plugin development is what you want to look into, not Forge modding. Look up kennethbgoodin Bukkit tutorials on YouTube. They're great for beginners.

Maker of the Craft++ mod.

Link to comment
Share on other sites

While I can't give you any suggestions for tutorials(as I've never seen one), I thought I would warn you about some potential problems you may run into while trying to do utility development for modded servers.

 

Probably the biggest problem, is that many events you may want to use for things like protection simply don't exist in forge(such as endermen block interaction). Any missing events would need to created for yourself using ASM, which is a bytecode manipulation framework, and ASM is a little bit harder than just basic modding. The alternative to using ASM to create your own events, would be to do as Anon10W1z suggested, and use Cauldron for the server, allowing Bukkit plugins. While Bukkit has a much larger range of events, Cauldron doesn't always play nice with all mods, and Bukkit events have a tendency to not be triggered by modded items(GriefPrevention Bukkit plugin vs Thaumcraft wand of excavation).

 

Basically, Forge has infinite possibilities, but it'll take a lot of work to realize them. While Bukkit is easier, but will probably not interact with mods quite how you would like.

 

If you have any questions about specific things (Forge code/ASM/Bukkit theory) feel free to send me a message and I'll do my best to help you out, as I've gone into a lot of these things before.

Link to comment
Share on other sites

Hello and thank you guys for good answers.

 

The reason I wanted to do forge modding instead of bukkit is because of the DMCA takedown. I am guessing that bukkit will be replaced with something better in the future, and I didn't want to be reliant on cauldron.

 

Also, like you are saying, bukkit doesn't register item handling very well, and I wanted to do a protection plugin or mod.

 

Do any of you know if bukkit plugins will exist in the very near future without cauldron? I would not want to create something that will we out of date in a month.

 

Thanks again for the answers ☺

Link to comment
Share on other sites

Isn't spigot also affected by the takedown?

Yes.

 

Really? I got a 1.8 version not long ago and it's easy to set up a dev environment for it. The only thing I think is affected is that they can't put up download links, which is why you need to build the jar yourself. Unless something has changed in the past month or so (I don't keep up to date on it) then it should still work.

Link to comment
Share on other sites

Above is true.

 

Since official github source has been taken down along with downloads, Spigot team (what's left of it), is making updates by patcher distribution that doesn't contain "taken-down" code (the one that was affected by DMCA) therefore it's legal.

 

I wouldn't really count on ANYTHING bukkit-based. That era has ended the day, some selfish persona done DMCA.

 

Next era would be Sponge project (for now doesn't have actual server implementation, just in-dev API that works with Forge).

https://spongepowered.org/

If anything - invest you time in this. It comes with very good (still wip tho) docs, code and developers, and seems like it will lead in near future. Note that you can still code server mods with Forge.

1.7.10 is no longer supported by forge, you are on your own.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I made a huge forge 1.7.10 mod pack but whenever I try to create a singleplayer world I get the error saying "A fatal error has occurred, this connection is terminated." Does anyone know what the issue could be?  Here is my fml-client-latest.log from when it crashes: https://paste.ubuntu.com/p/3rKSJSqnrX/ and here is the list of mods: https://imgur.com/a/AZifMbg    
    • Im trying to host a minecraft server using the curseforge serverpack from FTB Direwolf20 and when I try to start the server I run into an error The Error: Starting server A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)         at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)         at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)         at java.lang.reflect.Method.invoke(Unknown Source)         at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:43)         at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:12) Caused by: java.lang.NoClassDefFoundError: org/apache/logging/log4j/Level         at net.minecraft.launchwrapper.Launch.launch(Launch.java:94)         at net.minecraft.launchwrapper.Launch.main(Launch.java:28)         ... 6 more Caused by: java.lang.ClassNotFoundException: org.apache.logging.log4j.Level         at java.net.URLClassLoader$1.run(Unknown Source)         at java.net.URLClassLoader$1.run(Unknown Source)         at java.security.AccessController.doPrivileged(Native Method)         at java.net.URLClassLoader.findClass(Unknown Source)         at java.lang.ClassLoader.loadClass(Unknown Source)         at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)         at java.lang.ClassLoader.loadClass(Unknown Source)         ... 8 more   I'have tried deleting and downloading the newset version of java wich didnt work and now im using an older version which is the 1.7.0_80 Here is what my Server folder looks like: https://ibb.co/jkbfRY7 Here is what the ServerStart.bat file looks like: @if NOT "%FTB_VERBOSE%"=="yes" ( @echo off ) call settings.bat if NOT EXIST minecraft_server.1.7.10.jar ( goto install ) if NOT EXIST libraries\%LAUNCHWRAPPER% ( goto install ) goto skipinstall :install echo running install script! call FTBInstall.bat :skipinstall REM Check if java in path REM TODO: use %JAVACMD% where java > NUL 2>&1 if %ERRORLEVEL% NEQ 0 ( echo No java binary in path. Can't run server, exiting... pause exit /B ) REM Test JVM REM e.g. 32-bit JVM does not have server\jvm.dll library java -server -version > java-test.log 2>&1 if %ERRORLEVEL% NEQ 0 ( echo Detected following JVM error: echo ======================================= more java-test.log echo ======================================= echo JVM test failed. Can't run server, Exiting... pause exit /B ) if not exist eula.txt ( echo Missing eula.txt. Startup will fail and eula.txt will be created echo Make sure to read eula.txt before playing! goto startserver ) find "eula=false" eula.txt 1 > NUL 2>&1 if %ERRORLEVEL% EQU 0 ( echo Make sure to read eula.txt before playing! Exiting. pause exit /B ) del /f /q autostart.stamp > nul 2>1 :startserver echo Starting server java -server -Xms512M -Xmx2048M -XX:PermSize=256M -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:+CMSClassUnloadingEnabled -XX:ParallelGCThreads=2 -XX:MinHeapFreeRatio=5 -XX:MaxHeapFreeRatio=10 -jar FTBServer-1.7.10-1558.jar nogui :server_loop if exist autostart.stamp ( del /f /q autostart.stamp > nul 2>1 echo If you want to completely stop the server process now, press Ctrl+C before the time is up! for /l %%i in (5,-1,1) do ( echo Restarting server in %%i choice /t 1 /d y > nul ) echo Starting server now java -server -Xms512M -Xmx2048M -XX:PermSize=256M -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:+CMSClassUnloadingEnabled -XX:ParallelGCThreads=2 -XX:MinHeapFreeRatio=5 -XX:MaxHeapFreeRatio=10 -jar FTBServer-1.7.10-1558.jar nogui echo Server process finished goto :server_loop ) echo Exiting... pause  
    • Made a modpack (Well Rounded Blockheads, in case the modlist on curseforge helps) and server to host it, worked fine until last night. The issue that pops up after some days being up/working is when you leave a world (singleplayer) or shutdown a server, the process hangs and jumps to 8.5gb ram used, eats up CPU usage (50-60% in taskman on a 3800x) and just sits there. If done on a single player world, the game doesnt fully crash, (e.g. if you alt+f4 buttons like save and quit, options stay in the window, are still clickable but they do nothing) Saving seems to still happen, as location/inventory updates if I restart server or client and play the world again.   If I start the currently afflicted server but dont login the server closes properly, its only once I log back in the problem occurs. Its a priv server and I dont have anyone else to test atm so Idk if its a prob with my player or players/area in general. Only recent changes in game are the additions of a pnuematicraft pressure chamber, an enchanting table, and bookshelves from builders crafts and additions.... I've been trying to get help on this all day, so ANY assistance goes a long way, even if its a way to debug this myself >~< Debug/Latest logs
    • Thanks warjort. I was afraid, that this is because they are entities. Now I know where to dig. But what about water, for example? I have checked via debug code, that there is no entity there (appropriate method return null). What is wrong with liquids?
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.