Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.4.5/6/7] keepcalm's mods - Events API, BukkitForge - Interdim TPs, Lockette!


keepcalm
 Share

Recommended Posts

  • Replies 223
  • Created
  • Last Reply

Top Posters In This Topic

Thank you for the Events API, but I can't get it to work.

 

I tried it with a fresh MC146, MCP725, Forge489 and BlockBreak source downloaded on 2012-01-15.

 

Eclipse gives a few problems in keepkalm.mods.events ForgeEventHelper.java, but it still compiles.

import org.bukkit.Bukkit;

--- remove unused import ---

 

	public static boolean onBlockDamage(ItemInWorldManager man) {

	// mcp has ridiculously long names

	if (man.curblockDamage % 2 == 1) {
		return false;
	}

	PlayerDamageBlockEvent ev = new PlayerDamageBlockEvent(man.thisPlayerMP, man.partiallyDestroyedBlockX,
			man.partiallyDestroyedBlockY, man.partiallyDestroyedBlockZ,
			man.theWorld, man.curblockDamage, man.durabilityRemainingOnBlock);

	MinecraftForge.EVENT_BUS.post(ev);

	if (ev.isCanceled()) {
		return true;
	}
	return false;

}

--- with man.xyz, change visibility of xyz to public ---

 

Without the BlockBreakNin.jar in the coremods folder, it runs, but doesn't work.

With the jar in the folder it gives a runtime error:

2013-01-16 09:49:10 [iNFO] [ForgeModLoader] Forge Mod Loader version 4.6.17.515 for Minecraft 1.4.6 loading
2013-01-16 09:49:11 [iNFO] [sTDERR] Exception in thread "main" java.lang.RuntimeException: java.lang.ExceptionInInitializerError
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.FMLRelauncher.setupHome(FMLRelauncher.java:175)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.FMLRelauncher.relaunchServer(FMLRelauncher.java:133)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.FMLRelauncher.handleServerRelaunch(FMLRelauncher.java:33)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at net.minecraft.server.MinecraftServer.main(MinecraftServer.java:1375)
2013-01-16 09:49:11 [iNFO] [sTDERR] Caused by: java.lang.ExceptionInInitializerError
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at keepcalm.mods.events.asm.transformers.events.BlockEventHelpers.<init>(BlockEventHelpers.java:37)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at java.lang.reflect.Constructor.newInstance(Unknown Source)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at java.lang.Class.newInstance0(Unknown Source)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at java.lang.Class.newInstance(Unknown Source)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.RelaunchClassLoader.registerTransformer(RelaunchClassLoader.java:75)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.RelaunchLibraryManager.handleLaunch(RelaunchLibraryManager.java:238)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.FMLRelauncher.setupHome(FMLRelauncher.java:155)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	... 3 more
2013-01-16 09:49:11 [iNFO] [sTDERR] Caused by: java.lang.NullPointerException
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at java.util.Properties$LineReader.readLine(Unknown Source)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at java.util.Properties.load0(Unknown Source)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at java.util.Properties.load(Unknown Source)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	at keepcalm.mods.events.asm.transformers.events.ObfuscationHelper.<clinit>(ObfuscationHelper.java:140)
2013-01-16 09:49:11 [iNFO] [sTDERR] 	... 13 more

Link to comment
Share on other sites

EPIC!!

 

Thanks for all your work!

 

But I have a few requests:

GreifPrevention compatibility. I works but many features broken.

http://dev.bukkit.org/server-mods/grief-prevention/

 

CoreProtect compatibility Also work but will not rollback non vanilla blocks. It detects them if they were removed but not placed.

http://dev.bukkit.org/server-mods/coreprotect/

 

And A little help. The perms load, I set them up, and I can assign groups to my players, but it does't auto assign them nor are they able to use any commands while in their groups. I have tried both PermissionsEx and GroupManager. All commands seem to work fine if you are OP.

 

Thanks again

 

Link to comment
Share on other sites

Fantastic! I'm so pleased that someone has decided to continue this challenging project. My hat goes off to you sir. Good luck facing the small mountain of bug reports turning up at Github  ;) I will contribute some of my own there shortly.

 

Godspeed you magnificent gentleman.

Link to comment
Share on other sites

Whenever I load Ptweaks it gives this error.

 

[bukkitForge] Error occurred while enabling PTweaks v6.0 (Is it up to date?)
java.lang.NoClassDefFoundError: org/bukkit/craftbukkit/v1_4_R1/CraftServer
at me.devplugin.ptweaks.AutoSaveStopper.<init>(AutoSaveStopper.java:15)
at me.devplugin.ptweaks.PerformanceTweaks.onEnable(PerformanceTweaks.java:22)
at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)
at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:423)
at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
at keepcalm.mods.bukkit.bukkitAPI.BukkitServer.loadPlugin(BukkitServer.java:956)
at keepcalm.mods.bukkit.bukkitAPI.BukkitServer.enablePlugins(BukkitServer.java:940)
at keepcalm.mods.bukkit.bukkitAPI.BukkitServer.<init>(BukkitServer.java:277)
at keepcalm.mods.bukkit.asm.BukkitStarter.run(BukkitStarter.java:46)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.bukkit.craftbukkit.v1_4_R1.CraftServer
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:44)
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:39)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 10 more

Link to comment
Share on other sites

so far only tested the permissionsEX you added and server events (missed that little plugin...looks like i may need to submit more lines to it)

 

its working great VERY GOOD WORK!!!

 

now i just need to hunt down towny, iconomy and an old stargate plugin i used to use and ill be one VERY happy admin

Link to comment
Share on other sites

Hey KeepCalm, can i make a spotlight review on this, because everyone need to see this? I will give you the link to the video spotlight.

 

Sounds cool, thanks :)

Protip: try and find answers yourself before asking on the forum.

It's pretty likely that there is an answer.

 

Was I helpful? Give me a thank you!

 

 

width=635 height=903http://bit.ly/HZ03zy[/img]

 

 

Tired of waiting for mods to port to bukkit?

use BukkitForge! (now with a working version of WorldEdit!)

Link to comment
Share on other sites

Oh, one problem I have with bukkitforge is The latest Voxelsniper does not work. (No crash)

http://dev.bukkit.org/server-mods/voxelsniper/

 

iDisguise (No Crash)

http://dev.bukkit.org/server-mods/idisguise/

 

Factions (No Crash)

http://dev.bukkit.org/server-mods/factions/

 

Be Herobrine (Only works with Disguisecraft, which does not work as well.)(No crash)

http://dev.bukkit.org/server-mods/disguisecraft/

http://dev.bukkit.org/server-mods/be-herobrine/

 

Command Book. It works fine, but the spawnmob command is missing mob over another mob (such as spawning a creeper over a bat, or spiderJockey: skeleton over a spider. The command is this: [/spawnmob bat|creeper]

http://dev.bukkit.org/server-mods/commandbook/

 

CookieMonster (No crash)

http://dev.bukkit.org/server-mods/cookiemonster/

Link to comment
Share on other sites

In the Events API

 

A small thing:

In META-INF/MANIFEST.MF

keepcalm.mods.blockbreak.asm.BlockBreakLoadingPlugin

should be

keepcalm.mods.events.asm.BlockBreakLoadingPlugin

like it is in BlockBreakNin.jar

 

and a bigger problem (for me it is)

 

After adding mcp.properties and obf.properties to the src/minecraft folder and changing some of the variables in ItemInWorldManager.java from private to public, it works when running from Eclipse.

 

After recompile and reobfuscate, there is now the file "ir.class" in the minecraft folder.

I can add this to the coremod .jar file, but it doesn't seem to be loaded.

It gives this error when trying to break a block:

 

 

Description: Ticking entity

java.lang.IllegalAccessError: tried to access field ir.i from class keepcalm.mods.events.ForgeEventHelper
at keepcalm.mods.events.ForgeEventHelper.onBlockDamage(ForgeEventHelper.java:218)
at ir.a(ItemInWorldManager.java:142)
at iq.j_(EntityPlayerMP.java:220)
at yc.a(World.java:2295)
at in.a(WorldServer.java:647)
at yc.g(World.java:2257)
at yc.h(World.java:2103)
at in.h(WorldServer.java:516)
at net.minecraft.server.MinecraftServer.r(MinecraftServer.java:679)
at ho.r(DedicatedServer.java:270)
at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:598)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:497)
at fy.run(SourceFile:849)

 

 

 

Link to comment
Share on other sites

another bug

wormhole x-treme doesnt detect the button press needed to create a gate, even with the commands or makeing the gate the old fashioned way

http://forums.bukkit.org/threads/tp-wormhole-x-treme-multi-world-capable-stargates-moved-to-bukkitdev.23973/

 

 

for those above with issues with PermissionPEX, make sure you use the one linked on the first page, permissionsPEX works fine for me... server_events and wormhole x-treme however dont :( (hence the bug reports) if your unable to fix it for these please let me know as there the only plugins i really wanted to use :)

 

 

updated to #70, both bugs reported still exist :(

Link to comment
Share on other sites

I installed a test server with BukkitForge, Factions plugin and ComputerCraft mod.

 

Factions seems to work fine (did very little testing). A piece of land claimed by one player couldn't be destroyed or build upon by other players.

 

But if an other player made a ComputerCraft turtle, they could use that to break blocks in the protected area.

Link to comment
Share on other sites

Using #87, and PEX from here, PermissionsEx should now work, along with all the other perms plugins.

Protip: try and find answers yourself before asking on the forum.

It's pretty likely that there is an answer.

 

Was I helpful? Give me a thank you!

 

 

width=635 height=903http://bit.ly/HZ03zy[/img]

 

 

Tired of waiting for mods to port to bukkit?

use BukkitForge! (now with a working version of WorldEdit!)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • show the code your use for this is the Event called?, use debugger to check the values in the condition
    • if you add your Biome to the Overworld via BiomeManager#addAdditionalOverworldBiomes, you need to register your Biome via DeferredRegister or RegistryEvent unfortunately a json only Biome does not work in this case
    • use debugger to check the conditions you are using before you render your Entity
    • yes, and then post the correct logs
    • Good Morning, I tried overriding one of the vanilla rock blocks according to instructions in this old thread, but failed for the same reason the org TM did, even though I got a tiny bit farther than he did. I can remove the original block entirely from world spawn, and replace it with custom version, which I want to prevent due to following up workload(adapting recipes etc. to custom block). What I tried solving the issue/actually making replacing(partially) work: 1. I had to use the original Forge variant of registering the block in main class, like that: which actually did use the custom granite block as replacer(not exactly illustrated in the old thread), but didn't consider it on world feature generation... 2. I then believed it was due to not using correct path variables for assets texture/models/blockstates etc., so I created missing asset packets for both, vanilla asset path, and my mod path. This also did not fix the issue with creating holes filled up with Items.AIR on world feature generation. 3. I then tried to remove the vanilla granite block during feature generation, and reimported it after with my replacement set up, during feature generation as well(according to @Luis_ST advice). But the holes were still there, only this time I got my replaced granite block spawned as well. What do I want to achieve(asking myself and you in hope maybe there's a better solution)? Mojang found it a good idea, to give one of the hardest rock materials on this planet, the .harvestLevel(soft as a pillow), so I can harvest it with a wooden pickaxes(which technically is even worth, but doesn't matter since wooden "pickaxe" tools do not exist in my mod). I really just want to compare harvestLevel of any of my tools, against the harvestLevel of the targetBlock, so I can automatically disallow harvesting it, if the tool doesn't match the harvestLevel(which for whatever reason does not work as intended in 1.16.5 Minecraft). Edit: and before you shout "doPlayerHarvestCheck". Yes, I do that! Edit2: Also, why are there Manga Comic Girls, on the right upper corner of my Monitor, stating how can it be that big?(whatever "it" is?)
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.