Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Game crashes seconds after entering world, saved or newly created


Recommended Posts

Seriously bummed. Got my game all tricked out, got everything working together, was playing for about 40 mins last night then the 'internal server shut down' and it crashed. Now it crashes within seconds of either loading a saved game, or creating a new world. I even copied the entire .minecraft directory over from a backup, and it still crashes!  I am running a bunch of mods, with several that are in beta, so I'm sure it's not a forge problem specifically, but since I don't have a clue where to start, and since forge is basically the foundation for the other mods, here I am, hoping somebody here can point me in the right direction. On to the spoilers...


JAR mods (in the order they are installed; am I correct in assuming all API's go into the jar?)




Optifine 1.4.2_HD_U_A7

PlayerAPIRenderer 1.2

GuiApi 0.14.8-1.4.2

TooManyItems 2012_10_24_1.4.2

MetallurgyApi v1

Thermal Expansion Api 2.0.0

Atomic Science Api

Universal Electricity Api

and Id Resolver 1.4.2 Update 0 installed to \Coremods




Crash Report:


---- Minecraft Crash Report ----

// I just don't know what went wrong :(


Time: 11/8/12 8:46 AM

Description: Unexpected error



at awr.a(NetClientHandler.java:766)

at cg.a(SourceFile:87)

at bw.b(MemoryConnection.java:78)

at awr.d(NetClientHandler.java:104)

at awz.b(WorldClient.java:72)

at net.minecraft.client.Minecraft.l(Minecraft.java:1826)

at net.minecraft.client.Minecraft.J(Minecraft.java:854)

at net.minecraft.client.Minecraft.run(Minecraft.java:779)

at java.lang.Thread.run(Unknown Source)


Relevant Details:

- Minecraft Version: 1.4.2

- Operating System: Windows 7 (amd64) version 6.1

- Java Version: 1.7.0_09, Oracle Corporation

- Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

- Memory: 378899744 bytes (361 MB) / 937295872 bytes (893 MB) up to 954466304 bytes (910 MB)

- JVM Flags: 2 total; -Xms512m -Xmx1024m

- AABB Pool Size: 14 (784 bytes; 0 MB) allocated, 12 (672 bytes; 0 MB) used

- FML: MCP v7.19 FML v4.2.18.433 Minecraft Forge Optifine OptiFine_1.4.2_HD_U_A7 59 mods loaded, 59 mods active

mcp [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

FML [Forge Mod Loader] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

Forge [Minecraft Forge] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

mod_TooManyItems [mod_TooManyItems] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

mod_ReiMinimap [mod_ReiMinimap] ([1.4.2]ReiMinimap_v3.2_05.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

BasicComponents [basic Components] (BasicComponents_v1.0.0.260.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

IC2 [industrialCraft 2] (industrialcraft-2_1.108.71-lf.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

AtomicScience [Atomic Science] (AtomicScience_v0.2.0.78.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

AS_UpdateCheck [AtomicStryker Update Check Mod] (AtomicStrykerUpdateCheckMod.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

Backpack [backpack] (backpack-1.1.4-1.4.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

BuildCraft|Core [buildCraft] (buildcraft-A- Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

BuildCraft|Builders [bC Builders] (buildcraft-A- Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

BuildCraft|Energy [bC Energy] (buildcraft-A- Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

BuildCraft|Factory [bC Factory] (buildcraft-A- Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

BuildCraft|Transport [bC Transport] (buildcraft-A- Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

BuildCraft|Silicon [bC Silicon] (buildcraft-A- Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

mod_CCas [mod_CCas] (Chicken Cassarole for 1.4.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

mod_Fert [mod_Fert] (Composter for 1.4.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

ComputerCraft [ComputerCraft] (ComputerCraft1.46.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

CCTurtle [ComputerCraft Turtles] (ComputerCraft1.46.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

CraftGuide_forge [CraftGuide] (CraftGuide- Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

MoCreatures [DrZhark's Mo'Creatures Mod] (DrZharks MoCreatures Mod v4.1.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

ExtrabiomesXL [ExtrabiomesXL] (ExtrabiomesXL-universal-3.3.0.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

Forestry [Forestry for Minecraft] (forestry-A- Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

LuminousEther [Luminous Ether] (GreenTechv1.7.0.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

GreenTechnology [Green Technology] (GreenTechv1.7.0.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

mod_Heal [mod_Heal] (Healing Block for 1.4.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

ICBM [iCBM] (ICBM_v0.6.0.52.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

MetallurgyCore [Metallurgy Core] (Metallurgy Core 2.2.3.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

MetallurgyBase [Metallurgy Base] (Metallurgy Base Metals 2.2.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

MetallurgyEnder [Metallurgy Ender] (Metallurgy Ender Metals 2.2.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

MetallurgyFantasy [Metallurgy Fantasy] (Metallurgy Fantasy Metals 2.2.2.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

MetallurgyNether [Metallurgy Nether] (Metallurgy Nether Metals 2.2.3.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

MetallurgyPrecious [Metallurgy Precious] (Metallurgy Precious Metals 2.2.3.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

MetallurgyUtility [Metallurgy Utility] (Metallurgy Utility Ores 2.2.3.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

Millenaire [Millénaire] (millenaire3.2.1.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

mod_Stackables [mod_Stackables] (More Stackables.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

Mystcraft [Mystcraft] (mystcraft-uni-1.4.2- Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

mod_NetherBricks [mod_NetherBricks] (Nether Bricks for 1.4.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

mod_Oat [mod_Oat] (Oatmeal for 1.4.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

ParachuteMod [Parachute Mod] (parachute-1.4.2-fml-339.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

PowerTools [PowerTools] (PowerTools-1.1.0.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

ThePreHistoricMod [The Pre-Historic Mod] (PreHistoricMod - Beta V1.5.0 For MC 1.4.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

Railcraft [Railcraft] (Railcraft_6.7.0.0.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

ReptileMod [Reptile Mod] (reptiles-1.4.2-fml-339.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

AS_Ruins [Ruins Spawning System] (Ruins 1.4.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

SoulShards [soul Shards] (SoulShards-v1.10-universal.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

StevesCarts [steve's Carts] (StevesCarts2.0.0.a20.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

ThermalExpansion|Core [Thermal Expansion] (ThermalExpansion-2.0.3.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

ThermalExpansion|Factory [Factory] (ThermalExpansion-2.0.3.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

ThermalExpansion|Energy [Energy] (ThermalExpansion-2.0.3.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

LAPI [LAPI] (Tropicraft v4.0.3a.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

TropicraftMod [Tropicraft] (Tropicraft v4.0.3a.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

TwilightForest [The Twilight Forest] (twilightforest-1.12.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

AIBlock [AIBlock] (Weather 1.22 for MC 1.4.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

ExtendedRenderer [Extended Renderer] (Weather 1.22 for MC 1.4.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

WeatherMod [Weather and Tornadoes] (Weather 1.22 for MC 1.4.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

Xie_RuntimeContentLoader [Xie's Mod] (Xie) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

mod_IDResolver [mod_IDResolver] (IDResolver_1.4.2_COREMOD_Update-0.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available

- LWJGL: 2.4.2

- OpenGL: GeForce GTX 560/PCIe/SSE2 GL version 4.2.0, NVIDIA Corporation

- Is Modded: Definitely; 'forge,fml'

- Type: Client

- Texture Pack: faithful32pack.zip

- Profiler Position: N/A (disabled)

- Vec3 Pool Size: 44 (2464 bytes; 0 MB) allocated, 12 (672 bytes; 0 MB) used

- World MpServer Entities: 2 total; [axc['Daemonshi'/165, l='MpServer', x=-175.50, y=-678.99, z=256.50], pg['item.tile.torch'/85, l='MpServer', x=-163.75, y=20.88, z=275.53]]

- World MpServer Players: 1 total; [axc['Daemonshi'/165, l='MpServer', x=-175.50, y=-678.99, z=256.50]]

- World MpServer Chunk Stats: MultiplayerChunkCache: 5

- Forced Entities: 3 total; [pg['item.tile.torch'/85, l='MpServer', x=-163.75, y=20.88, z=275.53], pg['item.tile.torch'/85, l='MpServer', x=-163.75, y=20.88, z=275.53], axc['Daemonshi'/165, l='MpServer', x=-175.50, y=-678.99, z=256.50]]

- Retry Entities: 0 total; []




Note I am unable to post the contents of the  ForgeModLoader-client-0.txt file. I tried in this post, as well as making it its own post, and I keep timing out. I'm guessing it's just too long.  Going through it, I did find some lines that may be of interest though:




2012-11-08 08:44:52 [iNFO] [ForgeModLoader] FML has found a non-mod file CoroAI for MC 1.4.2.zip in your mods directory. It will now be injected into your classpath. This could severe stability issues, it should be removed if possible.

2012-11-08 08:44:52 [iNFO] [ForgeModLoader] FML has found a non-mod file CustomMobSpawner 1.7.1.zip in your mods directory. It will now be injected into your classpath. This could severe stability issues, it should be removed if possible.

2012-11-08 08:44:52 [iNFO] [ForgeModLoader] FML has found a non-mod file GSWireClient-1.4.2-b107.zip in your mods directory. It will now be injected into your classpath. This could severe stability issues, it should be removed if possible.

2012-11-08 08:44:52 [iNFO] [ForgeModLoader] FML has found a non-mod file Metallurgy Mystcraft Addon 1.2.jar in your mods directory. It will now be injected into your classpath. This could severe stability issues, it should be removed if possible.

2012-11-08 08:44:52 [FINE] [ForgeModLoader] No MLProp configuration for mod_TooManyItems found or required. No file written

2012-11-08 08:44:52 [FINE] [ForgeModLoader] Injecting dummy network mod handler for BaseMod mod_TooManyItems

2012-11-08 08:44:52 [sEVERE] [ForgeModLoader] Detected an attempt by a mod mod_TooManyItems to perform game activity during mod construction. This is a serious programming error.

2012-11-08 08:44:52 [FINE] [ForgeModLoader] Attempting to inject @SidedProxy classes into mod_TooManyItems

2012-11-08 08:44:52 [FINER] [ForgeModLoader] Sent event FMLConstructionEvent to mod mod_TooManyItems

2012-11-08 08:44:52 [FINER] [ForgeModLoader] Sending event FMLConstructionEvent to mod mod_ReiMinimap

2012-11-08 08:44:52 [FINE] [ForgeModLoader] No MLProp configuration for mod_ReiMinimap found or required. No file written

2012-11-08 08:44:52 [FINE] [ForgeModLoader] Injecting dummy network mod handler for BaseMod mod_ReiMinimap

2012-11-08 08:44:52 [sEVERE] [ForgeModLoader] Detected an attempt by a mod mod_ReiMinimap to perform game activity during mod construction. This is a serious programming error.

2012-11-08 08:44:58 [WARNING] [ForgeModLoader] BuildCraft: Using outdated version [3.1.8 (build:20)] for Minecraft 1.4.2. Consider updating.

45:01 [WARNING] [ForgeModLoader] Forestry: Using outdated version [ (build:14)] for Minecraft 1.4.2. Consider updating.

45:17 [iNFO] [sTDOUT] CLIENT MAJOR: null: Loading language: en_US

2012-11-08 08:45:17 [iNFO] [sTDOUT] CLIENT ERROR: null: Error when reading reputation line in file C:\Users\Scott\AppData\Roaming\.minecraft\mods\millenaire\languages\ar\japanese_reputation.txt: 32*64.64; ????? ?????; ?? $name, ??? ???? ??? ?????? ???? ????????? .??? ??????? ???? ???????. : For input string: "64.64"

2012-11-08 08:45:17 [iNFO] [sTDOUT] CLIENT MAJOR: null: Language loaded: en_US. Wand name: Wand of Summoning


and I see this following error a lot: (especially where the ruins mod is making all its ruins)

46:08 [iNFO] [sTDOUT] java.lang.IllegalAccessException: Can not set static final alf field alf.av to null value




Note the 2 errors that say I'm using outdated buildcraft & forestry mods; both versions are the most recent betas I am able to find.

Link to comment
Share on other sites

I get this one randomly, too (with 70-some mods).  I also saw it reported on MinecraftForums with just Mo' Creatures and DivineRPG, but couldn't replicate it myself using that setup.  There is a very similar report from someone with a ModLoader install, so I'm beginning to suspect it's something in Minecraft proper, or something that ModLoader and FML do the same.  If anyone smarter than me is interested and can figure out what exactly this is pointing to, here is the ML report I found:



java.lang.ArrayIndexOutOfBoundsException: 0

at agl.a(SourceFile:239)

at awr.a(NetClientHandler.java:1204)

at cr.a(SourceFile:41)

at bx.b(SourceFile:341)

at awr.d(NetClientHandler.java:90)

at awz.b(SourceFile:61)

at net.minecraft.client.Minecraft.l(SourceFile:1282)

at net.minecraft.client.Minecraft.J(SourceFile:582)

at net.minecraft.client.Minecraft.run(SourceFile:534)

at java.lang.Thread.run(Unknown Source)

--- END ERROR REPORT e59def4c ----------




I did have one world that was broken, and after removing Mo' Creatures from my set, it loaded back up.  Would be interested to see if you get the same behavior.

I'm fixing the stupid villagers.  http://www.minecraftforum.net/topic/1588460-

Link to comment
Share on other sites

Interesting... removed Mo'creatures and created a new world, and it stayed up for a few minutes. The crash would have happened within the first few seconds. Unfortunately, I had already deleted the broken worlds so can't test it there. BUT, when this error did kick in, I wouldn't be able to last more than a few seconds in a newly created world so looks like it may have something to do with mo'c...  Sucks too, as that's one of the main mods I want to use. Was really hoping the problem was with one of the betas....


Edit: Just plugged Mo'Creatures & CustomMobSpawner back in, created a new world, and it crashed just seconds into it.  Removed the mods, reloaded the now broken world, and it seems to be running fine.  Looks like Mo is the culprit... :( :( :(



Link to comment
Share on other sites

It's definitely more complicated. I was using Mo'Creatures just fine as soon as it was updated. I didn't start getting this new world-killing crash until after I expanded my game with all these betas. There were still crashes but nothing like this one.  Maybe I'll load up a fresh directory and use Mo by itself and see what happens....


Edit: Mo' works just fine by itself. So Mo isn't the problem itself, but it's definitely (or almost definitely) part of the problem....  Maybe I'll get my full load going until I get another busted world, save that world file, then reload my mods, with Mo being one of the first, then just keep trying to load the broken world and see if it works or not. Try to whittle it down. Interesting how Mo & DivineRPG together cause the problem too though; I'm not using Divine at all.

Link to comment
Share on other sites

Some progress...  The broken world repeats the crash after I installed the Reptiles mod. It's repeatable: Remove mod, the world loads, install the mod, it crashes.

And, with Reptiles installed, remove Mo'C, and the world loads, put Mo'C back in, it crashes. Yet, installing both mods into a clean game with no other mods installed and they both work fine alongside each other.  It's enough to make my head hurt.


Mods installed up to this point:





Mo'C 4.1.2




faithful 32x32 texture pack






BuildCraft beta







Gonna move Reptiles to a probation folder and keep on plugging, see if there are any others...


Finished going through them all. The only one that repeated the crash when I loaded the broken save was Reptiles. Gonna keep that one out of the mix for a while and see if the game is more stable.



Link to comment
Share on other sites

I have noticed a number of bugs with ID Resolver, but have been too lazy to try and debug them or tell the creators about it. I am not familiar with this bug, but I am almost certain its caused by IDresolver...

I had to go through and edit my configs manually cause IDresolver would cause weird errors.

Link to comment
Share on other sites

I've been trying to get all these mods working without ID Resolver to see if it runs better. Can't do it man. I'm about 2/3 the way through, and now I get a black screen after loading the next mod, regardless of what the mod is. After getting 40+ mods going, this is a serious let down. It really is a pain going in and editing all those id's, so now I'm looking at some other, hopefully better, loaders. Any thoughts on Magic Launcher? I tried that once already, but it was showing errors on several mods and ended up crashing with about a dozen loaded. Not sure I was doing it right though, so I'd be willing to give it another go.


Link to comment
Share on other sites

I recommend MultiMC for launching.  I did some digging yesterday, pulling apart the code.  The error/stack trace definitely points to entity spawning, I just haven't been able to figure out where the requests to spawn an entity with a negative ID is originating. 

I did put a stupid hack in Forge to change all negative ID entities to some other mob, and that made the crashing go away. :)  I feel like there is a better way to handle these bad cases, but just not sure what it is yet.  I'm going to keep trying to track down the root of the problem, but now I no longer believe it's ID Resolver.

I'm fixing the stupid villagers.  http://www.minecraftforum.net/topic/1588460-

Link to comment
Share on other sites

Can you pastebin ForgeModLoader-client-0 and post the link?

Protip: try and find answers yourself before asking on the forum.

It's pretty likely that there is an answer.


Was I helpful? Give me a thank you!



width=635 height=903http://bit.ly/HZ03zy[/img]



Tired of waiting for mods to port to bukkit?

use BukkitForge! (now with a working version of WorldEdit!)

Link to comment
Share on other sites

Played around for about an hour last night with the hack installed. No crashes to report! I'm sure it would have within that time so looks like it did the trick, good job man!


@keepcalm  Not sure who you were asking, so here's mine.  Had to break it in half so pastebin would accept it.


Part 1: http://pastebin.com/FXnFgB09


Part 2: http://pastebin.com/NN7p5Rt5



Link to comment
Share on other sites

Your error was a file that Ruins Mod was trying to load... You just needed to reinstall it, it would seem...

Protip: try and find answers yourself before asking on the forum.

It's pretty likely that there is an answer.


Was I helpful? Give me a thank you!



width=635 height=903http://bit.ly/HZ03zy[/img]



Tired of waiting for mods to port to bukkit?

use BukkitForge! (now with a working version of WorldEdit!)

Link to comment
Share on other sites

Some mod you're using is using the old mechanics for mob ids and they need to switch to the new, so that you can have more then 128 mob idea. Please go figure out wehich and talk to them.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.