Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.7.10] Gradle Error "No such version exists"


Lyeoj
 Share

Recommended Posts

So I was trying to build a new version of my mod, which I had been able to do without problems plenty of times before, and I received this error.


C:\Users\Lyeoj\Desktop\MC Modding>gradlew build

FAILURE: Build failed with an exception.

* Where:
Build file 'C:\Users\Lyeoj\Desktop\MC Modding\build.gradle' line: 25

* What went wrong:
A problem occurred evaluating root project 'MC Modding'.
> No such version exists!

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug
option to get more log output.

BUILD FAILED

Total time: 5.469 secs

 

This is my gradle.build file, even though the only thing I had changed in it since the last time I made a new build was the mod version:

buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "forge"
            url = "http://files.minecraftforge.net/maven"
        }
        maven {
            name = "sonatype"
            url = "https://oss.sonatype.org/content/repositories/snapshots/"
        }
    }
    dependencies {
        classpath 'net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT'
    }
}

apply plugin: 'forge'

version = "1.7.10-Beta-1.2.5"
group= "lyeoj.deadlyfeesh.mod" // http://maven.apache.org/guides/mini/guide-naming-conventions.html
archivesBaseName = "Deadly Feesh"

minecraft {
    version = "1.7.10-10.13.4.1490-1.7.10"
    runDir = "eclipse"
}

dependencies {
    // you may put jars on which you depend on in ./libs
    // or you may define them like so..
    //compile "some.group:artifact:version:classifier"
    //compile "some.group:artifact:version"
      
    // real examples
    //compile 'com.mod-buildcraft:buildcraft:6.0.8:dev'  // adds buildcraft to the dev env
    //compile 'com.googlecode.efficient-java-matrix-library:ejml:0.24' // adds ejml to the dev env

    // for more info...
    // http://www.gradle.org/docs/current/userguide/artifact_dependencies_tutorial.html
    // http://www.gradle.org/docs/current/userguide/dependency_management.html

}

processResources
{
    // this will ensure that this task is redone when the versions change.
    inputs.property "version", project.version
    inputs.property "mcversion", project.minecraft.version

    // replace stuff in mcmod.info, nothing else
    from(sourceSets.main.resources.srcDirs) {
        include 'mcmod.info'
                
        // replace version and mcversion
        expand 'version':project.version, 'mcversion':project.minecraft.version
    }
        
    // copy everything else, thats not the mcmod.info
    from(sourceSets.main.resources.srcDirs) {
        exclude 'mcmod.info'
    }
}

I know that my forge is out of date, but even upon trying to update forge, gradle would give the exact same error. I also downloaded a fresh copy of the forge src and made sure my gradle.build file was the same as its. I even tried to run gradlew setupDecompWorkspace with the fresh forge src and it still failed with the exact same error.

Link to comment
Share on other sites

I have this same problem, but my error is slightly different:

 

FAILURE: Build failed with an exception.

* Where:
Build file 'C:\Forge\build.gradle' line: 28

* What went wrong:
A problem occurred evaluating root project 'Forge'.
> No such version exists!

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 4.9 secs

 

build.gradle:

 

buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "forge"
            url = "http://files.minecraftforge.net/maven"
        }
        maven {
            name = "sonatype"
            url = "https://oss.sonatype.org/content/repositories/snapshots/"
        }
    }
    dependencies {
        classpath 'net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT'
    }
}

apply plugin: 'forge'

version = "1.7.10-0.1a"
group= "mod.gumballweapons.main.GumballWeapons"
archivesBaseName = "GumballWeapons"

sourceCompatibility = 1.8
targetCompatibility = 1.8

minecraft {
    version = "1.7.10-10.13.4.1448-1.7.10"
    runDir = "eclipse"
}

dependencies {    
    compile files("C:/Forge/src/libs/Baubles-princess-1.7.2-1.0.0.18p.jar")
}

processResources
{
    // this will ensure that this task is redone when the versions change.
    inputs.property "version", project.version
    inputs.property "mcversion", project.minecraft.version

    // replace stuff in mcmod.info, nothing else
    from(sourceSets.main.resources.srcDirs) {
        include 'mcmod.info'
                
        // replace version and mcversion
        expand 'version':project.version, 'mcversion':project.minecraft.version
    }
        
    // copy everything else, thats not the mcmod.info
    from(sourceSets.main.resources.srcDirs) {
        exclude 'mcmod.info'
    }
}

WIP mods: easyautomation, easyenergy, easyelectronics, easymoney, easytrasportation, easysecurity, easymultiverse, easyfactions, easymagick, easyalchemy, easyseasons

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.