Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.7.10] [UNSOLVED] Could not find a texture that actually exists.


TheDogePwner
 Share

Recommended Posts

Hey,

 

So, I have an Item class I use that looks like this (except this is significantly more simplified):

 

public class MNItem extends Item {
private String name;

public MNItem(String name, CreativeTabs tab) {
	this.name = name;

	setUnlocalizedName(name);
	setCreativeTab(tab);
	setTextureName("modid:" + name);
	setMaxStackSize(64);
}

public String getName() {
	return this.name;
}

public MNItem(String name, CreativeTabs tab, int stackSize) {
	this(name, tab);
	setMaxStackSize(stackSize);
}
}

 

And I create an item in my main class like this:

@EventHandler
public void preinit(FMLPreInitializationEvent event) {
GameRegistry.registerItem(new MNItem("SteelIngot", myCustomCreativeTab), "SteelIngot");
}

 

Here is my folder layout:

src

    main

          java

                ....

          resources

                assets

                        modid

                                textures

                                        items

                                            SteelIngot.png

 

Here is the error report:

[20:49:46] [Client thread/ERROR] [TEXTURE ERRORS]:   domain modid is missing 1 texture
[20:49:46] [Client thread/ERROR] [TEXTURE ERRORS]:     domain modid is missing a resource manager - it is probably a side-effect of automatic texture processing
[20:49:46] [Client thread/ERROR] [TEXTURE ERRORS]: -------------------------
[20:49:46] [Client thread/ERROR] [TEXTURE ERRORS]:     The missing resources for domain modid are:
[20:49:46] [Client thread/ERROR] [TEXTURE ERRORS]:       textures/items/SteelIngot.png
[20:49:46] [Client thread/ERROR] [TEXTURE ERRORS]: -------------------------

Why is this? Thanks for your help!

Sup bruh.

Link to comment
Share on other sites

If you're using IntelliJ IDEA and none of your resources are working in the development environment (but they are working in the release/obfuscated environment), you need to add the following code to your build.gradle (source):

idea.module.inheritOutputDirs = true

 

If this isn't the case, I'm not sure what your issue is.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Is your mod ID actually "modid"?

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

I had a similar issue, but was able to resolve it by making sure my resource location was done properly.  I'd check to make sure where you are telling it to find the texture that it says "modid:path/to/asset" instead of just "path/to/asset".  The bit before the colon is the domain that it looks for the texture in, and your log says it's looking in the domain 'modid' so I think you just have a typo for the texture path.

Link to comment
Share on other sites

9 times out of 10 the issue is that you renamed the texture file, To fix a casing issue. You may of first created it with the name "Steelingot.png" and 1/2 a second later changed it to "SteelIngot.png"

What you need to do is do a full clean in your project.

It should wipe out the mis-capitolized name in your bin directory.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.