Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

error when trying to add a config file so i can change ids for my mod


sidthesloth123
 Share

Recommended Posts

i was tyring to add it so 2 of my blocks can have their id's changed just as a test,but i am running into the same error all the time and the config file does not generate.

 

code of main class:

http://pastebin.com/6KgVVxsj

error message:

http://pastebin.com/Ut1gxBh7

 

if anyone can help you would be the best.

 

im using the latest recommended build of forge for 1.4.4

Link to comment
Share on other sites

You are creating blocks before IDs are generated.

 

You have to do any block = new BlockYours(id) after the id was correctly assigned.

sorry i dont understand what you mean?

Basically what he's saying is that you set the ID variables after registring the blocks, meaning that you are "creating" the blocks before setting the IDs, thus resulting in their IDs being 0. The fix is kind of complicated, but I will try to explain it.

 

Basically, remove the "public final static Block" before the variables and do "public static Block compactdirt;" before all the methods, but still in the "public class compactblocks". After that, move the setting of the variables (compactdirt = new compactdirt...) in the method marked with @Init. If you don't understand, write.

Link to comment
Share on other sites

You are creating blocks before IDs are generated.

 

You have to do any block = new BlockYours(id) after the id was correctly assigned.

sorry i dont understand what you mean?

Basically what he's saying is that you set the ID variables after registring the blocks, meaning that you are "creating" the blocks before setting the IDs, thus resulting in their IDs being 0. The fix is kind of complicated, but I will try to explain it.

 

Basically, remove the "public final static Block" before the variables and do "public static Block compactdirt;" before all the methods, but still in the "public class compactblocks". After that, move the setting of the variables (compactdirt = new compactdirt...) in the method marked with @Init. If you don't understand, write.

 

Thanks so much! :D

Link to comment
Share on other sites

You are creating blocks before IDs are generated.

 

You have to do any block = new BlockYours(id) after the id was correctly assigned.

sorry i dont understand what you mean?

Basically what he's saying is that you set the ID variables after registring the blocks, meaning that you are "creating" the blocks before setting the IDs, thus resulting in their IDs being 0. The fix is kind of complicated, but I will try to explain it.

 

Basically, remove the "public final static Block" before the variables and do "public static Block compactdirt;" before all the methods, but still in the "public class compactblocks". After that, move the setting of the variables (compactdirt = new compactdirt...) in the method marked with @Init. If you don't understand, write.

 

Get this error too, can you please create a dummy mod or something? So I can understand? Thanks!

Link to comment
Share on other sites

You are creating blocks before IDs are generated.

 

You have to do any block = new BlockYours(id) after the id was correctly assigned.

sorry i dont understand what you mean?

Basically what he's saying is that you set the ID variables after registring the blocks, meaning that you are "creating" the blocks before setting the IDs, thus resulting in their IDs being 0. The fix is kind of complicated, but I will try to explain it.

 

Basically, remove the "public final static Block" before the variables and do "public static Block compactdirt;" before all the methods, but still in the "public class compactblocks". After that, move the setting of the variables (compactdirt = new compactdirt...) in the method marked with @Init. If you don't understand, write.

 

Get this error too, can you please create a dummy mod or something? So I can understand? Thanks!

 

Il do it for you by tomorrow;

Link to comment
Share on other sites

You are creating blocks before IDs are generated.

 

You have to do any block = new BlockYours(id) after the id was correctly assigned.

sorry i dont understand what you mean?

Basically what he's saying is that you set the ID variables after registring the blocks, meaning that you are "creating" the blocks before setting the IDs, thus resulting in their IDs being 0. The fix is kind of complicated, but I will try to explain it.

 

Basically, remove the "public final static Block" before the variables and do "public static Block compactdirt;" before all the methods, but still in the "public class compactblocks". After that, move the setting of the variables (compactdirt = new compactdirt...) in the method marked with @Init. If you don't understand, write.

 

Get this error too, can you please create a dummy mod or something? So I can understand? Thanks!

 

done just have to lay it out like i was shown works the same for items

 

http://pastebin.com/6ALJaMwp

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.