Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.8.9] FMLMissingMappingsEvent and missing blocks


ShetiPhian
 Share

Recommended Posts

I've gone through all my mods and changed their modid's to lowercase, and cleaned up all block and item registered names and made them lowercase.

Thankfully I've only got one that has a non-alpha/public release so this doesn't affect the rest.

 

I've used FMLMissingMappingsEvent to remap the id's, but it doesn't seem to be fully working.

 

There is no missing blocks/items message on world load.

The item and itemblock are being replaced, as they still exist in inventory.

The block however is deleted from the world.

 

The log doesn't have any errors and even appears to be working.

[FML]: Injecting existing block and item data into this server instance
[FML]: Found a missing id from the world endertanks:blockEnderTank
[FML]: Found a missing id from the world endertanks:blockEnderTank
[FML]: Found a missing id from the world endertanks:itemEnderBucket
[endertanks]: Block Remap: endertanks:blockEnderTank > endertanks:ender_tank
[endertanks]: ItemBlock Remap: endertanks:blockEnderTank > endertanks:ender_tank
[endertanks]: Item Remap: endertanks:itemEnderBucket > endertanks:ender_bucket
[FML]: Fixed block id mismatch endertanks:ender_tank: -1 (init) -> 198 (map).
[FML]: Fixed item id mismatch endertanks:ender_tank: -1 (init) -> 4096 (map).
[FML]: Fixed item id mismatch endertanks:ender_bucket: -1 (init) -> 4097 (map).

 

Here is the remap code, its in the main class of my mod (with preInit, init, etc.) and is being executed as seen by log output and partly working remap.

@Mod.EventHandler
public void fmlMissingMappingsEvent(FMLMissingMappingsEvent event)
{
    for (FMLMissingMappingsEvent.MissingMapping mapping : event.getAll()) {
        if (Values.blockEnderTank != null && mapping.name.equalsIgnoreCase("EnderTanks:blockEnderTank")) {
            if (mapping.type == GameRegistry.Type.BLOCK) {
                Values.logEnderTanks.info("Block Remap: " + mapping.name + " > " + Values.blockEnderTank.getRegistryName());
                mapping.remap(Values.blockEnderTank);
            } else {
                Values.logEnderTanks.info("ItemBlock Remap: " + mapping.name + " > " + Values.blockEnderTank.getRegistryName());
                mapping.remap(Item.getItemFromBlock(Values.blockEnderTank));
            }
            continue;
        }
        if (Values.itemEnderBucket != null && mapping.name.equalsIgnoreCase("EnderTanks:itemEnderBucket")) {
            if (mapping.type == GameRegistry.Type.ITEM) {
                Values.logEnderTanks.info("Item Remap: " + mapping.name + " > " + Values.itemEnderBucket.getRegistryName());
                mapping.remap(Values.itemEnderBucket);
            }
        }
    }
}

 

 

EDIT:

I think the problem has been located.

PersistentRegistryManager.injectSnapshot

After the missed mapping have been handled in 'if (injectFrozenData)'

 

The remapping is ignored and any missing block is set to BlockDummyAir

 

EDIT2:

Well either I'm missing something or my options are between two "wrongs"; use mixed case naming, or use reflection to correct the registry.

I don't want to be responsible for accidentally messing up the registry on someones world, so I'll stick with the mixed case naming.

Link to comment
Share on other sites

When a brand-spanking new mod is added to a brand-spanking new world, there shouldn't be any of its blocks in that world needing remapping, so why are you doing remapping? (There's something missing from your story that means "the world" to us. What are you trying to do???)

The debugger is a powerful and necessary tool in any IDE, so learn how to use it. You'll be able to tell us more and get better help here if you investigate your runtime problems in the debugger before posting.

Link to comment
Share on other sites

I never specified if the worlds where new or not because there is no point in remapping on a new world.

 

I'll expand on my previous statement of "Thankfully I've only got one that has a non-alpha/public release so this doesn't affect the rest."

One of my mods is publicly released and used by many, I don't want to mess up those existing worlds.

The rest are either private rebuilds or public alpha, so I don't care about those worlds.

 

 

The problem is the remap process is broken; even after a successful remap in world blocks are replaced with dummy air.

I have two options; edit the registry via reflection (I'm not willing to do that) or leave the mixed case id's.

 

The mod id's case is automatically made lowercase in the registry so changing that required no remaps, and the remap works correctly for items.

That just leaves only the block that is going to remain with the 'wrong' mixed case id.

Link to comment
Share on other sites

Indeed, you didn't say anything about worlds, so there were too many possibilities to guess at.

 

So you're changing names in a mod but not moving from one Forge (or MC) version to another. There's hope, or at least there should have been. If what you say about injectSnapshot is correct and block remappings are all being ignored, then there may be a bug in Forge that needs to be reported (though it may have been fixed since 1.8.9). You might want to check the change logs.

 

Speaking of later versions, it is generally hopeless to "upgrade" existing modded worlds to later MC versions of Minecraft (possibly because block remapping is broken), so you can posit that it simply shouldn't even be attempted. That frees you to rename things with impunity when porting your mods to newer MC versions -- only new worlds will run with the new naming. Therefore, make a note to self to complete your case-change renaming when you next upgrade this mod (e.g. to 1.9.2)

The debugger is a powerful and necessary tool in any IDE, so learn how to use it. You'll be able to tell us more and get better help here if you investigate your runtime problems in the debugger before posting.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Ok, so I did some investigations and after a lot of trial and error, I finally came up with a solution. I will try to explain what I did, and why, for anyone who might need it. From what I understood, implementation will add a depedency for both compiling and runtime (pretty sure it will only include API files for compiling if there are, but I'm not 100% sure), and will resolve any nested depedencies aswell, so its kinda neat if one's mod permenently depends on other's mod or API ! Though I need to control whether a mod is included during runtime or not, so I need to specify the scope of my depedencies. I did some searches, and it turned out that Gradle will consume either jars or source folders regardless, so there is not a specific way to deal with one or the other it seems. I then tried the following and it worked like a charm (modified the commit branch / tags so its pointing to a permanent commit, more info here) ! depedencies { compileOnly 'com.github.lazyMods:baubles:1.10.0.0-1.18:api' runtimeOnly 'com.github.lazyMods:baubles:1.10.0.0-1.18' } But, whenever I try to run, the game crashes with a NoSuchMethod exception, pointing towards a method MenuScreens::m_96206_ called within the Baubles main class during ClientSetup (which is the unmapped name of MenuScreens::register) ; which is clearly a mapping issue. It confused me at first, but now that I think of it it's quite obvious : trying to run the game with uncompiled source files will cause all sorts of issues. And even if Jitpack seems to compile on the go those files, it will lack any metadata expected by Forge or ForgeGradle, so it's no use anyway. The only two solutions I can think of are : Download the mod jar, put it in a libs folder inside your workingDir that you can settup as a local repository, then add that jar as a runtime depedency Use CurseMaven as a repository (as @diesieben07 suggested), and add the correct mod jar as a depedency (more info here) I chose the latter, so now I have the following in my build.gradle file, and it works perfectly (one can even remove the ":api" from the baubles depedency to show the entire mod source files in Eclipse) : repositories { maven { url "https://cursemaven.com" content { includeGroup "curse.maven" } } maven { url "https://jitpack.io" } } depedencies { compileOnly "com.github.lazyMods:baubles:1.10.0.0-1.18:api" runtimeOnly fg.deobf("curse.maven:baubles-366844:3576950") // Points toward Baubles: Reborn? v1.10.0.1-1.18.1 on curseforge.com } I couldn't use CurseMaven straight up as lazynessmind didn't provide a source jar or an api jar on curse forge just yet, so I had to use its Github instead to get the API, hence the struggle. I could have added the mod jar itself as an API, but then I would have to manualy add the source files for Eclipse, which then makes this whole "manage your depedencies solely with Gradle" obsolete...   Thanks for the help, as I could not figure out those things on my own ! I hope that may be usefull to someone some day !
    • I am not sure where in your code the icon and tab name text are rendered.
    • So I've got myself a GUI similar to that of the Advancements screen or the Creative screen where I've got a main screen that renders the window, and tabs that render their own info. Everything works fine and dandy, until I have one of the tabs render text. When that happens, all other text rendered by the screen, along with the tab icon are no longer rendered. There seemingly are no errors, and when I try debugging I can see that each code path is still called so I'm not sure what's going on. So within my screen the main render function looks as follows public void render(MatrixStack matrixStack, int mouseX, int mouseY, float partialTicks) { int i = (this.width - GUI_WIDTH) / 2; int j = (this.height - GUI_HEIGHT) / 2; this.renderBackground(matrixStack); if (maxPages != 0) { ITextComponent page = new StringTextComponent(String.format("%d / %d", tabPage + 1, maxPages + 1)); int width = this.font.width(page); RenderSystem.disableLighting(); this.font.draw(matrixStack, page.getString(), i + (GUI_WIDTH / 2) - (width / 2), j - 44, -1); } this.drawWindowBackground(matrixStack, mouseX, mouseY, i, j); this.renderWindow(matrixStack, i, j); this.drawWindowTooltips(matrixStack, mouseX, mouseY, i, j); } The errant line is within this.drawWindowBackground(matrixStack, mouseX, mouseY, i, j);. Here we render the tab window itself. private void drawWindowBackground(MatrixStack matrixStack, int mouseX, int mouseY, int offsetX, int offsetY) { if (this.selectedTab == null) { fill(matrixStack, offsetX + 9, offsetY + 18, offsetX + 9 + 234, offsetY + 18 + 113, -16777216); int i = offsetX + 9 + 117; drawCenteredString(matrixStack, this.font, EMPTY, i, offsetY + 18 + 56 - 9 / 2, -1); drawCenteredString(matrixStack, this.font, SAD_LABEL, i, offsetY + 18 + 113 - 9, -1); } else { RenderSystem.pushMatrix(); RenderSystem.translatef((float)(offsetX + 9), (float)(offsetY + 18), 0.0F); this.selectedTab.drawTabBackground(matrixStack); RenderSystem.popMatrix(); RenderSystem.depthFunc(515); RenderSystem.disableDepthTest(); } } From there the tab draws itself as follows: public void drawTabBackground(MatrixStack matrixStack) { if (!this.centered) { this.scrollX = 117 - (this.maxX + this.minX) / 2.0D; this.scrollY = 56 - (this.maxY + this.minY) / 2.0D; this.centered = true; } RenderSystem.pushMatrix(); RenderSystem.enableDepthTest(); RenderSystem.translatef(0.0F, 0.0F, 950.0F); RenderSystem.colorMask(false, false, false, false); fill(matrixStack, 4680, 2260, -4680, -2260, -16777216); RenderSystem.colorMask(true, true, true, true); RenderSystem.translatef(0.0F, 0.0F, -950.0F); RenderSystem.depthFunc(518); fill(matrixStack, MAX_WIDTH, MAX_HEIGHT, 0, 0, -16777216); RenderSystem.depthFunc(515); this.minecraft.getTextureManager().bind(background); int i = MathHelper.floor(this.scrollX); int j = MathHelper.floor(this.scrollY); int k = i % 16; int l = j % 16; for(int i1 = -1; i1 <= 15; ++i1) { for(int j1 = -1; j1 <= 8; ++j1) { blit(matrixStack, k + 16 * i1, l + 16 * j1, 0.0F, 0.0F, 16, 16, 16, 16); } } this.renderWindow(matrixStack); RenderSystem.depthFunc(518); RenderSystem.translatef(0.0F, 0.0F, -950.0F); RenderSystem.colorMask(false, false, false, false); fill(matrixStack, 4680, 2260, -4680, -2260, -16777216); RenderSystem.colorMask(true, true, true, true); RenderSystem.translatef(0.0F, 0.0F, 950.0F); RenderSystem.depthFunc(515); RenderSystem.popMatrix(); } And finally we get to the errant line: this.renderWindow(matrixStack);. This method is overridden by each tab and renders the content of the tab. For my tab it is simple, we render a piece of text at the center of the tab. This text renders fine, however it breaks the tab icon and window name. @Override protected void renderWindow(MatrixStack matrixStack) { ITextComponent divineFavourText = new TranslationTextComponent("screen.mesoamericamythology.divine_relationships.favour.divine_favour", this.getRelationship().getDivineFavour()); // x, y, colour // This line breaks the rendering :( drawCenteredString(matrixStack, this.minecraft.font, divineFavourText, MAX_WIDTH / 2, MAX_HEIGHT / 2, Integer.parseInt("FFFFFF", 16)); } Below I have two screenshots. The one on the left is what the UI looks like when I don't draw the string in renderWindow. The right is what happens when I do. I'm a little befuddled at the moment. Hoping someone has more pointers that would help me understand what is going on.
    • User was banned for piracy. Buy the game.
    • Well, the errors seem as though they're tconstruct/jei, have you tried updating those? There are newer versions for 1.16 on curseforge for both of those mods. If you're convinced it's one of your dimensions mods, remove them 1 by one, or remove all and add them back 1 by 1, until you find the culprit.   *edit: what is tlskincape?
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.