Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Breaking tile entities provocates Minecraft to freeze


Hypsellis
 Share

Recommended Posts

I move this issue here like the devs told me on Github.

 

I noticed that the ender protal frames behaved them really strangely. When I try to destroy an ender portal frame with an ender eye inside, Minecraft totally freezes, then if I wait, Minecraft freezes eternally, and I'm obliged to kill Minecraft with MultiMC, and I don't any crash reports.

I can confirm now that this issue comes from Forge since there is no problems with Minecraft Vanilla, and the bug happens even if no mods are installed, only Forge. Some other blocks of other mods are touched by this bug too. The ones I noticed are :

 

- Building Brick : all the glass, ice and packed ice blocks

- Deep Resonance : resonant crystal

- Biomes O Plenty : celestial crystal

- Botania : mana prism

-  Blood Arsenal : blood stained glass block and pane

- Evilcraft : darktank

- EnderIO : killer joe, zombie generator, all the fused quartz glasses

- Random Things : lapis lamp, quartz lamp, rainbow lamp, biome glass, spectre block, fluid display

 

I let you know that all the tests possible has already been made before I create this general issue and post it. I already tried to :

 

- Test the mods one by one only by installing them and forge without any other mods

- Change of Forge Version

- Change between the 1.9 and 1.9.4 version

- Change of mod version

- Play without optifine and any shaders

- Switch between the creative and survival mode

- Delete and reinstall totally MultiMC, Forge and all the mods

 

Nothing of all that change anything, the bug still happens in the same way for the same blocks listed at the top. They always follow this log http://pastebin.com/vrY5Z3na .  I know what the error code -805306369 means, but it's not linked to my memory, I have 16 Go of memory and I gave 12 Go of memory to this Minecraft instance, so it's not possible that I lack of memory. The error code isn't caused by Minecraft but by MultiMC which kills Minecraft, so it's not the cause of the bug.

 

I already asked too to all the developpers of the mods concerned what could provocates this bug, nobody is able (with some who agressed me). For what I see, this bug touchs only the tile entities, and particulary the transparent, animated and lighted ones. Please don't tell me again that I'm stupid, that I understand nothing, that it's all my fault, that I'm a spammer... I already heard that too much from many developpers on GitHub and it begins to be very annoying. I'm myself a developper, so I know what to do or not.

 

Link to comment
Share on other sites

To me it looks like you've posted the log from MultiMC and not the logs from Forge or Minecraft.

 

If the log you posted isn't one of these:

 

"[path to minecraft]\crash-reports\crash-[date & time]-client.txt"

"[path to minecraft]\logs\fml-client-latest.log" (grab it right after a crash)

 

Post one or preferably both of them.

 

After reading through your problem description, your logs, what other people have said that they've tried, etc it's pretty obvious that this is a problem with MultiMC and/or your particular installation..more likely your installation unless it's a fringe case but MultiMC has a fairly large userbase so single fringe cases like this should be very very unlikely to occur.

 

Forge has a way way way WAY larger userbase with people using a plethora of different launchers ranging from vanilla launchers to launchers they coded themselves in an afternoon running on anything from embedded ARM cpu's in microwave owens to supercomputers with 1000s of cpus...if there was a problem with Forge that caused the client to crash when breaking blocks, the Forge crew would without any doubt what so ever hear about it within two seconds after the broken Forge build became availible to the public.

 

Just look at how many people come in here asking about why their cracked launchers wont work with Forge (scroll down in this forum and back a few pages, look at the locked threads...most of them got the posters banned), don't you think there would be quite a few _more_ who came in with a problem like this?

 

Yes, it's not _impossible_ that this really is an extreme fringe case-bug in Forge that no one has noticed before but so far you haven't provided any evidence that points towards that being the case, everything is pointing towards this being a problem with your system and/or your installation of Minecraft.

 

You claim that you're a developer and knows what to do and not to do, why then haven't you even tried to resolve the problem from your side first?

You've messed around with MultiMC, uninstalled it, reinstalled it, installed Forge to the left, right and center and you always get the same problem..which somehow lead you to conclude that there is a problem with Forge because Forge is the only common factor?

 

It never occured to you to try with another launcher, preferably the vanilla launcher that Forge actually supports?

 

It never occured to you, as a developer, to move everything out of Windows space in the \program files\ folder structures where permissions are actually enforced every now and then and programs that believes they own their own folder fail all the time because, you know, access denied..and every antivirus/bloatware from Norton ever released will break anything that do something unexpected within said folders (like saving, changing, removing, modifying, etc files within said folder structures)?

 

If you have to use MultiMC, use the generic Linux version (I'm assuming MultiMC is somewhat platform independent just like vanilla MC, Forge, every other launcher and most everything else written in Java and related to Minecraft out there is, if not..then try something else, just not the Windows installer version) which hopefully should install itself under your user profile, instead of in the Program Files folders, where Windows couldn't care less what you or any program you run does to your files.

 

I promise you, yes I promise, that doing any of the above (move MultiMC and everything else out of Program Files into a folder you have full access to or use the vanilla launcher instead (it can handle multiple instances just fine now, just install different profiles in different folders and you can play any Minecraft and Forge version you want) or use the generic Linux version of MultiMC) will solve the problem. You may get new problems because you did it wrong, which at this point feels like a likely thing you would do, but at least you can break end portals without crashing.

 

Yes, I may be setting myself up for a monumental fail here if this turns out to really be a very obscure bug in Forge that required a developer with an unheard of skill level to even find (yet still somehow fail to resolve and why haven't you made a PR with a patch already?) but I really doubt that and even if I somehow end up winning a dumbest post of the year award it's worth it just to tell you that...uhm..your attitude really could use some improving if you want to get friendlier responses from people.

 

 

Link to comment
Share on other sites

thank you Ravenleft for the wall of text

 

If you have to use MultiMC, use the generic Linux version

 

he/she is on windows

 

"[path to minecraft]\crash-reports\crash-[date & time]-client.txt"

 

no we want "[path to minecraft]\logs\fml-client-latest.log" (grab it right after a crash)

 

To me it looks like you've posted the log from MultiMC and not the logs from Forge or Minecraft.

 

the MMC(MultiMC) log is fine

 

but I really doubt that and even if I somehow end up winning a dumbest post of the year award it's worth it just to tell you that...uhm..your attitude really could use some improving if you want to get friendlier responses from people.

 

you are getting in dangerous territory

 

Yes, I may be setting myself up for a monumental fail here if this turns out to really be a very obscure bug in Forge that required a developer with an unheard of skill level to even find (yet still somehow fail to resolve and why haven't you made a PR with a patch already?)

 

WHAT ??????????

 

Just look at how many people come in here asking about why their cracked launchers wont work with Forge (scroll down in this forum and back a few pages, look at the locked threads...most of them got the posters banned), don't you think there would be quite a few _more_ who came in with a problem like this?

 

did you even read the log ??

 

 

 

Link to comment
Share on other sites

Ok already I will thank you because you seemed to have solved my problem, it was just simply a stupid problem of Windows permission wich messed my MultiMC installation. That it was the nice part, now let's speak about the wall of text you wrote.

 

Frankly this is really unhealth and mean to judge me or anybody else only by my forge and some github posts. You don't even know me, we never discussed together, but you judge like you knew me since many years. But you aren't the only one in this case, I got some violent answers of some developpers on GitHub when I reported them this issue. I really can't understand this kind of behaviour, I have been always correct with anybody, I haven't insulted or hurted anybody, my message is pretty clear and well explained. And before to yell on someone that he is a spammer or a stupid asshole, you take the time to understand the problem and check if the problem is true. And if it's not, you give suppositions of where the problem could come, or you just close the subject and move away. There is no need to answer violently by injures. This is really an immature behaviour.

 

And yeah I'm a developper, but you you are clearly not one when I see that you consider MultiMC like a cracked Minecraft version, that I should the Linux version while I'm on Windows and it won't change anything to the MultiMC behaviour itself. If you had readded my first post, you would have seen that I already tried to reinstall totally MultiMC, to use only Minecraft with Forge alone, to try with the Minecraft normal application and not MultiMC. And yhe MultiMC log is the forge log, if you had looked a bit the log you could have seen that all the informations come from forge and the mods wich depends of it. MultiMC only adds some informations at the beginning about the settings of the Minecraft session before Forge lauchs it and begin to register and set all the mods.

 

And even if I'm a developper, I'm an human after all. I do errors like everybody here. I can't think to all the possibilities. The developpers of Minecraft, Forge and all the mods wich exists do errors too. If they were perfect, they wouldn't take time to release alpha and beta versions before an official version, they wouldn't need to open an issue section, and take fun to solve all the issues that "annoying" people like me report them.

 

So yeah, you won the dumbest post of the year award.

 

So now the problem has been solved, I close this issue, sorry again for the bothering.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.