Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

"Two Errors" message when attempting to install


Recommended Posts

I'm using Magic Launcher to install my mods, and all went well until I had to get a new version of Forge. I forgot my previous version, but it was before 3.3.7. For sure. Anyways, I got the latest version, and I got "Two errors." The error log was as follows:

 

 

 

MagicLauncher 0.9.8

java.home: C:\Program Files\Java\jre7

java.runtime.name: Java SE Runtime Environment

java.runtime.version: 1.7.0_05-b05

os.name: Windows Vista

os.version: 6.0

os.arch: x86

sun.arch.data.model: 32

Missing class member: public static [Labn; biomeArray, class: ahy, mod: MinecraftForge-3.3.7.135-Client.zip

Class member is not public: private (ILjava/lang/String;)V <init>, class: vx, mod: MinecraftForge-3.3.7.135-Client.zip

Missing class member: public static [Labn; biomeArray, class: ahy, mod: minecraftforge-client-3.2.6.130.zip

Class member is not public: private (ILjava/lang/String;)V <init>, class: vx, mod: minecraftforge-client-3.2.6.130.zip

Missing class member: public static [Labn; biomeArray, class: ahy, mod: minecraftforge-client-3.3.7.135.zip

Class member is not public: private (ILjava/lang/String;)V <init>, class: vx, mod: minecraftforge-client-3.3.7.135.zip

 

 

Once I got the "two errors" message, I didn't download any other mod. But I ALWAYS downloaded in the order of Modloader, ModloaderMP, Forge, and then other mods.

I'm not at all sure why this is happening, for I was playing with it just fine not an hour ago. Any help would be appreciated.

Link to post
Share on other sites

Why are you trying to install three different forge mods (2 different versions) into Minecraft?  Something is VERY wrong with your set up. In addition, you no longer need ModLoader as its functionality is included in Forge now and ModLoaderMP is outdated. Mods should no longer be requiring ModLoaderMP.

Link to post
Share on other sites

I don't recall adding two other forge versions into my minecraft. Once I got the error, and Minecraft blackscreened, I deleted the .jar, ran minecraft, and tried again. I got the same result. Unless I'm missing something.

Link to post
Share on other sites

Oops, must have messed that up. I'll try to run a mod that requires Modloader & Forge to work. (Pam's Harvestcraft for this.)

 

 

--- BEGIN ERROR REPORT e8de9772 --------

Generated 6/16/12 1:40 PM

 

Minecraft: Minecraft 1.2.5

OS: Windows Vista (x86) version 6.0

Java: 1.7.0_05, Oracle Corporation

VM: Java HotSpot Client VM (mixed mode), Oracle Corporation

LWJGL: 2.4.2

OpenGL: ATI Radeon HD 2400 PRO    version 3.3.10834 Compatibility Profile Context, ATI Technologies Inc.

 

java.lang.NoSuchMethodError: pb.isGenMineableReplaceable(Lxd;III)Z

at eh.a(WorldGenMinable.java:61)

at yg.a(SourceFile:236)

at yg.b(SourceFile:250)

at yg.a(SourceFile:68)

at yg.a(SourceFile:27)

at abn.a(SourceFile:215)

at aly.a(SourceFile:460)

at ko.a(ChunkProvider.java:205)

at ack.a(Chunk.java:1192)

at ko.c(ChunkProvider.java:115)

at ko.b(ChunkProvider.java:128)

at xD.d(World.java:648)

at xD.a(World.java:563)

at net.minecraft.client.Minecraft.e(Minecraft.java:2199)

at net.minecraft.client.Minecraft.a(Minecraft.java:2085)

at net.minecraft.client.Minecraft.a(Minecraft.java:2032)

at net.minecraft.client.Minecraft.a(Minecraft.java:1943)

at xh.a(SourceFile:163)

at vp.a(SourceFile:74)

at xh.a(SourceFile:233)

at vp.f(SourceFile:122)

at vp.i(SourceFile:110)

at net.minecraft.client.Minecraft.k(Minecraft.java:1567)

at net.minecraft.client.Minecraft.x(Minecraft.java:822)

at net.minecraft.client.Minecraft.run(Minecraft.java:750)

at java.lang.Thread.run(Unknown Source)

--- END ERROR REPORT 34f77310 ----------

 

 

 

Mods loaded in order: Modloader, MinecraftForge, 4096Fix, Pam's Harvestcraft. I'm not sure if this means much towards the fix, but when I move the Forge up, on top of the Modloader, (As in Mods loaded: Forge, modloader, etc...) Modloader has 10 errors, and Forge is ok. The error report for the modloader error is as follows:

 

 

--- BEGIN ERROR REPORT 9f578458 --------

Generated 6/16/12 1:44 PM

 

Minecraft: Minecraft 1.2.5

OS: Windows Vista (x86) version 6.0

Java: 1.7.0_05, Oracle Corporation

VM: Java HotSpot Client VM (mixed mode), Oracle Corporation

LWJGL: 2.4.2

OpenGL: ATI Radeon HD 2400 PRO    version 3.3.10834 Compatibility Profile Context, ATI Technologies Inc.

 

cpw.mods.fml.common.LoaderException: java.lang.NullPointerException

at cpw.mods.fml.common.modloader.ModLoaderModContainer.preInit(ModLoaderModContainer.java:114)

at cpw.mods.fml.common.Loader.preModInit(Loader.java:235)

at cpw.mods.fml.common.Loader.loadMods(Loader.java:593)

at cpw.mods.fml.client.FMLClientHandler.onPreLoad(FMLClientHandler.java:193)

at net.minecraft.client.Minecraft.a(Minecraft.java:383)

at net.minecraft.client.Minecraft.run(Minecraft.java:735)

at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.NullPointerException

at ModLoader.registerTileEntity(ModLoader.java:1480)

at ModLoader.registerTileEntity(ModLoader.java:1470)

at mod_Pamfood.<init>(mod_Pamfood.java:735)

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance0(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at cpw.mods.fml.common.modloader.ModLoaderModContainer.preInit(ModLoaderModContainer.java:107)

... 6 more

--- END ERROR REPORT 5e84d0a2 ----------

 

 

Link to post
Share on other sites

Try leaving ModLoader out completely and see what happens. Try this even though a mod says it requires ModLoader. Forge is now supposed to be exactly duplicating ModLoader's functionality.

 

Also, the error message in your first log is caused by something you are installing in your jar file after forge is overwriting Forge's version pb.class (the Block class)

 

You left out the part of the log that lists mods, so you are on your own figuring out which one is doing this... :D

Link to post
Share on other sites

Forge duplicates Modloaders functionality...Did not know that. I put in Forge, put in Pams Harvestcraft, no 4096 fix, 'cause that was spouting errors up the wazoo, and...It worked. Nothing asploded, computer didn't meltdown...And I didn't even need to do much. Just remove one mod. Thank you, so much! I am now certain I am a complete idiot for not trying that.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.