Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Error when running Gradlew setupdecompworkspace


untamemadman
 Share

Recommended Posts

When I run the command gradlew setupdecompworkspace

I get the following error:

 

 

 

M:\untamemadman\Minecraft Mod\1.10\Test>gradlew setupdecompworkspace

Etag download for http://files.minecraftforge.net/maven/net/minecraftforge/forge/json failed with code 400

Error occurred parsing version!

This mapping 'snapshot_20160518' was designed for MC 1.9.4! Use at your own peril.

#################################################

        ForgeGradle 2.2-SNAPSHOT-59f33ec

  https://github.com/MinecraftForge/ForgeGradle

#################################################

              Powered by MCP unknown

            http://modcoderpack.com

        by: Searge, ProfMobius, Fesh0r,

        R4wk, ZeuX, IngisKahn, bspkrs

#################################################

:deobfCompileDummyTask

:deobfProvidedDummyTask

:getVersionJson

:extractUserdev

Download http://files.minecraftforge.net/maven/net/minecraftforge/forge/1.10-12.18.0.1982-1.10.0/forge-1.10-12.18.0.1982-1.10.0.pom

Download http://files.minecraftforge.net/maven/net/minecraftforge/forge/1.10-12.18.0.1982-1.10.0/forge-1.10-12.18.0.1982-1.10.0-userdev.jar

:extractDependencyATs SKIPPED

:extractMcpData

Download http://files.minecraftforge.net/maven/de/oceanlabs/mcp/mcp/1.10/mcp-1.10-srg.zip

:extractMcpMappings SKIPPED

:genSrgs

:downloadClient

:downloadServer

:splitServerJar

:mergeJars

:deobfMcSRG

Applying SpecialSource...

Applying Exceptor...

:decompileMc

[Fatal Error] jsr305-3.0.1.pom:2:1: Content is not allowed in prolog.

[Fatal Error] netty-1.6.pom:2:1: Content is not allowed in prolog.

[Fatal Error] authlib-1.5.22.pom:2:1: Content is not allowed in prolog.

Download https://libraries.minecraft.net/com/mojang/realms/1.9.1/realms-1.9.1.pom

[Fatal Error] fastutil-7.0.12_mojang.pom:2:1: Content is not allowed in prolog.

:decompileMc FAILED

 

FAILURE: Build failed with an exception.

 

* What went wrong:

Execution failed for task ':decompileMc'.

> Could not resolve all dependencies for configuration ':forgeGradleMcDeps'.

  > Could not resolve com.google.code.findbugs:jsr305:3.0.1.

    Required by:

        com.yourname.modid:Test:1.0

      > Could not resolve com.google.code.findbugs:jsr305:3.0.1.

        > Could not parse POM https://repo1.maven.org/maven2/com/google/code/findbugs/jsr305/3.0.1/jsr305-3.0.1.pom

            > Content is not allowed in prolog.

      > Could not resolve com.google.code.findbugs:jsr305:3.0.1.

        > Could not get resource 'https://libraries.minecraft.net/com/google/code/findbugs/jsr305/3.0.1/jsr305-3.0.1.pom'.

            > Could not HEAD 'https://libraries.minecraft.net/com/google/code/findbugs/jsr305/3.0.1/jsr305-3.0.1.pom'. Received status code 403 from server: Forbidden

  > Could not resolve com.mojang:netty:1.6.

    Required by:

        com.yourname.modid:Test:1.0

      > Could not resolve com.mojang:netty:1.6.

        > Could not parse POM https://libraries.minecraft.net/com/mojang/netty/1.6/netty-1.6.pom

            > Content is not allowed in prolog.

  > Could not resolve com.mojang:authlib:1.5.22.

    Required by:

        com.yourname.modid:Test:1.0

      > Could not resolve com.mojang:authlib:1.5.22.

        > Could not parse POM https://libraries.minecraft.net/com/mojang/authlib/1.5.22/authlib-1.5.22.pom

            > Content is not allowed in prolog.

  > Could not resolve it.unimi.dsi:fastutil:7.0.12_mojang.

    Required by:

        com.yourname.modid:Test:1.0

      > Could not resolve it.unimi.dsi:fastutil:7.0.12_mojang.

        > Could not parse POM https://libraries.minecraft.net/it/unimi/dsi/fastutil/7.0.12_mojang/fastutil-7.0.12_mojang.pom

            > Content is not allowed in prolog.

  > Could not resolve com.google.code.findbugs:jsr305:3.0.1.

    Required by:

        com.yourname.modid:Test:1.0

      > Could not resolve com.google.code.findbugs:jsr305:3.0.1.

        > Could not parse POM https://repo1.maven.org/maven2/com/google/code/findbugs/jsr305/3.0.1/jsr305-3.0.1.pom

            > Content is not allowed in prolog.

      > Could not resolve com.google.code.findbugs:jsr305:3.0.1.

        > Could not get resource 'https://libraries.minecraft.net/com/google/code/findbugs/jsr305/3.0.1/jsr305-3.0.1.pom'.

            > Could not HEAD 'https://libraries.minecraft.net/com/google/code/findbugs/jsr305/3.0.1/jsr305-3.0.1.pom'. Received status code 403 from server: Forbidden

 

* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

 

BUILD FAILED

 

Total time: 1 mins 13.291 secs

 

 

 

I got the same thing with both the 1.9.4 mdk and the new 1.10 mdk

Could someone help me?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • oh ok how can i remove it? i have already installed java 8 did it need a restart?  
    • Yes, downgrade it to one older Java 8 version.
    • OK, with java 8 says that:C:\Users\Utente\Desktop\minecraft server 1.16.5>java -Xmx16G -Xms16G -jar forge-1.16.5-36.2.22.jar --nogui 2022-01-23 21:48:25,419 main WARN Advanced terminal features are not available in this environment [21:48:25] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.22, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, --nogui] [21:48:25] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 17.0.2 by Oracle Corporation Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0x7ff95560) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0x7ff95560         at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:41)         at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95)         at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:41)         at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55)         at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708)         at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52)         at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47)         at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62)         at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55)         at cpw.mods.modlauncher.Launcher.main(Launcher.java:66)         at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63)         at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60)         at net.minecraftforge.server.ServerMain.main(ServerMain.java:57)
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.