Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[SOLVED] [1.8.9] Issues with my Container


Nxs0000
 Share

Recommended Posts

Hey,

 

I recently stared working on a TileEntity vitrine that display an item/itemBlock on it when it does contain one.

Basically the TileEntity contains 2 properties:

        
private ItemStack contained;
private EntityItem image;

the "image" is created from the "contained" with the it's property stackSize set to 1.

 

Now i wanted to add a Gui that would allow me to change the contained easily, so i created both the GuiContainer class and the Container one (and registered in the GuiHandler class)

To do all that i just followed bedrockminer's tutorials, changing what needed to be changed, but now i have some wierd issues: (all tested in a single player world)

- when i open the Container, the first Item in my Hotbar gets change into the item that is contained in the TileEntity, even though the item is still in it and clicking on the item in the contained slot take the one in my hotbar.

- when i close the Gui, this first item don't gets back to what it was before openning, and, when i open my inventory (in survival) i can see that some on the items from my hotbar got copied to the armor slots and crafting slots.

- I have to relog to get my inventory back right, as before i even openned the Container.

 

Here is my VitrineContainer construtor. The class is extending Container, have a property theVitr where I store the VitrineTileEntity.

public VitrineContainer(VitrineTileEntity vitr, IInventory player) {

	this.theVitr = vitr;
        	theVitr.openInventory(((InventoryPlayer)player).player);

                //Player  inventory
	for(int x = 0; x<9; x++){
		this.addSlotToContainer(new Slot(player, x, 8+x*18, 49+58));
	}

	for(int y = 0; y<3; y++){
		for(int x = 0; x<9; x++){
			this.addSlotToContainer(new Slot(player, 9+x+y*9, 8+x*18, 49 +18*y));
		}
	}

	this.addSlotToContainer(new Slot(vitr, 0, 8, 18)); // TileEntity's slot, top left of the Gui
}

 

I don't think the error could come from other classes since I barely created the Gui class just to draw a 1-row chest, and my VitrineBlock and VitrineTileEntity work fine and don't have much to do with the Container, exept for the TileEntity that extends IInventory so I completed the newly genereted methods to return the correct objects (slot 0 returning the contained ItemStack).

 

Maybe it only is an issue of synchronizing Server and Client since reloging correct the Inventory mess.

 

Before: 1470836268-2016-08-10-15-06-02.png

Open the Container: 1470836271-2016-08-10-15-06-06.png

Clicking on the contained Item: 1470836275-2016-08-10-15-07-54.png

Opening the inventory after closing the Container: 1470836273-2016-08-10-15-06-16.png

 

What is/could be wrong ? Thank you for any help

Link to comment
Share on other sites

I dont know if that is the problem, but I would recommend you to add the slots in this order:

1. Slot(s) of the TileEntity

2. Player Inventory

3. Player Hotbar

Since the Container uses a List of Slots it may be the problem

 

Also, what does

theVitr.openInventory

do?

Link to comment
Share on other sites

the openInventory call a method from the TileEntity that needed to be override, for now i left it empty.

 

I tried what you said:

Before: 1470841336-2016-08-10-16-55-47.png

After: 1470841338-2016-08-10-16-56-08.png

 

This really is weird: The inventory looks messed up but the item are just showed in the wrong place: for exemple, when i click on the second slot from the first row i get the 59 blaze powder... Plus, even so the slot for the Container displays the wool, clicking on it does nothing.

It seem to be a display issue now

Link to comment
Share on other sites

yea, it seems

 

I open the Cotainer by right-clicking on the Vitrine Block, then using this in "onBlockActivated"

if (!worldIn.isRemote) {
      playerIn.openGui(Main.instance, GuiHandler.getID(15), worldIn, pos.getX(), pos.getY(), pos.getZ()); //15 correspond to my Vitrine
}

 

GuiHandler

@Override
public Object getServerGuiElement(int ID, EntityPlayer player, World world, int x, int y, int z) {
	if(ID == 15)
		return new VitrineContainer((VitrineTileEntity) world.getTileEntity(new BlockPos(x,y,z)) , player.inventory);
    return null;
}

@Override
public Object getClientGuiElement(int ID, EntityPlayer player, World world, int x, int y, int z) {
    if(ID == 15)
    	return new GuiVitrine((VitrineTileEntity) world.getTileEntity(new BlockPos(x,y,z)) , player.inventory);
    return null;
}

 

Link to comment
Share on other sites

that could be the drawScreen, that doesn't display the item right since it doesn't understand my slots? Since i left if that way :

@Override
public void drawScreen(int mouseX, int mouseY, float partialTicks)
{
    super.drawScreen(mouseX, mouseY, partialTicks);
}

Link to comment
Share on other sites

ok... fml... I'm dumb

Thanks for the help guys! i juste messed up from the start >.<

 

The real issue was that I did @Override the initGui() to add my stuff and forgot to call the super back...

This caused the inventory to appear weird, which i tried to correct by changing the order in which the slots are registered.

 

Thanks for your time everyone,

Have a nice day !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • It doesn't work even if I remove every mod Please help
    • Hi, so I was making an item that sends info to the server to do some work, and I want the server to send the client back the results? How do I do that? Here is my code:   The snippet that sends the packet to the server SimpleChannelNetwork.CHANNEL.sendToServer(new CreateStructureCompass("fortress"));   The file that manage the traffic package io.github.bossmania.NetherandEndMaps.core.network; import io.github.bossmania.NetherandEndMaps.NetherandEndMaps; import io.github.bossmania.NetherandEndMaps.core.network.message.CreateStructureCompass; import net.minecraft.util.ResourceLocation; import net.minecraftforge.fml.network.NetworkRegistry; import net.minecraftforge.fml.network.simple.SimpleChannel; public class SimpleChannelNetwork { public static final String NETWORK_VERSION = "0.1.0"; public static final SimpleChannel CHANNEL = NetworkRegistry.newSimpleChannel( new ResourceLocation(NetherandEndMaps.MOD_ID, "network"), () -> NETWORK_VERSION, version -> version.equals(NETWORK_VERSION), version -> version.equals(NETWORK_VERSION)); public static void init() { CHANNEL.registerMessage(0, CreateStructureCompass.class ,CreateStructureCompass::encode, CreateStructureCompass::decode, CreateStructureCompass::handle); } }   the code that handle the packet receive and where I want the server to send back a packet to the client package io.github.bossmania.NetherandEndMaps.core.network.message; import java.util.function.Supplier; import io.github.bossmania.NetherandEndMaps.common.items.TemporaryItem; import net.minecraft.entity.player.ServerPlayerEntity; import net.minecraft.item.ItemStack; import net.minecraft.network.PacketBuffer; import net.minecraft.util.math.BlockPos; import net.minecraft.world.gen.feature.structure.Structure; import net.minecraft.world.server.ServerWorld; import net.minecraftforge.fml.network.NetworkEvent; import net.minecraft.item.Item; import net.minecraft.item.ItemGroup; public class CreateStructureCompass { public String structureType; public CreateStructureCompass() { } //create the constructor and store the structureType public CreateStructureCompass(String structureType) { this.structureType = structureType; } //encode the message public static void encode(CreateStructureCompass message, PacketBuffer buffer) { buffer.writeString(message.structureType); } //decode the message public static CreateStructureCompass decode(PacketBuffer buffer) { return new CreateStructureCompass(buffer.readString()); } //execute function when message is sent to server public static void handle(CreateStructureCompass message, Supplier<NetworkEvent.Context> contextSupplier) { NetworkEvent.Context context = contextSupplier.get(); context.enqueueWork(() -> { //get the player and the server ServerPlayerEntity player = context.getSender(); ServerWorld SEWorld = player.getServerWorld(); //get the location of the structure BlockPos structureLocation = SEWorld.func_241117_a_(Structure.FORTRESS, player.getPosition(),100, false); //this is where I want the server to send structureLocation back to the player }); context.setPacketHandled(true); } }  
    • I cannot get an instance of MC Forge to run with either the vanilla launcher or GDLauncher, yet vanilla MC and Fabric MC work fine in both.  I am running the latest versions of everything, and no 1.18-compatible version of Forge will launch even though they all install without fail. Using the vanilla launcher I get exit code 0 and the following logs: Debug log Latest log With GDLauncher I get the following console output:  
    • In 1.15 and before, you could get the item being held/dragged by the cursor using PlayerInventory#getItemStack. This no longer seems to be the case. How do we do this now?
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.