Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

SMP Problems Need fix


plarsootje
 Share

Recommended Posts

Hello, I have some SMP issues but i can't get it fixed

I'm making a mod and i want to run it on my server to

i have installed forge on both on my client everythings works when i run my server i get no error the mod is loaded but when i try to connect i get a screen on my client with nothing only on the buttom a "done" button i can't find a error report only on my server console it says "end.of.stream"

 

Can someone help

Maby i'm doing something whrong in my code

 

Here is my code

 

Please can someone help i'm trying to fix it already 4 days:(

 

mod_runescape.class

 

package net.runescape;

 

import net.minecraft.block.Block;

import cpw.mods.fml.common.Mod;

import cpw.mods.fml.common.Mod.Init;

import cpw.mods.fml.common.Mod.Instance;

import cpw.mods.fml.common.Mod.PostInit;

import cpw.mods.fml.common.Mod.PreInit;

import cpw.mods.fml.common.SidedProxy;

import cpw.mods.fml.common.event.FMLInitializationEvent;

import cpw.mods.fml.common.event.FMLPostInitializationEvent;

import cpw.mods.fml.common.event.FMLPreInitializationEvent;

import cpw.mods.fml.common.network.NetworkMod;

import cpw.mods.fml.common.registry.GameRegistry;

import cpw.mods.fml.common.registry.LanguageRegistry;

 

@Mod(modid="Runescape", name="Runescape", version="v1.0")

@NetworkMod(clientSideRequired=true, serverSideRequired=false)

public class mod_runescape {

 

public static Block DragonStone;

 

        @Instance("mod_runescape")

        public static mod_runescape instance;

       

        @SidedProxy(clientSide="net.runescape.ClientProxy", serverSide="net.runescape.CommonProxy")

        public static CommonProxy proxy;

       

        @PreInit

        public void preInit(FMLPreInitializationEvent event) {

        }

       

        @Init

        public void load(FMLInitializationEvent event) {

                proxy.registerRenderers();

                DragonStone =(new DragonStoneBlock(3000,0)).setBlockName("DragonStoneBlock").setHardness(1F).setResistance(5F);

                GameRegistry.registerBlock(DragonStone);

                LanguageRegistry.addName(DragonStone, "DragonStone");

        }

       

        @PostInit

        public void postInit(FMLPostInitializationEvent event) {

        }

}

 

 

CommonProxy.class

 

package net.runescape;

 

public class CommonProxy {

        public static String BLOCK_PNG = "/mod/blocks.png";

       

        public void registerRenderers() {

        }

}

 

 

ClientProxy.class

 

package net.runescape;

 

import net.minecraftforge.client.MinecraftForgeClient;

 

public class ClientProxy extends CommonProxy {

       

        @Override

        public void registerRenderers() {

                MinecraftForgeClient.preloadTexture(BLOCK_PNG);

        }

       

}

 

Link to comment
Share on other sites

That's what my Minecraft_Server.jar says

 

[iNFO] Starting minecraft server version 1.4.5

[WARNING] To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"

[iNFO] Loading properties

[iNFO] Default game type: SURVIVAL

[iNFO] Generating keypair

[iNFO] Starting Minecraft server on *:25565

[iNFO] Preparing level "world"

[iNFO] Preparing start region for level 0

[iNFO] Preparing spawn area: 87%

[iNFO] Done (1,420s)! For help, type "help" or "?"

[iNFO] User plarsootje connecting with mods [Runescape]

[iNFO] plarsootje[/127.0.0.1:58983] logged in with entity id 309 at (51.5, 67.62000000476837, 252.5)

[iNFO] plarsootje lost connection: disconnect.endOfStream

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • hi i made the accesstransformer.cfg file with the text it needs for what im doing, but i dont know how to refresh the gradle project, in eclipse you right click in the project, gradle and refresh gradle project but im using intellij and all the tutorials for accesstransformers are made for eclipse #AbstractClientPlayerEntity public net.minecraft.client.entity.player.AbstractClientPlayerEntity field_175157_a # playerInfo #NetworkPlayerInfo public net.minecraft.client.network.play.NetworkPlayerInfo field_187107_a # playerTextures public net.minecraft.client.network.play.NetworkPlayerInfo field_178864_d # playerTexturesLoaded public net.minecraft.client.network.play.NetworkPlayerInfo func_178841_j()V # loadPlayerTextures public net.minecraft.client.network.play.NetworkPlayerInfo field_178867_a # gameProfile  
    • i wrote the accessmodifier thing, refreshed the build.gradle file and even restarted my idle but it didnt worked, i checked the location of where the .cfg file should be but there is nothing(src/main/resources/META-INF/accesstransformer.cfg), there is only the mods.toml
    • Did you had a look at the link to the Forge doc I attached?
    • I have a server on Forge, no mods installed, version 1.16.5.  If I try to do any update on a new release the placed block values randomize.  Basically, the grass turns to rail road tracks, horses are dolphins grazing grass, chickens are fish sliding around on the grass, and the ender dragon is raining fire and hell down on the world.  It's a interesting take on the game.  However, you can't play this scrambled mess.  The block will look correct in your hand, but once place it's anyone's guess what it becomes. There is literally zombie army's marching single file LOL...So the server is currently stuck on 1.16.5 and I can't update it basically.  If I reload my backup to the version 1.16.5 all order is restored.   I have updated my account, java, and reinstalled Minecraft.  Single player works fine on new world creations....it's just this server and trying to update.  It has been updated many times in the past, as it's a couple years old...any suggestions?
    • I know this is basic java knowledge but PLEASE tell me a solution, i already learned java but i never imagined how i can use public, private and protected(obviusly i use them but i dont know how to connect private fieds so my class) im BEGGING YOU tell me how, i tried some tutorials of how to access to private fields but it wasnt helpful
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.