Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.10] [SOLVED] Translucent particles only overlap from certain angles?


Ferrettomato
 Share

Recommended Posts

I'm making a custom particle that is partially semi-transparent. I want the alpha of the particles to combine (so that two low-alpha parts appear high-alpha when overlapping), instead of hiding the particles behind them. The particles do this, but only when the player is facing in the direction the particle is traveling. How can I get the particles to overlap regardless of the player's looking direction?

 

My particle's render function:

    @Override
    public void renderParticle(VertexBuffer worldRendererIn, Entity entityIn, float partialTicks, float rotationX, float rotationZ, float rotationYZ, float rotationXY, float rotationXZ)
    {
//        this.theRenderEngine.bindTexture(rLocPortal);
//        super.renderParticle(worldRendererIn, entityIn, partialTicks, rotationX, rotationZ, rotationYZ, rotationXY, rotationXZ);
//        int i = 1;//(int)(((float)this.life + partialTicks) * 15.0F / (float)this.lifeTime);

//        if (i <= 15)
//        {
            GlStateManager.enableAlpha();
            GL11.glEnable(GL11.GL_BLEND);
            this.theRenderEngine.bindTexture(rLoc);
            float f = /*(float)(i % 4) /*/ (0.0f);
            float f1 = 1;//f + 0.24975F;
            float f2 = /*float)(i / 4) /*/ (0.0f);
            float f3 = 1;//f2 + 0.24975F;
            float f4 = 0.3F;
            float f5 = (float)(this.prevPosX + (this.posX - this.prevPosX) * (double)partialTicks - interpPosX);
            float f6 = (float)(this.prevPosY + (this.posY - this.prevPosY) * (double)partialTicks - interpPosY);
            float f7 = (float)(this.prevPosZ + (this.posZ - this.prevPosZ) * (double)partialTicks - interpPosZ);
            GlStateManager.color(0.0F, 0.0F, 0.0F, 1.0F);
            this.particleAlpha = 1F;
            this.particleRed = 1F;
            this.particleBlue = 1F;
            this.particleGreen = 1F;
            GlStateManager.disableLighting();
            RenderHelper.disableStandardItemLighting();
            worldRendererIn.begin(7, VERTEX_FORMAT);
            worldRendererIn.pos((double)(f5 - rotationX * f4 - rotationXY * f4), (double)(f6 - rotationZ * f4), (double)(f7 - rotationYZ * f4 - rotationXZ * f4)).tex((double)f1, (double)f3).color(this.particleRed, this.particleGreen, this.particleBlue, this.particleAlpha).lightmap(0, 240).normal(0.0F, 1.0F, 0.0F).endVertex();
            worldRendererIn.pos((double)(f5 - rotationX * f4 + rotationXY * f4), (double)(f6 + rotationZ * f4), (double)(f7 - rotationYZ * f4 + rotationXZ * f4)).tex((double)f1, (double)f2).color(this.particleRed, this.particleGreen, this.particleBlue, this.particleAlpha).lightmap(0, 240).normal(0.0F, 1.0F, 0.0F).endVertex();
            worldRendererIn.pos((double)(f5 + rotationX * f4 + rotationXY * f4), (double)(f6 + rotationZ * f4), (double)(f7 + rotationYZ * f4 + rotationXZ * f4)).tex((double)f, (double)f2).color(this.particleRed, this.particleGreen, this.particleBlue, this.particleAlpha).lightmap(0, 240).normal(0.0F, 1.0F, 0.0F).endVertex();
            worldRendererIn.pos((double)(f5 + rotationX * f4 - rotationXY * f4), (double)(f6 - rotationZ * f4), (double)(f7 + rotationYZ * f4 - rotationXZ * f4)).tex((double)f, (double)f3).color(this.particleRed, this.particleGreen, this.particleBlue, this.particleAlpha).lightmap(0, 240).normal(0.0F, 1.0F, 0.0F).endVertex();
            Tessellator.getInstance().draw();
            GlStateManager.enableLighting();
            GL11.glDisable(GL11.GL_BLEND);
//        }
    }

 

Apologies if I'm using strange terminology. I'm new to rendering and such.

Link to comment
Share on other sites

Hi

 

Unfortunately there's no real robust answer to this problem - translucent (alpha blending) rendering is sensitive to the order you draw the objects in. 

https://www.opengl.org/wiki/Transparency_Sorting

and

http://www.opengl-tutorial.org/intermediate-tutorials/tutorial-10-transparency/

 

You could try turn off writing to the depth mask- currently, when the front particle renders first, it completely hides the one behind it, i.e. the one behind it never draws at all because it is behind the depth mask of the front particle.  But this will cause some weird other effects - the appearance may change depending on whether the front particle renders first, or the back particle renders first, and whether the particles are behind another translucent block (eg water or stained glass). 

 

The OpenGL commands you could try are

glDepthMask for writing to the depth mask (stops your particle from hiding anything that is drawn afterwards)

glDepthFunc for ignoring the depth mask when rendering (makes your particle always render even if it's behind other objects

Try them one at a time - you don't need them both.  I'm pretty sure glDepthFunc is not what you want to achieve but just in case.

 

This is a good info source on OpenGL

http://www.glprogramming.com/red/

and especially

http://www.glprogramming.com/red/chapter06.html

and

http://www.glprogramming.com/red/chapter10.html#name7

 

-TGG

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.