Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.11/1.10/1.9] Shared jar possible?


Zeno410
 Share

Recommended Posts

I have a mod, originally compiled in 1.9.4, which is still usable in 10.2 (which is great, one less version to maintain). However, when I try to run in 1.11, I get a "does not wish to run in Minecraft version Minecraft 1.11" error, without a reason. There are no explicit version requirements in the mod code. How is Forge deciding which mod jars are runnable in 1.11, and is there any way to share a jar across that range?

Link to comment
Share on other sites

Short answer no.

 

There were too many breaking changes in 1.11 for it be be feasible for the jar compiled in 1.9.4 to work on 1.11.

 

The 1.9.4 to 1.10.2 changes were small and didn't touch anything fundamentally so it was possible and forge special cased that mods would work between those versions.

 

Forge decides which version a mod works on by saying that the version it is compiled against unless stated otherwise by the mod(or forge) that that mc version is the one that it works on.

If I sound like a jerk it's because I'm tired

Link to comment
Share on other sites

I seem to have solved my own problem. I added acceptedMinecraftVersions = "[1.9.4,1.11]" to my @Mod annotation, and the mod attempts to run on all three versions. (The mods are a range, not a list, which tripped me up for a while).

 

Since this mod (Geographicraft) interacts only with the GenLayer stack, which is very stable over Minecraft versions (it hasn't changed since 1.8 ) it actually can run on all three versions.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.