Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge and Custom Language Files


Recommended Posts

Somehow, Forge doesn't work with a custom language file I want to use.

The language file I want to use is the Last Days Language pack. You can download it at http://adf.ly/Ei7i1.

I'm using MagicLauncher 1.0.0 to install mods etc.

Now, I'm putting the language stuff in a folder called "lang" in the same folder as the Minecraft.app is (yes, I'm on mac). OR I'm modding the jar file and put the language files directly in it, the outcome is the same:

Without Forge (I'm ONLY using forge for testing, no other mods at all), everything loads fine. Minecraft works and the language file is there.

Now, if I activate Forge, Minecraft loads up correctly with forge - but no sign of the language file.

If I start without Forge, choose the language file, quit Minecraft and start with Forge, Minecraft crashes after the splash. Here is the short log:



      Minecraft has crashed!     



Minecraft has stopped running because it encountered a problem; Failed to start game


A full error report has been saved to /Users/Corny/Library/Application Support/minecraft/crash-reports/crash-2013-01-08_14.40.22-client.txt - Please include a copy of that file (Not this screen!) if you report this crash to anyone; without it, they will not be able to help fix the crash :(




--- BEGIN ERROR REPORT c4d832ab --------

Full report at:

/Users/Corny/Library/Application Support/minecraft/crash-reports/crash-2013-01-08_14.40.22-client.txt

Please show that file to Mojang, NOT just this screen!


Generated 08.01.13 14:40


-- System Details --


Minecraft Version: 1.4.6

Operating System: Mac OS X (x86_64) version 10.8.2

Java Version: 1.6.0_37, Apple Inc.

Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Apple Inc.

Memory: 318228256 bytes (303 MB) / 362414080 bytes (345 MB) up to 362414080 bytes (345 MB)

JVM Flags: 2 total; -Xms350m -Xmx350m

AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

Suspicious classes: FML and Forge are installed

IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

FML: MCP v7.25 FML v4.6.12.511 Minecraft Forge 3 mods loaded, 3 mods active

mcp [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized

FML [Forge Mod Loader] (coremods) Unloaded->Constructed->Pre-initialized

Forge [Minecraft Forge] (coremods) Unloaded->Constructed->Pre-initialized

LWJGL: 2.4.2

OpenGL: Intel HD Graphics 3000 OpenGL Engine GL version 2.1 APPLE-8.0.61, Intel Inc.

Is Modded: Definitely; Client brand changed to 'forge,fml'

Type: Client (map_client.txt)

Texture Pack: Last Days  1.3.1.zip

Profiler Position: N/A (disabled)

Vec3 Pool Size: ~~ERROR~~ NullPointerException: null



at java.io.Reader.<init>(Reader.java:61)

at java.io.InputStreamReader.<init>(InputStreamReader.java:80)

at bn.a(StringTranslate.java:77)

at bn.a(StringTranslate.java:117)

at net.minecraft.client.Minecraft.a(Minecraft.java:414)

at asq.a(SourceFile:56)

at net.minecraft.client.Minecraft.run(Minecraft.java:744)

at java.lang.Thread.run(Thread.java:680)

--- END ERROR REPORT 1c985cf0 ----------



Other logs:

(I can't upload attachments)

full report.

Forge log


I noticed that the custom .lang-file has different permissions set than the ones that come with minecraft. I tried to change that (via terminal), but still couldn't get it to run.

Link to comment
Share on other sites

Interesting, it seems that it can not find your language file, meaning its not in the class path.

Where exactly are you installling it to and how are you running Minecraft?

If you stick it, and just it {not all the random mac files that are in the zip -.-} into your minecraft jar it should work fine. {It does in my tests}

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

I don't know exactly what you want to know, so sorry if I repeat myself or tell you something you know already.


I tried:

1. putting the languages.txt and en_LD.lang into ~/Library/Application Support/minecraft/minecraft.jar/lang

2. putting the languages.txt and en_LD.lang into /Applications/Minecraft/lang

(Minecraft.app is in /Applications/Minecraft)


Both times, I would start Minecraft with MagicLauncher, with an unpatched minecraft.jar and Forge as the only mod selected.

I was quite certain that I only copied the two files, but checked again for random mac files (you do mean .DS_Store, right?) - none in there.

If you can't reproduce it on another Mac, then it looks like it is somehow my fault. No idea what I've done wrong, though. :(

Link to comment
Share on other sites

Today, I installed the language packs via MagicLauncher, the mod order being 1. Forge and 2. language pack. Now it works.

I didn't do that before because MagicLauncher would tell me it didn't find any mods in that zip. Looks like it's wrong.

Not sure what exactly is the issue, but now I know a way around it (and so does everyone who has the same problem and finds this topic).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.