Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can't get enough RAM to run


Recommended Posts

I have spent the better part of two days troubleshooting this issue, but to no avail. Making an account and posting here is my last resort. 

In short, Forge is trying to open with what appears to be only 500 MB of RAM.

 ws1e0z.jpg

When it tries to run, it usually dies before a single block is loaded. Sounds load fine, but I cannot move and I cannot put in any commands. I can die before it crashes though, apparently. I do not know how to access the crash data on the new launcher. 

I have the newest version of the Minecraft Launcher downloaded. I have the newest version of Java. My computer's graphics drivers are up to date. I have tried allocating more RAM to Java directly. I have tried allocating more RAM to minecraft's JVM Arguments via five or six different codes/fixes. The most progress I have had is editing the RAM numbers in the JVM has made Forge's memory drop down to 470-460 MB. No consistency between the amount of drop and the change in RAM on the JVM Arguments. And, yes, I have tried turning it off and on again.

I'm lost.

Plz help. 

 

Edited by SirinaSplendora
Link to post
Share on other sites

You said (and your screenshot shows) that you have the loading screen enabled, but the log tells me otherwise...

Please post the log of a run with the loading screen enabled or post what exactly you put in the launch profile settings of your launcher.

Edited by diesieben07
  • Like 1
Link to post
Share on other sites

Do -Xmx3G -Xms3G in the launcher. Nothing else. If it tells you could not reserve enough space for heap space or whatever,  lower the values.

Apparently I'm addicted to these forums and can't help but read all the posts. So if I somehow help you, please click the "Like This" button, it helps.

Link to post
Share on other sites

hi,

Quote

    JVM Flags: 7 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx3G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn384M -Xmx512M

You have a system or user variable called "_JAVA_OPTIONS" that redefine -Xmx to 512 MB.
Follow this picture to remove it :

036b40aa6a.png

Edited by robin4002
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.