Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Mod incompatibility regression: Mumblelink


keybounce
 Share

Recommended Posts

Forge compatibility issue.

 

Forge is now failing to work with MumbleLink.

 

Regression: Worked perfectly in 145 with 443. I cannot get it to work in 147 with either 499 (stable/optifine) or 524 (latest)

 

Logs:

 

1. MultiMC, 147, 524, in jar. No other mods. Identifies a basemod mod_MumbleLink, in minecraft.jar, but then fail to find the class at construction time.

http://pastebin.com/fSHxVN1D

 

2. MultiMC, 147, 524, in mods folder. Same setup. Same issue.

http://pastebin.com/PrtfECGA

 

3. Magic Launcher, 145, 443, in internal mods. Works.

Note that even though it is "internal", it still gets identified by the mod filename and not just "minecraft.jar"

http://pastebin.com/ncsDwpjr

 

Note also that this has about 20 mods.

 

4. Magic Launcher, 147/524, internal mods. Fails.

http://pastebin.com/18ScdzS2

 

Notes:

Folder "MumbleLink" in the mods folder contains the native libraries that mumble link uses.

 

Jeb! The sheep! The fence pens, they do nothing still leak!

Link to comment
Share on other sites

Additional note:

 

Unpacking the zip file into the mods directory does work. Odd. This was not needed in prior versions. (This puts all the contents of the mod in the mods/MumbleLink directory)

 

Log file (499): http://pastebin.com/HLKtfdYm

 

I did not see any differences in the lines relating to MumbleLink other than the lack of the zip file name and the order (mod now found after the directory).

Jeb! The sheep! The fence pens, they do nothing still leak!

Link to comment
Share on other sites

This is causes by a mod author putting their mod in a sub folder inside the zip. If they packaged it correctly it would work fine.

 

Additionally - check the install instructions:

 

www.minecraftforum.net/topic/217587-147-mod-mumblelink-ml-smp-lan-mumble-realism-directional-voip/

 

It does state to unzip it.

Link to comment
Share on other sites

Yea, I noticed that. As I said, it works if I unpack it, but I haven't needed to in 132, 142, 145. Only now.

 

Maybe the author changed how they packed it?

 

(goes to compare ...)

Yep, this was the first time it's inside a subdir. Fun :-).

 

EDIT: Thank you.

Jeb! The sheep! The fence pens, they do nothing still leak!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.