Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[SOLVED] [1.12] Obfuscated Field Name for Reflection Use?


IceMetalPunk
 Share

Recommended Posts

I was just about ready to release my new mod, and then I built it and tested it fully...and it crashes. Why? Because part of my code uses the ReflectionHelper to get a private field's value from a vanilla tile entity class, but I only know the deobfuscated name, and so in the build version (when everything is obfuscated again), that field doesn't exist.

How do I find the obfuscated field names to access with the ReflectionHelper? I've looked in MCP's conf/fields.csv file, but the field I'm looking for is not listed there.

 

The field, by the way, is TileEntityShulkerBox#openCount. In the development environment, accessing that field with the ReflectionHelper works; but without the obfuscated identifier, it completely crashes in the production environment.

Please help? It's so close to release ;~;

 

EDIT Well, instead of panicking, I should have Googled for five more minutes before I posted this... I found it :) For anyone reading, I found this nice Bash script that finds all the rename map entries for a given field name (when run from your modding directory):  grep -rnw './' -e "openCount" | awk -F: '/RENAME MAP/ {print $4}' (Obviously, you can change the "openCount" to the field name you're looking for.) It outputs every matching field, its obfuscated version, and the class it's found it, which is all very useful. In this case, TileEntityShulkerBox#openCount is mapped from a field named field_190598_h, so I added that to the parameter list for my ReflectionHelper's call, and boom, everything works now :D

 

(After looking into it a little more, a faster script is this: grep -w './build/taskLogs/retroMapReplacedMain.log' -e "openCount" | awk -F: '/RENAME MAP/ {print $2}' ; that is assuming the map replacement log is in the path for every version of Forge, though, which might not be a valid assumption.)

Edited by IceMetalPunk
Solved

Whatever Minecraft needs, it is most likely not yet another tool tier.

Link to comment
Share on other sites

14 minutes ago, Elix_x said:

I didn't know that was a thing. Seems about as easy to use as the script anyway; but thanks for letting me know I have options :)

 

EDIT Plus, that command can be simplified even further: grep -w './build/taskLogs/retroMapReplacedMain.log' -e "openCount" | awk -F: '{print $2}' (All it does is search the map replacement log for the field in question, then passes the matched lines to awk to split it up at the colon delimiters.)

Edited by IceMetalPunk

Whatever Minecraft needs, it is most likely not yet another tool tier.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • show the code your use for this is the Event called?, use debugger to check the values in the condition
    • if you add your Biome to the Overworld via BiomeManager#addAdditionalOverworldBiomes, you need to register your Biome via DeferredRegister or RegistryEvent unfortunately a json only Biome does not work in this case
    • use debugger to check the conditions you are using before you render your Entity
    • yes, and then post the correct logs
    • Good Morning, I tried overriding one of the vanilla rock blocks according to instructions in this old thread, but failed for the same reason the org TM did, even though I got a tiny bit farther than he did. I can remove the original block entirely from world spawn, and replace it with custom version, which I want to prevent due to following up workload(adapting recipes etc. to custom block). What I tried solving the issue/actually making replacing(partially) work: 1. I had to use the original Forge variant of registering the block in main class, like that: which actually did use the custom granite block as replacer(not exactly illustrated in the old thread), but didn't consider it on world feature generation... 2. I then believed it was due to not using correct path variables for assets texture/models/blockstates etc., so I created missing asset packets for both, vanilla asset path, and my mod path. This also did not fix the issue with creating holes filled up with Items.AIR on world feature generation. 3. I then tried to remove the vanilla granite block during feature generation, and reimported it after with my replacement set up, during feature generation as well(according to @Luis_ST advice). But the holes were still there, only this time I got my replaced granite block spawned as well. What do I want to achieve(asking myself and you in hope maybe there's a better solution)? Mojang found it a good idea, to give one of the hardest rock materials on this planet, the .harvestLevel(soft as a pillow), so I can harvest it with a wooden pickaxes(which technically is even worth, but doesn't matter since wooden "pickaxe" tools do not exist in my mod). I really just want to compare harvestLevel of any of my tools, against the harvestLevel of the targetBlock, so I can automatically disallow harvesting it, if the tool doesn't match the harvestLevel(which for whatever reason does not work as intended in 1.16.5 Minecraft). Edit: and before you shout "doPlayerHarvestCheck". Yes, I do that! Edit2: Also, why are there Manga Comic Girls, on the right upper corner of my Monitor, stating how can it be that big?(whatever "it" is?)
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.