Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.12] How to get crafting result from a custom crafting table?


ctbe
 Share

Recommended Posts

I made a custom crafting table. In the Container it has a variable of type InventoryCrafting named craftMatrix, like the ContainerWorkbench class. It also has a variable of type InventoryCraftResult named craftResult. The thing is that that when I craft something and put the resulting ItemStack in the output slot, I can take it from it, but the ItemStacks in craftMatrix, increase twice in size. I debugged for hours to find what was going on and found that the responsible for said behavior was the method slotClick from the Container class. I overrode the slotClick method and canceled the call to super, but if I do that, I can't move items in or out the custom crafting table.

 

Debugging was hard because the super slotClick method is huge and is not commented. It was hard to put so many breakpoints just to see what the code was doing and I still don't know why it does what it does. The call to super is doing this:

 

  1. Allows the player to take the item.
  2. Reduces the stack count in craftMatrix by one.
  3. It doubles the stack count in craftMatrix.

 

So for example, if you had 4 planks in one slot on the craftMatrix (not the output), after taking the output of the crafting table, it leaves you with 3 planks, and then it converts those to 6 planks. If you take a result again, it reduces the planks to 5, then it makes them be 10. All that happens in the slotClick method of the Container class. I cannot identify why or how it is doing so. This is all my code in the overridden slotClick method

 

  override def slotClick(slotId: Int, dragType: Int, clickTypeIn: ClickType, player: EntityPlayer): ItemStack = {
    super.slotClick(slotId, dragType, clickTypeIn, player)
  }

 

If I change that code to return the ItemStack of the slot that was clicked and cancel the call to super, nothing happens. I can't use the crafting table at all. Is there a way to get the result of the crafting table without the items in the craftMatrix being duplicated?

 

Edit: I found what is duplicating the size, but don't know if it is a bug. The slotClick super method is calling the method onTake on the output slot (craftResult in this case). Inside there it gets two stacks in two variables. The stacks are the same ones. Each one represent a stack in the craftingMatrix, only that the code is getting the same stack in each variable. Then it compares if the ItemStacks are equal. If they are, it grows the stacks.

 

Edit: I can finally see what is going on. It is a lengthy process. The reason it works on normal crafting tables and not on custom ones is that normal crafting tables deal with recipes of type IRecipe that are in the game registry. When that happens, the onTake method gets a list of empty stacks and as a consequence it doesn't grow the craftingMatrix of the ContainerWorkbench in the method. If you are making a custom crafting table so your table recipes are therefore custom and not registered in the game registry as IRecipe, you will get a list that is equal to that of the craftingMatrix. That causes the onTake method to decrease the stack size by one and then duplicate it.

 

Only workarounds I find is either register my custom crafting table recipes as IRecipe in the game registry or remember the stack sizes before calling super in slotClick so that I can restore it after the call. But I don't know what will happen if I register my custom recipes in the game registry. I mean, the whole point of a custom crafting table is to have crafting that can be done only on that table. If the crafting can be done on a normal crafting table then the custom crafting table is useless.

Edited by ctbe
Add information
Link to comment
Share on other sites

The problem is in your recipe class's getRemainingItems method.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

19 minutes ago, Draco18s said:

The problem is in your recipe class's getRemainingItems method.

Yes. I just found that out and edited my main post. :(

 

I'll check how to fix it because my recipes are custom, but don't extend IRecipe. I was using another way of matching recipes, etc. Now I understand it wasn't the correct way. My question is though, if I register my custom recipes (as IRecipe) in the GameRegistry, will they be craftable in a normal crafting table? Because I want them only be craftable on my custom crafting table, not a normal one.

Edited by ctbe
Link to comment
Share on other sites

16 minutes ago, ctbe said:

if I register my custom recipes (as IRecipe) in the GameRegistry, will they be craftable in a normal crafting table? Because I want them only be craftable on my custom crafting table, not a normal one.

Edited 15 minutes ago by ctbe

Yes they will be craftable as long as they are not bigger than a 3x3. 

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

13 minutes ago, Animefan8888 said:

Yes they will be craftable as long as they are not bigger than a 3x3. 

Oh.

 

Then that defeats the purpose of having a custom crafting table. Given the circumstances I will use the workaround. Thanks.

 

Edit: I will either use the workaround in my first post, or simply don't use an InventoryCrafting slot. The only reason I was using a InventoryCrafting slots was that it was the only way to trigger onCraftMatrixChanged method when the player did something in the custom table and update everything accordingly. Because normal slots didn't trigger that method.

Edited by ctbe
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Ok, so I did some investigations and after a lot of trial and error, I finally came up with a solution. I will try to explain what I did, and why, for anyone who might need it. From what I understood, implementation will add a depedency for both compiling and runtime (pretty sure it will only include API files for compiling if there are, but I'm not 100% sure), and will resolve any nested depedencies aswell, so its kinda neat if one's mod permenently depends on other's mod or API ! Though I need to control whether a mod is included during runtime or not, so I need to specify the scope of my depedencies. I did some searches, and it turned out that Gradle will consume either jars or source folders regardless, so there is not a specific way to deal with one or the other it seems. I then tried the following and it worked like a charm (modified the commit branch / tags so its pointing to a permanent commit, more info here) ! depedencies { compileOnly 'com.github.lazyMods:baubles:1.10.0.0-1.18:api' runtimeOnly 'com.github.lazyMods:baubles:1.10.0.0-1.18' } But, whenever I try to run, the game crashes with a NoSuchMethod exception, pointing towards a method MenuScreens::m_96206_ called within the Baubles main class during ClientSetup (which is the unmapped name of MenuScreens::register) ; which is clearly a mapping issue. It confused me at first, but now that I think of it it's quite obvious : trying to run the game with uncompiled source files will cause all sorts of issues. And even if Jitpack seems to compile on the go those files, it will lack any metadata expected by Forge or ForgeGradle, so it's no use anyway. The only two solutions I can think of are : Download the mod jar, put it in a libs folder inside your workingDir that you can settup as a local repository, then add that jar as a runtime depedency Use CurseMaven as a repository (as @diesieben07 suggested), and add the correct mod jar as a depedency (more info here) I chose the latter, so now I have the following in my build.gradle file, and it works perfectly (one can even remove the ":api" from the baubles depedency to show the entire mod source files in Eclipse) : repositories { maven { url "https://cursemaven.com" content { includeGroup "curse.maven" } } maven { url "https://jitpack.io" } } depedencies { compileOnly "com.github.lazyMods:baubles:1.10.0.0-1.18:api" runtimeOnly fg.deobf("curse.maven:baubles-366844:3576950") // Points toward Baubles: Reborn? v1.10.0.1-1.18.1 on curseforge.com } I couldn't use CurseMaven straight up as lazynessmind didn't provide a source jar or an api jar on curse forge just yet, so I had to use its Github instead to get the API, hence the struggle. I could have added the mod jar itself as an API, but then I would have to manualy add the source files for Eclipse, which then makes this whole "manage your depedencies solely with Gradle" obsolete...   Thanks for the help, as I could not figure out those things on my own ! I hope that may be usefull to someone some day !
    • I am not sure where in your code the icon and tab name text are rendered.
    • So I've got myself a GUI similar to that of the Advancements screen or the Creative screen where I've got a main screen that renders the window, and tabs that render their own info. Everything works fine and dandy, until I have one of the tabs render text. When that happens, all other text rendered by the screen, along with the tab icon are no longer rendered. There seemingly are no errors, and when I try debugging I can see that each code path is still called so I'm not sure what's going on. So within my screen the main render function looks as follows public void render(MatrixStack matrixStack, int mouseX, int mouseY, float partialTicks) { int i = (this.width - GUI_WIDTH) / 2; int j = (this.height - GUI_HEIGHT) / 2; this.renderBackground(matrixStack); if (maxPages != 0) { ITextComponent page = new StringTextComponent(String.format("%d / %d", tabPage + 1, maxPages + 1)); int width = this.font.width(page); RenderSystem.disableLighting(); this.font.draw(matrixStack, page.getString(), i + (GUI_WIDTH / 2) - (width / 2), j - 44, -1); } this.drawWindowBackground(matrixStack, mouseX, mouseY, i, j); this.renderWindow(matrixStack, i, j); this.drawWindowTooltips(matrixStack, mouseX, mouseY, i, j); } The errant line is within this.drawWindowBackground(matrixStack, mouseX, mouseY, i, j);. Here we render the tab window itself. private void drawWindowBackground(MatrixStack matrixStack, int mouseX, int mouseY, int offsetX, int offsetY) { if (this.selectedTab == null) { fill(matrixStack, offsetX + 9, offsetY + 18, offsetX + 9 + 234, offsetY + 18 + 113, -16777216); int i = offsetX + 9 + 117; drawCenteredString(matrixStack, this.font, EMPTY, i, offsetY + 18 + 56 - 9 / 2, -1); drawCenteredString(matrixStack, this.font, SAD_LABEL, i, offsetY + 18 + 113 - 9, -1); } else { RenderSystem.pushMatrix(); RenderSystem.translatef((float)(offsetX + 9), (float)(offsetY + 18), 0.0F); this.selectedTab.drawTabBackground(matrixStack); RenderSystem.popMatrix(); RenderSystem.depthFunc(515); RenderSystem.disableDepthTest(); } } From there the tab draws itself as follows: public void drawTabBackground(MatrixStack matrixStack) { if (!this.centered) { this.scrollX = 117 - (this.maxX + this.minX) / 2.0D; this.scrollY = 56 - (this.maxY + this.minY) / 2.0D; this.centered = true; } RenderSystem.pushMatrix(); RenderSystem.enableDepthTest(); RenderSystem.translatef(0.0F, 0.0F, 950.0F); RenderSystem.colorMask(false, false, false, false); fill(matrixStack, 4680, 2260, -4680, -2260, -16777216); RenderSystem.colorMask(true, true, true, true); RenderSystem.translatef(0.0F, 0.0F, -950.0F); RenderSystem.depthFunc(518); fill(matrixStack, MAX_WIDTH, MAX_HEIGHT, 0, 0, -16777216); RenderSystem.depthFunc(515); this.minecraft.getTextureManager().bind(background); int i = MathHelper.floor(this.scrollX); int j = MathHelper.floor(this.scrollY); int k = i % 16; int l = j % 16; for(int i1 = -1; i1 <= 15; ++i1) { for(int j1 = -1; j1 <= 8; ++j1) { blit(matrixStack, k + 16 * i1, l + 16 * j1, 0.0F, 0.0F, 16, 16, 16, 16); } } this.renderWindow(matrixStack); RenderSystem.depthFunc(518); RenderSystem.translatef(0.0F, 0.0F, -950.0F); RenderSystem.colorMask(false, false, false, false); fill(matrixStack, 4680, 2260, -4680, -2260, -16777216); RenderSystem.colorMask(true, true, true, true); RenderSystem.translatef(0.0F, 0.0F, 950.0F); RenderSystem.depthFunc(515); RenderSystem.popMatrix(); } And finally we get to the errant line: this.renderWindow(matrixStack);. This method is overridden by each tab and renders the content of the tab. For my tab it is simple, we render a piece of text at the center of the tab. This text renders fine, however it breaks the tab icon and window name. @Override protected void renderWindow(MatrixStack matrixStack) { ITextComponent divineFavourText = new TranslationTextComponent("screen.mesoamericamythology.divine_relationships.favour.divine_favour", this.getRelationship().getDivineFavour()); // x, y, colour // This line breaks the rendering :( drawCenteredString(matrixStack, this.minecraft.font, divineFavourText, MAX_WIDTH / 2, MAX_HEIGHT / 2, Integer.parseInt("FFFFFF", 16)); } Below I have two screenshots. The one on the left is what the UI looks like when I don't draw the string in renderWindow. The right is what happens when I do. I'm a little befuddled at the moment. Hoping someone has more pointers that would help me understand what is going on.
    • User was banned for piracy. Buy the game.
    • Well, the errors seem as though they're tconstruct/jei, have you tried updating those? There are newer versions for 1.16 on curseforge for both of those mods. If you're convinced it's one of your dimensions mods, remove them 1 by one, or remove all and add them back 1 by 1, until you find the culprit.   *edit: what is tlskincape?
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.