Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Mod don't have any texture on Server.


Recommended Posts

Hey, I created a server and now my mod haven't any texture. In Singleplayer isn't this issue. Also in my log-files is no error-message or something like this...

Pls help me, have anyone an idea what the problem could be?

There is only this ugly black-purple texture...

Link to post
Share on other sites

Thank you for ultimate experience of downloading a zipped project via mediafire...
 

Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(item, meta, loc);

Don't use ModelMesher. Use ModelLoader::setCustomResourceLocation().
Also, you should be using register events if you want to be able to update to 1.11+.

What kind of crappy tutorials does everyone watch? Why is there so many ModelMesher threads on the forum?

  • Like 1
Link to post
Share on other sites

Just replace the old

Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(item, meta, loc);

 

But it's highly recommended to start using registry events. They're not so hard to understand. Read the docs first, and here's some simple information:

 

Edited by MrBendelScrolls
Link to post
Share on other sites

Hey, 1st thank you a lot. 2nd, I'm thinking about updating to 1.12, but there are 2 new variables in crafting (ResouceLocation name, ResourceLocation group). I know what they do but I have no idea what to put in... Any idea?

 

The textures don't load, even not in eclipse...

 

Code:

    private void registerModel(Object obj, int meta, ModelResourceLocation loc) {
        Item item = null;
        if(obj instanceof Item) {
            item = (Item) obj;
        } else if(obj instanceof Block) {
            item = Item.getItemFromBlock((Block)obj);
        } else  {
            throw new IllegalArgumentException();
        }

        ModelLoader.setCustomModelResourceLocation(item, meta, loc);

 

 

Edited by MoorhuhnHD
Link to post
Share on other sites

Without looking at your code, I'd imagine it's an issue with naming. In your IDE, uppercase/lowercase doesn't necessarily matter, so you'll have textures fine in your IDE. But once you build it, names of items or textures need to be lowercase. If you have upper case names, it won't load properly.

 

If you do have lowercase names and such, than you know the issue is elsewhere. Post your code to GitHub too - not everyone is going to download a random zip file.

Developer of Levels and Lost Eclipse

Link to post
Share on other sites
3 minutes ago, TheXFactor117 said:

You didn't read what I said earlier.

Which bit? All lower case? No, you should still do that.

Uploading the project to github? No, you should still do that.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites

In case you're curious, the reason Eclipse can work while a built jar doesn't is because a certain OS is NOT case sensitive while Java treats resource "files" inside a jar as if they are.

The debugger is a powerful and necessary tool in any IDE, so learn how to use it. You'll be able to tell us more and get better help here if you investigate your runtime problems in the debugger before posting.

Link to post
Share on other sites
10 hours ago, jeffryfisher said:

...while Java treats resource "files" inside a jar as if they are.

Jar files are zip files.

The zip format enforces case sensitivity in its file format specification.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.