Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

The runServer task loads my coremod 3 times


Eufranio
 Share

Recommended Posts

I am trying to run my mod from my IDE, using the runServer task, but when I run the server with it, my coremod loads 3 times and eventually gives me a DuplicateModsFoundException...

Log: https://hastebin.com/iqequfogeb.sql

http://prntscr.com/hmmx8i

When running on a normal server, it loads fine, this problem seems to be only when running it on my IDE. Let me know if you need any other info...

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • I've been trying to load a custom modpack but it's not letting me create any worlds, it keeps giving me the error "Errors in currently selected datapacks prevented the world from loading. You can either try to load it with only the vanilla data pack ("safe mode") or go back to the title screen to manually fix it". Any way to fix this without needing to remove too many mods? debug log: https://gist.github.com/antxasil/71401fb6a004a66e7248d04d8e7af589
    • I've used forge before, but I can't get it to work with 1.18+   Launcher code: [0116/225441.672:INFO:main_context.cpp(136)] CEF initialized successfully. [0116/225441.673:INFO:main_context.cpp(138)] CEF version: 85.3.13+gcd6cbe0+chromium-85.0.4183.121 [0116/225502.918:WARNING:angle_platform_impl.cc(48)] compileToBinary(257):  C:\fakepath(107,1-13): warning X3557: loop only executes for 1 iteration(s), forcing loop to unroll C:\fakepath(102,1-13): warning X3557: loop only executes for 1 iteration(s), forcing loop to unroll [0116/225508.369:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=2 [0116/225515.224:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=2 [0116/225515.353:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=2 [0116/225525.860:INFO:LauncherAppRenderer.cpp(51)] [Info: 2022-01-16 21:55:17.9581899: LauncherMain.cpp(104)] Initiated models [0116/225525.861:INFO:LauncherAppRenderer.cpp(51)] [Info: 2022-01-16 21:55:17.9592226: LauncherController.cpp(435)] Constructing launcher controller with workDir: C:\...\.minecraft, isActive: 0 [0116/225525.861:INFO:LauncherAppRenderer.cpp(51)] [Info: 2022-01-16 21:55:17.9819604: LauncherAppRenderer.cpp(172)] Javascript bridge extended in OnWebKitInitialized. [0116/225526.215:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=3 [0116/225526.238:INFO:LauncherAppRenderer.cpp(69)] OnBrowserDestroyed: id=3 [0116/225526.387:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=3 [0116/225538.615:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=1 [0116/225825.050:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=5 [0116/230007.904:INFO:LauncherAppRenderer.cpp(518)] OnContextReleased: no frame (unknown context), browser id=6     "Latest" code [16jan.2022 23:00:09.457] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, Elverea, --version, 1.18.1-forge-39.0.36, --gameDir, C:\Users\Norge\AppData\Roaming\.minecraft, --assetsDir, C:\Users\Norge\AppData\Roaming\.minecraft\assets, --assetIndex, 1.18, --uuid, 31cc9858833c43488f09a460a739f964, --accessToken, ????????, --clientId, NzcyMWNmNWYtZGZhNS00YmY1LWFkMTgtMTljYjVhNzZhODM5, --xuid, 2535453675472907, --userType, msa, --versionType, release, --launchTarget, forgeclient, --fml.forgeVersion, 39.0.36, --fml.mcVersion, 1.18.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20211210.034407] [16jan.2022 23:00:09.462] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 9.0.7+91+master.8569cdf starting: java version 17.0.1 by Microsoft
    • Hello I'm running minecraft server 1.18.1 with forge 39.0.36 in ubuntu and tried to remove a mod, even thou the server starts it throws a bunch of  "Found a missing id from the world", I did the -Dfml.queryResult=confirm but it shows also tried to run the command directly like fml confirm and it throws ¿Which is the correct solution to get rid of all the "Found a missing id from the world" in 39.0.36?
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.