Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Do FluidEvents work in 1.7.10? Is there an alternative to BlockEvent.NeighborNotifyEvent to detect fluid spreading?


Recommended Posts

I am trying to backport my mod to 1.7.10. I have a 1.11.2 version that uses 

BlockEvent.NeighborNotifyEvent

to detect when a fluid spreads. I need to do the same in 1.7.10. I have notice there is a 

FluidEvent.FluidMotionEvent

But it never seems to be fired.

Is there anyway to detect when water changes or when there is a physics update on blocks in 1.7.10?


To help rule out any problems here is some code:
Event listener

/**Handles when a water bucket is placed down over lava.**/
@SubscribeEvent(priority = EventPriority.HIGHEST)
public void enderObsidianSpawnWaterEventCheck(FluidEvent.FluidMotionEvent event)
{
   System.out.println("EVENT!!!!!!!!!!!!!!!!!"); //Never called at any point I try.
}

 

Registering event (inside of init of main mod file)

NECEventHandler neceh = new NECEventHandler();
MinecraftForge.EVENT_BUS.register(neceh);
FMLCommonHandler.instance().bus().register(neceh);

 

Edited by SubliminallySublime
Link to post
Share on other sites

Why do you want to backport mods? Especially to a version as ancient as 1.7.10, which isn't even supported on this forum anymore.

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to post
Share on other sites
11 minutes ago, larsgerrits said:

Why do you want to backport mods? Especially to a version as ancient as 1.7.10, which isn't even supported on this forum anymore.

Because the version already exists. I'm just trying to update it. My regular crew decided 1.7.10+ still is not ready. Too many mod authors aren't updating. 1.7.10 may be permanent for us.

Link to post
Share on other sites
1 minute ago, SubliminallySublime said:

1.7.10+ still is not ready.

Dude, 1.12.2 has been out for a while now, and the 1.13 snapshots are getting more stable every week. There's no way 1.7.10+ is "not ready".

 

3 minutes ago, SubliminallySublime said:

Too many mod authors aren't updating.

I know, that sucks. But that's how it's been since the beginning of modding. Some mods disappear, new mods get made. Most mods that aren't getting update anymore are replaced by other mods, most of the time even better than the original. You'll have to get over it.

 

6 minutes ago, SubliminallySublime said:

1.7.10 may be permanent for us.

Good luck. It's gonna be really hard to find support for outdated Minecraft versions, and you'll be missing out on the amazing features the new Minecraft versions will be getting.

 

On this forum, you won't get support for 1.7.10. You'll have to get over it.

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to post
Share on other sites
Just now, larsgerrits said:

Dude, 1.12.2 has been out for a while now, and the 1.13 snapshots are getting more stable every week. There's no way 1.7.10+ is "not ready".

 

I know, that sucks. But that's how it's been since the beginning of modding. Some mods disappear, new mods get made. Most mods that aren't getting update anymore are replaced by other mods, most of the time even better than the original. You'll have to get over it.

 

Good luck. It's gonna be really hard to find support for outdated Minecraft versions, and you'll be missing out on the amazing features the new Minecraft versions will be getting.

 

On this forum, you won't get support for 1.7.10. You'll have to get over it.

Maybe you misunderstand. I have it up to date, but as someone who enjoys jumping between versions since the mods are more important than the game, I hate when they aren't available across versions. I am only trying not to be hypocritical with my own mods. Having been around since the beginning I am fully aware of how it works. As 1.7.10 is undeniably the most modded version, I figured someone would be able to help. Sorry I asked.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.