Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Minecraft Forge Server wont start when trying to add ram(MAC)


neji813
 Share

Recommended Posts

Hello, I'm new to making a modded minecraft server and just recently started looking into how to make/run one on mac. I was able to create a regular Vanilla server and run it smoothly without any errors. I eventually moved on to running modded minecraft forge servers and ran into an error message on the mac terminal and I am unsure where to go or what to do. I have a early 2008 mac running El capitain. The mod server file I used to download the forge server is 1.12.2 (forge - 14.23.2.2611). I used this download then followed the same instructions provided to me by a youtube video on how to start a minecraft server.I then proceeded to start the Start.command file I created to add more ram and ran into this error message:

 

 

A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException
    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.base/java.lang.reflect.Method.invoke(Method.java:564)
    at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:62)
    at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:31)
Caused by: java.lang.ClassCastException: java.base/jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to java.base/java.net.URLClassLoader
    at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    ... 6 more
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.

 

 

Link to comment
Share on other sites

That crash log tells me that there was an error... and exactly nothing else.
What mods are you running on the sever (if none tell me none)?

Are you able to run a normal minecraft server on your computer?

What tutorial did you follow?

What is inside your Start.command file

What version is your Java?

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

You're using Java 9, which isn't supported by Forge. You need to use Java 8 instead.

 

In future, post the FML log (fml-server-latest.log in the server directory) in a spoiler or on Gist. 

Edited by Choonster

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

@Cadiboo I havent added any mods yet. Yes i am able to run a normal minecraft server on the computer. Here is the links to the videos I followed:

 

 

 

start.command file has this text inside:

 

#!/bin/bash

cd "$(dirname "$0")"

exec java Xms1024M -Xmx1024M -jar forge-1.12.2-14.23.2.2611-universal.jar nogui

 

And the version of java im using is Version 8 Update 161 (build 1.8.0_161-b12)

 

Edited by neji813
Link to comment
Share on other sites

1 minute ago, neji813 said:

Version 8 Update 161 (build 1.8.0_161-b12)

Java should be Version 8 Update 151 8u151

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

3 minutes ago, neji813 said:

Ok. How would i go about changing it to that? Also is it Runtime environment or development kit for the java download version? 

I dont believe you need the Development kit, but I've always downloaded it just to be safe (it includes normal java in it) and its worked fine


 

How to change it:

It could be complicated, you should be able to change it with commands but that didn't work for me (MacBook Pro 2013) so I deleted java completely then installed the right java

Java 8u151:

http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html

 

MAKE SURE you download 8u151 not 8u152 (8u151 is the second release from the to, and the 3rd item from the top)

 

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

29 minutes ago, Cadiboo said:

I dont believe you need the Development kit, but I've always downloaded it just to be safe (it includes normal java in it) and its worked fine


 

How to change it:

It could be complicated, you should be able to change it with commands but that didn't work for me (MacBook Pro 2013) so I deleted java completely then installed the right java

Java 8u151:

http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html

 

MAKE SURE you download 8u151 not 8u152 (8u151 is the second release from the to, and the 3rd item from the top)

 

So I deleted my java and reinstalled the files from the website download page you provided. I proceeded to try and attempt to start the server through the start.command file again and received the same message in the terminal I posted earlier. 

Link to comment
Share on other sites

39 minutes ago, neji813 said:

 

That wasn't in a spoiler or on Gist.

 

There's no error in that log, because you're running the server with Java 8. Your original crash was caused by running the server with Java 9.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

1 minute ago, Choonster said:

 

That wasn't in a spoiler or on Gist.

 

There's no error in that log, because you're running the server with Java 8. Your original crash was caused by running the server with Java 9.

How do you place it in a spoiler and I was looking in the folder an that was the latest.I just reinstalled java 8 151 and it still didnt work

Link to comment
Share on other sites

Just now, neji813 said:

How do you place it in a spoiler

 

Use the eye icon in the post editor.

 

Just now, neji813 said:

and I was looking in the folder an that was the latest.I just reinstalled java 8 151 and it still didnt work

 

Delete the FML log and then run the server again, making sure to use Java 8. If it still crashes, post the new FML log.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

15 minutes ago, Choonster said:

 

Use the eye icon in the post editor.

 

 

Delete the FML log and then run the server again, making sure to use Java 8. If it still crashes, post the new FML log.

Ok so I followed your steps and I started the server from the start.command file and Received this message from the mac terminal and NO logs were created:   

 

A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException

    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

    at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

    at java.base/java.lang.reflect.Method.invoke(Method.java:564)

    at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:62)

    at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:31)

Caused by: java.lang.ClassCastException: java.base/jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to java.base/java.net.URLClassLoader

    at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)

    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

    ... 6 more

logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.

 

[Process completed]

 

Link to comment
Share on other sites

Ok so I uninstalled Java 9 with the commands from terminal straight from this website here:

 

https://gist.github.com/schnell18/bcb9833f725be22f6acd01f94b486392

 

and then reinstalled java 8. I then removed all of my files regarding forge craft then reinstalled everything and start the "start.command" file then received this error message:

 

Spoiler

A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException

    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

    at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

    at java.base/java.lang.reflect.Method.invoke(Method.java:564)

    at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:62)

    at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:31)

Caused by: java.lang.ClassCastException: java.base/jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to java.base/java.net.URLClassLoader

    at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)

    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

    ... 6 more

logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.

 

[Process completed]

 

 

Edited by neji813
Link to comment
Share on other sites

please list all files inside your /Library/Java/JavaVirtualMachines/ directory

you can get to this directory with Command+Shift+G then paste in "/Library/Java/JavaVirtualMachines/"

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

23 minutes ago, Cadiboo said:

please list all files inside your /Library/Java/JavaVirtualMachines/ directory

you can get to this directory with Command+Shift+G then paste in "/Library/Java/JavaVirtualMachines/"

Here the list:

 

jdk-9.0.4.jdk

jdk1.8.0_151.jdk

jdk1.8.0_161.jdk

Link to comment
Share on other sites

Delete both jdk-9.0.4.jdk and jdk1.8.0_161.jdk

 

only jdk1.8.0_151.jdk should be in that folder

 

5a8fc805d5187_ScreenShot2018-02-23at6_51_07pm.png.9978ad898c54a02b2f8cda737ff68b64.png

Edited by Cadiboo
  • Like 1

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.