Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.10.2]How to let forge know the mod contains coremod ,not just a coremod


bxzsj
 Share

Recommended Posts

35 minutes ago, bxzsj said:

I changed the max stack of the bucket, when more than one bucket water place water ,it always return to one bucket.

I found that ItemBucket.onItemRightClick cause this.

So,I want to modify it.

Forge adds a universal bucket which can be filled with any liquid and which can be made stackable. Use that instead of messing with vanilla's bucket.

If you insist on overwriting vanilla mechanics, update to 1.12.2 where registry entries can be overwritten.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • I also getting issues with installing Forge serve  JVM info: Eclipse Adoptium - 17.0.1 - 17.0.1+12 java.net.preferIPv4Stack=true Found java version 17.0.1 <html><a href='https://www.creeperhost.net/'>Data kindly mirrored by CreeperHost</a></html> Considering minecraft server jar javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target     at java.base/sun.security.ssl.Alert.createSSLException(Alert.java:131)     at java.base/sun.security.ssl.TransportContext.fatal(TransportContext.java:370)     at java.base/sun.security.ssl.TransportContext.fatal(TransportContext.java:313)     at java.base/sun.security.ssl.TransportContext.fatal(TransportContext.java:308)     at java.base/sun.security.ssl.CertificateMessage$T13CertificateConsumer.checkServerCerts(CertificateMessage.java:1357)     at java.base/sun.security.ssl.CertificateMessage$T13CertificateConsumer.onConsumeCertificate(CertificateMessage.java:1232)     at java.base/sun.security.ssl.CertificateMessage$T13CertificateConsumer.consume(CertificateMessage.java:1175)     at java.base/sun.security.ssl.SSLHandshake.consume(SSLHandshake.java:396)     at java.base/sun.security.ssl.HandshakeContext.dispatch(HandshakeContext.java:480)     at java.base/sun.security.ssl.HandshakeContext.dispatch(HandshakeContext.java:458)     at java.base/sun.security.ssl.TransportContext.dispatch(TransportContext.java:200)     at java.base/sun.security.ssl.SSLTransport.decode(SSLTransport.java:172)     at java.base/sun.security.ssl.SSLSocketImpl.decode(SSLSocketImpl.java:1500)     at java.base/sun.security.ssl.SSLSocketImpl.readHandshakeRecord(SSLSocketImpl.java:1415)     at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:450)     at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:421)     at java.base/sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:580)     at java.base/sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:183)     at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1665)     at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1589)     at java.base/java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:529)     at java.base/sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:308)     at net.minecraftforge.installer.DownloadUtils.getConnection(DownloadUtils.java:243)     at net.minecraftforge.installer.DownloadUtils.downloadManifest(DownloadUtils.java:307)     at net.minecraftforge.installer.json.Util.getVanillaVersion(Util.java:73)     at net.minecraftforge.installer.actions.ServerInstall.run(ServerInstall.java:86)     at net.minecraftforge.installer.InstallerPanel.run(InstallerPanel.java:423)     at net.minecraftforge.installer.SimpleInstaller.launchGui(SimpleInstaller.java:175)     at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:147) Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target     at java.base/sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:439)     at java.base/sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:306)     at java.base/sun.security.validator.Validator.validate(Validator.java:264)     at java.base/sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:231)     at java.base/sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:132)     at java.base/sun.security.ssl.CertificateMessage$T13CertificateConsumer.checkServerCerts(CertificateMessage.java:1341)     ... 24 more Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target     at java.base/sun.security.provider.certpath.SunCertPathBuilder.build(SunCertPathBuilder.java:141)     at java.base/sun.security.provider.certpath.SunCertPathBuilder.engineBuild(SunCertPathBuilder.java:126)     at java.base/java.security.cert.CertPathBuilder.build(CertPathBuilder.java:297)     at java.base/sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:434)     ... 29 more Failed to download version manifest, can not find server jar URL.    
    • crash report: https://pastebin.com/DAAFEVzq  this is the crash report of my friend, we both start up a forge server 36.2.22, to me works just fine, but to him instantly crashes at start up java i used: adoptium jdk 8 java he used: latest java 8 64 bit and also tried with adoptium jdk 8
    • I've been struggling with setting up a 1.16.5 Minecraft server, I've done this before and never had issues..  Every time I try to open the ForgeServer.jar file to launch the server with, nothing happens. And when I try to run it through the linked bat file, I get the following: https://imgur.com/X1K3jd1 I have java 8 version 321 installed and am using the latest Forge 1.16.5-36.2.23 on both client and server. I'm not sure what I'm doing wrong here. I previously had the wrong java installed, which is now fixed. I've tried to remake the server several times, re-installed Minecraft and java and used Jarfix.  I'll also include a picture of the server files to know the file names etc, don't know if that may help or not. Written in the Run.bat: java -Xmx4G -Xms4G -jar ForgeServer.jar nogui Pause https://imgur.com/Sq9k0Ws
    • create a new server an copy the world and mods folder into the new server, if you have changed the configs you also need to copy it. Also note if you have banned player or you use a whitelist/ you opt players you have to copy these files. This is the way I use, theoretically it's also possible to only replace the libraries folder and the run script files. But I haven't test that.  nevermind D7 way is 10 times better😅 I would also recommend you to create a backup of the server before updating 
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.