Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Making a 1.12.2 mod compatible with a 1.11.2 client/server


Stenbergcsgo
 Share

Recommended Posts

So I've created a mod for the newest version of Minecraft ( This is the first iteration of the mod) - however I would like for the mod to be additionally compatible with the Minecraft version 1.11.2. To create the mod I used the MCP eclipse workspace setup, is there an easy fix for me to rollback the mod, or do I need to setup a new MCP workspace for that version, then "remake" my mod?

Link to comment
Share on other sites

8 minutes ago, diesieben07 said:
  1. This is pointless.

Feel the same, but in a unique situation where this is required. Out of curiosity, if I'm required to make a new workspace(and a new jar file) for my mod to work on this outdated version, how come forges 1.12.2 version (single jar) runs on both 1.12.2 and 1.11.2?

Link to comment
Share on other sites

The way I recommend for doing multi-version development.

 

1.) Use git and github to provide revision control for your code. Make sure the build.gradle is under the revision control (this is key to quickly switching between the versions).

2.) Have your master branch with the latest version of the code.

3.) Create a branch for each version of the code.

4.) Whenever you plan to work on a certain version, clone the repository and do the gradlew setupDecompWorkspace and gradlew eclipse.

5.) In Eclipse, import each as a separate project.

6.) Now as you develop you can keep the things that are different separate, but you can also easy merge code across versions where appropriate.

 

Basically, standard version control. In most programming situations you are developing a couple different versions simultaneously.

 

I recommend setting up all your modding developments this way from the beginning because you undoubtedly will want to upgrade at some point.

Edited by jabelar

Check out my tutorials here: http://jabelarminecraft.blogspot.com/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • So I've gotten this error and I tried fixing it the way another form did, but it came with no success and I am truly lost as this isn't well documented. Doing `gradlew build` shows: My gradlew path is the following: C:/     Gradle         bin         docs         init.d         lib         src         LICENSE         NOTICE         README The bin is added to the system environment variables "Path" list.   Any help? Thanks!
    • I downloaded the Forge Server Installer and installed the server to my root directory, then I tried to launch the server and got nothing but a log file, it did not even generate the files. This is all that is in the log files, I am running the latest Java 8 version and JDK 17 version (Adoptium Temurin 17 LTS). // Debug.txt [28Jan2022 17:09:25.344] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.23, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge] [28Jan2022 17:09:25.346] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 17.0.2 by Eclipse Adoptium [28Jan2022 17:09:25.354] [main/DEBUG] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Found launch services [minecraft,testharness,fmlclient,fmlserver] // Latest.txt [28Jan2022 17:09:25.344] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.23, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge] [28Jan2022 17:09:25.346] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 17.0.2 by Eclipse Adoptium  
    • Here is the log file https://drive.google.com/file/d/1Y456kYGNFfgbNDpoE3cW735JKRV-WRt1/view?usp=sharing
    • Here's the new log https://gist.github.com/RichyZ2002/fdaaacb1fd39095d5e15e5d5101542a4
    • I have read the documentation and run the example once, but attach is not executed. When the subscribed Entity is called, attach is called, and then MyCapabilityImplementation is called. fill in the code in the place corresponding to MyCapabilityImplementation. This is how I understand it, am I wrong And I'm not sure what the need for the ResourceLocation string is. It says there are no restrictions, so does that mean it is an ID for identification purposes? Main public void registerCapabilities(RegisterCapabilitiesEvent event) { MyCapability.register(event); }     The problem with not running has been resolved. I had misinterpreted it. MinecraftForge.EVENT_BUS.register(MyCapabilityAttacher.class); So the only thing I'm concerned about is the correctness of future development procedures.  
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.