Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Command executes without backslash


Coder
 Share

Recommended Posts

I am using the most simple way of implementing CommandBase and setting its variables in order to register a command, for some reason when I write the name of the command without a backslash it still executes as if it was a command.

Why is this happening?

	@Override
	public String getName() {
		return "thing";
	}

	@Override
	public String getUsage(ICommandSender sender) {
		return "/thing";
	}
	
	@Override
	public List<String> getAliases() {
		return Arrays.asList(new String[] { "thing", "thingst" });
	}
	
	@Override
	public void execute(MinecraftServer server, ICommandSender sender, String[] args) throws CommandException {
		// execute the command here
	}
	
	public int getRequiredPermissionLevel() {
        return 0;
    }

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.