Jump to content

Modded minecraft crashing on launch


CallumW25

Recommended Posts

I'll get straight to the point, I have a bunch of mods in my regular minecraft client, I didn't use twitch for it because it annoys me :P. Anyway, every time i launch the profile, it crashes almost instantly "An unexpected issue occurred and the game has crashed" blah blah. The mods I'm using are listed below, I think there might be a clashing issue but i'm not sure. I assigned 4GB ram to the profile too.

 

Spoiler

 

Applied energistics 2

Baubles

Blood Magic

Buildcraft

Chance Cubes

CodeChickenLib

CoFHCore

Extra Utilities

Galacticraft

Guide API

Hwyla

iChuns Hats

iChunUtil

Inventory Tweaks

Iron Chests

JEI

Mantle

Not Enough Items

Open Blocks

Open Mods Lib

Optifine

Portal Gun

Thaumcraft

Thermal expansion

Thermal Foundation

Tinkers Construct

Twilight Forest

Voxel Map

 

 

After many checks, all the mods are 1.12.2, as required, theres probably some simple clash i'm missing, I looked in the logs folder for my profile, but didn't see anything obvious, I'll post that if it helps.

 

Please help.

 

Link to comment
Share on other sites

Please post your debug.log, preferably using Pastebin or Gist.

Edited by DaemonUmbra

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.

 

As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.

 

For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.

Spoiler

Logs (Most issues require logs to diagnose):

Spoiler

Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.

 

What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...

 

...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension

 

Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.

 

Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

Spoiler
  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.

Video:

Spoiler

 

 

 

or alternately, 

 

Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft

 

Server Not Starting:

Spoiler

If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.

 

Reporting Illegal/Inappropriate Adfocus Ads:

Spoiler

Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.

 

Posting your mod as a GitHub Repo:

Spoiler

When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.

 

  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]

 

Link to comment
Share on other sites

Well i feel like a complete idiot for missing that, however there is a new issue, I load the pack, it gets through some of the loading screen and then:


The game crashed whilst initializing game
Error: java.lang.VerifyError: Bad type on operand stack

 

No idea what that means :P

 

Edit: after looking at the logs, it claims to have a problem with a selection of mods, however these mods have all worked previously on the same version

Edited by CallumW25
Link to comment
Share on other sites

oh cOME ON, removing optifine got me further, it told me i needed different versions of some base mods so i reinstalled them. After doing that it got quite far through the loading process and crashed again :(.

 

"The game crashed whilst initializing game
Error: java.lang.RuntimeException: java.lang.ClassNotFoundException: net.minecraftforge.client.model.ItemLayerModel$BakedItemModel"

 

Logs tldr

1st half: https://pastebin.com/DtVXN6Ar

2nd half: https://pastebin.com/L3Vsgu7U

 

I'm sure this is really annoying you, but i really do appreciate the help

Link to comment
Share on other sites

  • 10 months later...

I also have simular troubles for a pack i made that worked in 1.7.10, but after updatting mods on the twitch mod launcher: i got this error. 

crash report: https://pastebin.com/aDMd6BP1

Modpack: 

BiblioCraft[v1.11.7][MC1.7.10].jar

buildcraft-7.1.23.jar

Carpenter's Blocks v3.3.8.1 - MC 1.7.10.jar

Chisel-2.9.5.11.jar

CodeChickenCore-1.7.10-1.0.7.47-universal.jar

CoFHCore-[1.7.10]3.1.4-329.jar

CollectiveFramework-1.0.0-132.jar

ComputerCraft1.75.jar

CustomNPCs_1.7.10d(29oct17).jar

Decocraft-2.4.2_1.7.10.jar

Hats-4.0.1.jar

iChunUtil-4.2.3.jar

Industrial-Craft-2-Mod-Experimental-1.7.10.jar

k4lib-1.7.10-0.1.75-universal.jar

Lantern1.47[1.7.10].jar

Mantle-1.7.10-0.3.2b.jar

MapWriter-1.7.10-2.1.10.jar

MineFactoryReloaded-[1.7.10]2.8.2B1-201.jar

Morph-Beta-0.9.3.jar

NEIIntegration-MC1.7.10-1.1.2.jar

NotEnoughItems-1.7.10-1.0.5.120-universal.jar

IC2NuclearControl-2.4.3a.jar

OpenBlocks-1.7.10-1.6.jar

OpenModsLib-1.7.10-0.10.jar

Peripherals++-1.3.6.jar

1.7.10-Pistronics2-v0.6.4.jar

Player-API-Core-1.7.10.jar

PortalGun-4.0.0-beta-6-fix-1.jar

PowerConverters-1.7.10-2.11.jar

ProjectRed-1.7.10-4.7.0pre12.95-Base.jar

ProjectRed-1.7.10-4.7.0pre12.95-Compat.jar

ProjectRed-1.7.10-4.7.0pre12.95-Integration.jar

ProjectRed-1.7.10-4.7.0pre12.95-Lighting.jar

ProjectRed-1.7.10-4.7.0pre12.95-Mechanical.jar

ProjectRed-1.7.10-4.7.0pre12.95-World.jar

Railcraft-Mod-1.7.10.jar

secretroomsmod-1.7.10-4.7.1.413.jar

[1.7.10] SecurityCraft v1.8.12.jar

SmartMoving-1.7.10-15.6.jar

SmartRender-1.7.10-2.1.jar

Sync-4.0.1.jar

Thermal-Expansion-Mod-1.7.10.jar

Thermal-Foundation-Mod-1.7.10.jar

TiCTooltips-mc1.7.10-1.2.5.jar

TConstruct-1.7.10-1.8.8.jar

witchery-1.7.10-0.24.1.jar

worldedit-forge-mc1.7.10-6.1.1-dist.jar

Optifine is used to improve my laptop's performance by turning some settings down to prevent crashing

 

Link to comment
Share on other sites

6 hours ago, dangerzachattack said:

I also have simular troubles

No you don't.

 

Please create your own thread.

Note that 1.7.10 is no longer supported on this forum though.

Some tips:

Spoiler

Modder Support:

Spoiler

1. Do not follow tutorials on YouTube, especially TechnoVision (previously called Loremaster) and HarryTalks, due to their promotion of bad practice and usage of outdated code.

2. Always post your code.

3. Never copy and paste code. You won't learn anything from doing that.

4. 

Quote

Programming via Eclipse's hotfixes will get you nowhere

5. Learn to use your IDE, especially the debugger.

6.

Quote

The "picture that's worth 1000 words" only works if there's an obvious problem or a freehand red circle around it.

Support & Bug Reports:

Spoiler

1. Read the EAQ before asking for help. Remember to provide the appropriate log(s).

2. Versions below 1.11 are no longer supported due to their age. Update to a modern version of Minecraft to receive support.

 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I created my own modpack just for mainly entities right now and im having issues with only a handful of the mobs. is there a way someone could help go over my work and check whats wrong? its a file 
    • Hi, I have a problem with my minecraft: I'm in forge 1.20.1 and I have several mods installed, (link to photo below) and after a while, at random, the game freezes, I can't play or move but I can still hear the game in the background, there's just the image that remains, (problematic when I fight a fire dragon :() ) can you help me? my mods:   zmedievalmusic-1.20.1-2.1 treeharvester-1.20.1-8.7 tctcore-1.0-1.20.1 specialmobs-1.20.1-3.1.3 simpleOres2-1.20.1-6.0.0.2 OldCombatMod_1.20x.jar oculus-mc1.20.1-1.7.0 medieval_buildings-forge-1.0.2 matmos-5.2-forge-1.20.1 journeymap-1.20.1-5.9.18-forge jei-1.20.1-forge-15.8.0.11 iceandfire-2.1.13-1.20.1-beta-4 healthindicatortxf-1.20.1-1.2.2-forge geckolib-forge-1.20.1-4.4.7 embeddium-0.3.25+mc1.20.1 dynamiclights-1.20.1-1.2 cupboard-1.20.1-2.7 crust-1.20.1-2.3.3 collective-1.20.1-7.71 citadel-2.4.9-1.20.1 bucketlib-1.20.1-2.3.0.5 born_in_chaos_(Forge)1.20.1_1.3.1 betterfpsdist-4.4   forge 1.20.1 (47.3.5) i fink it's because of ice and fire mod, but i want it thank to help me! i hope you are well Translated with DeepL.com (free version)
    • Long story short, my girlfriend found a mod for Minecraft she wanted but it was for Pocket Edition. So I took it on myself to try and port it over and it has gone fairly well until the point I had to work with particles. Basically, I had it working using animateTick but I was checking if the block name contained a certain value to specify the lantern's color and as such choose which particle to spawn. I was initially trying to do this via the constructor, but this value hasn't been initialized that early and I can't seem to find some event or method to override which ideally happens when the block is loaded/placed. Performing upwards to 16 string comparisons per tick isn't exactly efficient so I want to try and optimize this. By the time animateTick starts executing, the name is properly initialized and I can use that to set my property accordingly. But this is where I'm starting to run into a weird issue. This is my current code; public void animateTick(BlockState state, Level level, BlockPos pos, RandomSource randomSource) { // It's not fully initialized yet... I guess? if (this.getName().toString().contains("air")) return; if (!state.getValue(COLOR_SET)) { // This method doesn't work at all, neither states are updated var blockState = level.getBlockState(pos); blockState.setValue(LANTERNCOLOR, this.getBlockColor()); blockState.setValue(COLOR_SET, true); level.setBlockAndUpdate(pos, blockState); } double d0 = (double)pos.getX() + randomSource.nextDouble(); double d1 = (double)pos.getY() + randomSource.nextDouble(); double d2 = (double)pos.getZ() + randomSource.nextDouble(); // No idea how to better do this without adding 5 000 new files if (level.getBlockState(pos).getValue(LANTERNCOLOR) == DyeColor.WHITE.getId()) level.addParticle(PaperLanterns.LANTERN_GLOW_WHITE.get(), d0, d1, d2, 0.0D, ThreadLocalRandom.current().nextDouble(-0.10D, 0.0D), 0.0D); if (level.getBlockState(pos).getValue(LANTERNCOLOR) == DyeColor.BLUE.getId()) level.addParticle(PaperLanterns.LANTERN_GLOW_BLUE.get(), d0, d1, d2, 0.0D, ThreadLocalRandom.current().nextDouble(-0.10D, 0.0D), 0.0D); } COLOR_SET is a BooleanProperty meant to ensure this is only executed once, for performance reasons. LANTERNCOLOR is currently an IntegerProperty (it used to be an EnumProperty, but been changing stuff around trying to fix the issue) which specified the color. My issue is that I can only set one of these states, for example like this; if (!state.getValue(COLOR_SET)) { // LANTERNCOLOR is set successfully, but not COLORSET level.setBlockAndUpdate(pos, state.setValue(LANTERNCOLOR, this.getBlockColor())); level.setBlockAndUpdate(pos, state.setValue(COLOR_SET, true)); } // OR if (!state.getValue(COLOR_SET)) { // COLOR_SET is set successfully, but not LANTERNCOLOR level.setBlockAndUpdate(pos, state.setValue(COLOR_SET, true)); level.setBlockAndUpdate(pos, state.setValue(LANTERNCOLOR, this.getBlockColor())); } So I can only seemingly set one state at a time, I now know that my issue wasn't in my usage of EnumProperty so once I solve this I will be going back to that and using a switch-case. But I would love some pointers as to why I can only set one of these states. Is it because once you set it and update it, that instance of the block is now considered dirty and as such accepts no more state changes or something? I know the code's a bit all over the place with how I retrieve the states. I'm still learning and have been testing a bunch trying to get this to work, but have now found the issue but no idea how to solve it 😅 If there's a better way of setting this LANTERNCOLOR property and ensuring it's only executed once, that would be even better. The sole purpose of this is to choose which particle to spawn, since the particle colors are hardcoded.
    • Hi, I have a problem with my minecraft: I'm in forge 1.20.1 and I have several mods installed, (link to photo below) and after a while, at random, the game freezes, I can't play or move but I can still hear the game in the background, there's just the image that remains, (problematic when I fight a fire dragon :() ) can you help me? my mods: file:///C:/Users/meria/Pictures/Capture.PNG forge 1.20.1 (47.3.5) i fink it's because of ice and fire mod, but i want it thank to help me! i hope you are well Translated with DeepL.com (free version)
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.