Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Running from eclipse when using an api gives "Duplicate mod sources"


naturaGodhead
 Share

Recommended Posts

I use another mod as an api to make an addon for that mod. I have an issue where I'm trying to run from inside eclipse, and I get "You have mod sources that are duplicate within your system." There is only one copy of the jar located in run/mods, and my build path is pointed at that jar. I've tried moving the jar outside of run/mods to libs/ instead, and also trying to have jars in both places with the build path pointed at libs/, and still get the same issue.  If I remove the jar from run/mods completely and only have the one in libs/ with the build path pointed at it, the game crashes because the dependency is not in the mods folder. If it's there, it sees 2 jars, but if it isn't it sees 0. Anyone have a similar issue?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.