Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Why are people still coding for 1.7.10/1.8?


nocot
 Share

Recommended Posts

29 minutes ago, JanneSoon said:

It's not about abandoned favorite mods. The real reason is they don't have enough brain to update to newest versions. That's all

I’m pretty sure this isn’t the reason, let’s keep this polite

  • Sad 1

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

1 hour ago, JanneSoon said:

It's not about abandoned favorite mods. The real reason is they don't have enough brain to update to newest versions. That's all

1.7.10 is in my personal opinion the best version as im not happy with the changes Mojang has made to the game since then. I guess you could use 1.8 but there's no cauldron for that version.

Link to comment
Share on other sites

1 hour ago, BlurSpirit said:

im not happy with the changes Mojang has made to the game since then.

Write a mod to unchange them then.

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

7 minutes ago, BlurSpirit said:

why would I if there's a version I'm fully happy with?

Because you are using an unsupported version of the game.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

20 minutes ago, BlurSpirit said:

supported by most mods (next to 1.6.4) and has multiple cauldron versions

I'm sure that if you find a bug in a mod that is either 1.7.10 or 1.6.4 and is about the age of said version you will not receive support from the mod developers. They will not go out of their way to fix the bug in that old of a version, just like how Mojang isn't going to go back on any of there changes and fix bugs for users stuck on said versions.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

On 10/14/2018 at 10:12 AM, BlurSpirit said:

1.7.10 is in my personal opinion the best version as im not happy with the changes Mojang has made to the game since then. I guess you could use 1.8 but there's no cauldron for that version.

How'bout Sponge API ?

Link to comment
Share on other sites

I may be late to this but anyone who thinks that 1.7.10 is trash or obsolete now die in a hole.

I may come off as rude or ignorant but you are arguing about a game about the freedom to do whatever you want.

If anyone here has a problem with people who work their asses of to get mods to you then find another game.

Minecraft 1.7.10 is the version that modders use because it takes less time to develop stuff for YOU the developers know the limits of it and if I do say so myself it is more stable for mods now five-year-old brats go home I think its time for a nap because all of you are whining why won't they go to this version why won't they go to that version and I'm getting sick of it

Link to comment
Share on other sites

2 hours ago, EternalDarkWolf said:

obsolete

Obsolete when used as a verb means " cause (a product or idea) to be or become obsolete by replacing it with something new."(A simple google search would let you know this). Following this definition Forge versions and Minecraft versions less than 1.12 and 1.13, each for their respective versions, are obsolete.

2 hours ago, EternalDarkWolf said:

I may come off as rude or ignorant

No, you aren't coming off as "rude or ignorant", you are being rude and ignorant.

2 hours ago, EternalDarkWolf said:

you are arguing about a game about the freedom to do whatever you want.

No, there was no argument here that went against peoples freedom. No one here is arguing that you shouldn't develop mods for older versions or use mods for older versions. We are discussing the reason why people are doing such a thing.

2 hours ago, EternalDarkWolf said:

Minecraft 1.7.10 is the version that modders use because it takes less time to develop

This isn't completely true, model JSONs can be automated with external code(creates a default JSON model for an object) or internal code(has a custom IBakedModel). Events have become easier, registering objects to the game became as simple as initializing an instance of it giving it a registry name and adding it to a list. The list goes on.

2 hours ago, EternalDarkWolf said:

YOU the developers know the limits of it and if I do say so myself it is more stable for mods

I'm not quite sure what you mean by this, but it isn't "more stable for mods" all of the Minecraft versions are stable and Forge versions are stable when released and bug fixes go into it and more features are added.

2 hours ago, EternalDarkWolf said:

now five-year-old brats go home I think its time for a nap because all of you are whining

First off no one is whining that people are not leaving a version. Its just rather irritating to repeat the same phrase multiple times a day "Anything below 1.9 is no longer supported on this forum, please update to receive assistance. " or "It's 4 years old." And second off you are the one who is whining, about people discussing there opinions on a forum with other people who share the same opinion and people who have the opposite opinion. And instead of joining the conversation in an adult or mature manner you decided to insult them and tell people to die.

2 hours ago, EternalDarkWolf said:

why won't they go to this version why won't they go to that version and I'm getting sick of it

People have a right to say what they want, and if you are getting sick of reading the same thing over and over again, DON'T READ IT, DON'T LOG IN TO THE FORUMS, DON'T ASSOCIATE WITH PEOPLE WHO HAVE THAT OPINION. You have a choice.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

14 hours ago, EternalDarkWolf said:

I may come off as rude or ignorant but you are arguing about a game about the freedom to do whatever you want.

Fair point, however as Animefan said do what you want, there are other forums that support 1.9 & below (minecraftforum). Feel free to visit them, they have more people & people who still write mods for those versions. We simply can't support them here because we haven't written code for those versions for many (3+) years. We just don't know how to mod for those versions. I personally have only written mods for 1.12.2, and I couldn't help at all with older mods. I've ported a mod from 1.7.10, and it seems that absolutely everything was done differently back then.

  • Haha 1

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.