Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.13.2] Loading two mods on a server


Recommended Posts

Hello, I started Minecraft 1.13.2 modding this week. I made two Mods both work correctly.

 

If I add one mod two the server. Everything works fine. If I just add the twiced mod to the mods of my minecraft client, not on the server all items and blocks are shown wrong (all from the mod). 

 

Forge version ist the forge 25.0.55.

 

Thanks to all who will and want to help me. 

 

 

Edited by Patmobile
Link to post
Share on other sites

Post your logs

  • Like 1

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to post
Share on other sites

There doesn't seem to be anything wrong with those logs. What mods are you installing and where did you get them from?

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to post
Share on other sites

This are my own mods. I wrote those mods by myself. So I gave you an expamle:

Items mod is on the server and on the client: Everything works fine so I craft an iron spring and put these spring in my inventory. 

Then I close the game and put my blocks mod in the mod folder. Then I reconnect to the server. The spring is now in my inventory or when I craft a new one an snowbrick (everytime this doesn't change). 

Or stone helemt: I add the mod it says I have the Obsidian sword on my head but I can put it off an on again. So I think that the server does not think it is a sword. The server handle it Lila a helmet. 

 

It doesn't change anything if I add the blocks mod to the server

Link to post
Share on other sites

In that case, there is probably something wrong with your mods (given that I interpreted your problem correctly; your description is rather hard to understand).

Upload your code for both of the mods to a repo or something so that we can look at it and figure out what is wrong.

Edited by DavidM
  • Like 1

Some tips:

Spoiler

Modder Support:

Spoiler

1. Do not follow tutorials on YouTube, especially TechnoVision (previously called Loremaster) and HarryTalks, due to their promotion of bad practice and usage of outdated code.

2. Always post your code.

3. Never copy and paste code. You won't learn anything from doing that.

4. 

Quote

Programming via Eclipse's hotfixes will get you nowhere

5. Learn to use your IDE, especially the debugger.

6.

Quote

The "picture that's worth 1000 words" only works if there's an obvious problem or a freehand red circle around it.

Support & Bug Reports:

Spoiler

1. Read the EAQ before asking for help. Remember to provide the appropriate log(s).

2. Versions below 1.11 are no longer supported due to their age. Update to a modern version of Minecraft to receive support.

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.