Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Item is functional, but texture isn't loading


Mango106
 Share

Recommended Posts

Here is the github for my mod:

https://github.com/Citrine07/SoupMod/tree/Citrine07-SoupMod

 

I made a soup item called beef_stew, which extends SoupBase,  which extends FoodBase, which extends ItemFood. The item works and returns a bowl when eaten. The only problem I have is that the texture for the beef_stew doesn't load. I have the texture and item model in the right folder, i'm not sure what i'm doing wrong. Might have to do with the registries, I can't think of anything else.

Link to comment
Share on other sites

It can't find your model file because you're missing the assets folder. In src/main/resources should be a folder called "assets" which contains the "lang", "models", "recipes" and "textures" folders. the pack.mcmeta and mcmod.info should remain in the resources folder.

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.