Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[SOLVED] [1.13.2] Gui not displaying after GuiScreen object returned on client side


Recommended Posts

I've updated my code to use the new gui opening code, however whenever I click on the block, the GUI never displays. (Forge 1.13.2-25.0.73)

https://github.com/Ipsis/Woot/tree/1.13.x

 

So far I've done the following

* registered an extension point for returning the guiscreen

** https://github.com/Ipsis/Woot/blob/1.13.x/src/main/java/ipsis/woot/Woot.java#L68

* return a new GuiScreen for the FMLPlayMessages,OpenContainer

** https://github.com/Ipsis/Woot/blob/1.13.x/src/main/java/ipsis/woot/client/GuiHandler.java#L30

* used NetworkHooks.openGui in the onBlockActivated method for the block

** https://github.com/Ipsis/Woot/blob/1.13.x/src/main/java/ipsis/woot/util/WootBlock.java#L92

 

If I walk through the code then I can see the client side code being called, the correct block position being passed, the correct gui id being requested and the GuiScreen object being returned.

Then FMLPlayMessages.handle method calls the displayGuiScreen method successfully,  no obvious errors seem to occur and no event seems to be cancelled. That particular method gets to the end without issue.

 

I've put a breakpoint in the GUI drawGuiContainerBackgroundLayer and that is never hit.

Adding debug to the FMLPlayMessage.OpenContainer method handler in my code shows that I can call the gui open sequence repeatedly by right-clicking the block.

 

I'm assuming that I'm missing something really simple but I cannot for the life of me work out what it is.

 

Does anyone have any hints as to what obvious thing I'm overlooking.

 

Thanks.

Ipsis

 

 

Edited by Ipsissimus418
Update title with solved
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • oh, ok. So it isn't a forge thing, sorry for taking your time then.
    • This is a core issue in vanilla that has existed since its inception. They way that Items are rendered, is that the edge strip is generated by the CPU, by guessing where the GPU will place the pixels of the forward facing texture. Then the main texture is applied as one quad over top of it. The small white you see is where rounding errors happen and the CPU/GPU are disagreeing. There is no way to fix it beyond building a full model {not cheating like vanilla does and using one quad for the front of the item} This happens in every Minecraft version Modded or not, it varies based on Texture, CPU/GPU combo, and many other things.  
    • I believe this is the log you're asking for, but correct me if i'm wrong. This is from the "latest" txt in the log folder that forge creates after running the jar. Thanks for the help btw!
    • Ok so apparently this bug only seems to happen in 1.16 and up... it's not present in any versions below those specific ones... but apparently, there seems to be an issue with texture stitching in the forge 1.16.4 version 35.1.37, or for that matter any 1.16+ forge version... I have an Intel Iris 1536 MB graphics card and a 2.6 GHz Dual-Core Intel Core i5 processor, and it may need to be updated, an un-updated driver might be the cause of the texture issue, I don't really know, but it seems to be on forge's end more than anything. I'll include an image showing the texture issue if that helps. Also, can someone look into this please? Note: Open the images in a new tab and zoom in ( CMD + on mac, CTRL + on Windows) to see the white lines/gaps in more detail.https://imgur.com/a/INB6g4c
    • Hello everyone!   I'm working on a tree model visualizer object, that can draw a tree dynamically to the screen regardless of how many nodes or subtrees there are. The user can move the display with dragging, and here comes the problem I have. I need every object that is outside of the object to be hidden, like on the advancement screen in vanilla, however, no matter how hard I looked at the vanilla code, I wasn't being able to figure out a way to do this. Right now, my objects are visible outside of the object. That is what I don't want to happen How would I be able to make this happen? Any help is appreciated!
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.