Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[Solved] modid:name#inventory on texture?


Recommended Posts

So i'm trying to get a texture to work on a Item, but this is what's happening.

image.png.5dcc8143a527fa1f002cb10c55b2e456.png

Here's my code in ModItems.java:

package com.matthyfamily.init;

import com.matthyfamily.Reference;
import com.matthyfamily.items.ItemBasic;

import net.minecraft.client.renderer.block.model.ModelResourceLocation;
import net.minecraft.item.Item;
import net.minecraftforge.client.event.ModelRegistryEvent;
import net.minecraftforge.client.model.ModelLoader;
import net.minecraftforge.event.RegistryEvent;
import net.minecraftforge.fml.common.Mod;
import net.minecraftforge.fml.common.eventhandler.SubscribeEvent;

@Mod.EventBusSubscriber(modid=Reference.MODID)
public class ModItems {
	
	static Item Taco;
	
	public static void init() {
		Taco = new ItemBasic("Taco");
	}
	
	@SubscribeEvent
	public static void registerItems(RegistryEvent.Register<Item> event) {
		event.getRegistry().registerAll(Taco);
	}
	
	@SubscribeEvent
	public static void registerRenders(ModelRegistryEvent event) {
		registerRender(Taco, "inbc:taco");
	}
	
	private static void registerRender(Item item, String name) {
		ModelLoader.setCustomModelResourceLocation(item, 0, new ModelResourceLocation( name, "inventory"));
	}
}

I'm new to this, so if you need any more information, i'll reply with some.

Edited by matthyplayz
solved

i have no idea what to put here, so i'll just say you can edit your signature at https://www.minecraftforge.net/forum/settings/signature/

Link to post
Share on other sites

Can you send a link to your repo?

I suspect that you put the model json in the wrong place.

Edited by DavidM

Some tips:

Spoiler

Modder Support:

Spoiler

1. Do not follow tutorials on YouTube, especially TechnoVision (previously called Loremaster) and HarryTalks, due to their promotion of bad practice and usage of outdated code.

2. Always post your code.

3. Never copy and paste code. You won't learn anything from doing that.

4. 

Quote

Programming via Eclipse's hotfixes will get you nowhere

5. Learn to use your IDE, especially the debugger.

6.

Quote

The "picture that's worth 1000 words" only works if there's an obvious problem or a freehand red circle around it.

Support & Bug Reports:

Spoiler

1. Read the EAQ before asking for help. Remember to provide the appropriate log(s).

2. Versions below 1.11 are no longer supported due to their age. Update to a modern version of Minecraft to receive support.

 

 

Link to post
Share on other sites

Follow the way vanilla does it™️

  • Haha 1

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to post
Share on other sites
7 hours ago, Patmobile said:

Try to put your "models" and "textures" folder in "assets/inbc".

I did, now i'm getting this. I think the problem is that it is adding another ".png" to the end.

[15:23:54] [main/INFO] [GradleStart]: Extra: []
[15:23:54] [main/INFO] [GradleStart]: Running with arguments: [--userProperties, {}, --assetsDir, C:/Users/Christian/.gradle/caches/minecraft/assets, --assetIndex, 1.12, --accessToken{REDACTED}, --version, 1.12.2, --tweakClass, net.minecraftforge.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker]
[15:23:54] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
[15:23:55] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
[15:23:55] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker
[15:23:55] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker
[15:23:55] [main/INFO] [FML]: Forge Mod Loader version 14.23.5.2814 for Minecraft 1.12.2 loading
[15:23:55] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_201, running on Windows 10:amd64:10.0, installed at C:\Program Files\Java\jre1.8.0_201
[15:23:55] [main/ERROR] [FML]: Apache Maven library folder was not in the format expected. Using default libraries directory.
[15:23:55] [main/ERROR] [FML]: Full: C:\Users\Christian\.gradle\caches\modules-2\files-2.1\org.apache.maven\maven-artifact\3.5.3\7dc72b6d6d8a6dced3d294ed54c2cc3515ade9f4\maven-artifact-3.5.3.jar
[15:23:55] [main/ERROR] [FML]: Trimmed: c:/users/christian/.gradle/caches/modules-2/files-2.1/org.apache.maven/maven-artifact/3.5.3/
[15:23:55] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
[15:23:55] [main/INFO] [FML]: Detected deobfuscated environment, loading log configs for colored console logs.
2019-03-19 15:23:57,821 main WARN Disabling terminal, you're running in an unsupported environment.
[15:23:57] [main/INFO] [FML]: Ignoring missing certificate for coremod FMLCorePlugin (net.minecraftforge.fml.relauncher.FMLCorePlugin), we are in deobf and it's a forge core plugin
[15:23:57] [main/INFO] [FML]: Ignoring missing certificate for coremod FMLForgePlugin (net.minecraftforge.classloading.FMLForgePlugin), we are in deobf and it's a forge core plugin
[15:23:57] [main/INFO] [FML]: Searching C:\Users\Christian\Desktop\Inbcraft\run\.\mods for mods
[15:23:57] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker
[15:23:57] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.fml.relauncher.FMLCorePlugin
[15:23:57] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin
[15:23:57] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[15:23:57] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
[15:23:57] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[15:23:57] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[15:23:57] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[15:23:57] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
[15:24:01] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
[15:24:01] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
[15:24:01] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
[15:24:01] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[15:24:01] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.TerminalTweaker
[15:24:01] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.TerminalTweaker
[15:24:01] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[15:24:04] [Client thread/INFO] [minecraft/Minecraft]: Setting user: Player896
[15:24:13] [Client thread/WARN] [minecraft/GameSettings]: Skipping bad option: lastServer:
[15:24:13] [Client thread/INFO] [minecraft/Minecraft]: LWJGL Version: 2.9.4
[15:24:15] [Client thread/INFO] [FML]: -- System Details --
Details:
	Minecraft Version: 1.12.2
	Operating System: Windows 10 (amd64) version 10.0
	Java Version: 1.8.0_201, Oracle Corporation
	Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
	Memory: 306223864 bytes (292 MB) / 396886016 bytes (378 MB) up to 1623719936 bytes (1548 MB)
	JVM Flags: 0 total; 
	IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
	FML: 
	Loaded coremods (and transformers): 
	GL info: ' Vendor: 'Intel' Version: '4.0.0 - Build 10.18.10.4252' Renderer: 'Intel(R) HD Graphics 4000'
[15:24:15] [Client thread/INFO] [FML]: MinecraftForge v14.23.5.2814 Initialized
[15:24:15] [Client thread/INFO] [FML]: Starts to replace vanilla recipe ingredients with ore ingredients.
[15:24:15] [Client thread/INFO] [FML]: Replaced 1036 ore ingredients
[15:24:16] [Client thread/INFO] [FML]: Searching C:\Users\Christian\Desktop\Inbcraft\run\.\mods for mods
[15:24:18] [Thread-3/INFO] [FML]: Using sync timing. 200 frames of Display.update took 442362300 nanos
[15:24:20] [Client thread/INFO] [FML]: Forge Mod Loader has identified 5 mods to load
[15:24:20] [Client thread/INFO] [FML]: FML has found a non-mod file inbcraft-1.0.jar in your mods directory. It will now be injected into your classpath. This could severe stability issues, it should be removed if possible.
[15:24:21] [Client thread/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, inbc] at CLIENT
[15:24:21] [Client thread/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, inbc] at SERVER
[15:24:22] [Client thread/INFO] [minecraft/SimpleReloadableResourceManager]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Inbcraft
[15:24:22] [Client thread/INFO] [FML]: Processing ObjectHolder annotations
[15:24:22] [Client thread/INFO] [FML]: Found 1168 ObjectHolder annotations
[15:24:22] [Client thread/INFO] [FML]: Identifying ItemStackHolder annotations
[15:24:22] [Client thread/INFO] [FML]: Found 0 ItemStackHolder annotations
[15:24:23] [Client thread/INFO] [FML]: Configured a dormant chunk cache size of 0
[15:24:23] [Client thread/INFO] [STDOUT]: [com.matthyfamily.Inbcraft:preInit:21]: inbc:preInit
[15:24:23] [Client thread/INFO] [FML]: Applying holder lookups
[15:24:23] [Client thread/INFO] [FML]: Holder lookups applied
[15:24:23] [Client thread/INFO] [FML]: Applying holder lookups
[15:24:23] [Client thread/INFO] [FML]: Holder lookups applied
[15:24:23] [Client thread/INFO] [FML]: Applying holder lookups
[15:24:23] [Forge Version Check/INFO] [forge.VersionCheck]: [forge] Starting version check at http://files.minecraftforge.net/maven/net/minecraftforge/forge/promotions_slim.json
[15:24:23] [Client thread/INFO] [FML]: Holder lookups applied
[15:24:23] [Client thread/INFO] [STDOUT]: [com.matthyfamily.init.ModItems:registerModels:37]: inbc:taco#inventory inbc:taco
[15:24:23] [Forge Version Check/INFO] [forge.VersionCheck]: [forge] Found status: AHEAD Target: null
[15:24:23] [Client thread/INFO] [FML]: Applying holder lookups
[15:24:23] [Client thread/INFO] [FML]: Holder lookups applied
[15:24:23] [Client thread/INFO] [FML]: Injecting itemstacks
[15:24:23] [Client thread/INFO] [FML]: Itemstack injection complete
[15:24:39] [Sound Library Loader/INFO] [minecraft/SoundManager]: Starting up SoundSystem...
[15:24:40] [Thread-5/INFO] [minecraft/SoundManager]: Initializing LWJGL OpenAL
[15:24:40] [Thread-5/INFO] [minecraft/SoundManager]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
[15:24:40] [Thread-5/INFO] [minecraft/SoundManager]: OpenAL initialized.
[15:24:40] [Sound Library Loader/INFO] [minecraft/SoundManager]: Sound engine started
[15:24:54] [Client thread/INFO] [FML]: Max texture size: 8192
[15:24:55] [Client thread/INFO] [minecraft/TextureMap]: Created: 512x512 textures-atlas
[15:24:59] [Client thread/INFO] [FML]: Applying holder lookups
[15:24:59] [Client thread/INFO] [FML]: Holder lookups applied
[15:24:59] [Client thread/INFO] [STDOUT]: [com.matthyfamily.Inbcraft:init:27]: inbc:init
[15:24:59] [Client thread/INFO] [FML]: Injecting itemstacks
[15:24:59] [Client thread/INFO] [FML]: Itemstack injection complete
[15:24:59] [Client thread/INFO] [STDOUT]: [com.matthyfamily.Inbcraft:postInit:32]: inbc:postInit
[15:25:00] [Client thread/INFO] [FML]: Forge Mod Loader has successfully loaded 5 mods
[15:25:00] [Client thread/WARN] [minecraft/GameSettings]: Skipping bad option: lastServer:
[15:25:00] [Client thread/INFO] [mojang/NarratorWindows]: Narrator library for x64 successfully loaded
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: The following texture errors were found.
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: ==================================================
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:   DOMAIN inbc
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: --------------------------------------------------
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:   domain inbc is missing 1 texture
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:     domain inbc has 1 location:
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:       unknown resourcepack type net.minecraft.client.resources.LegacyV2Adapter : FMLFileResourcePack:Inbcraft
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: -------------------------
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:     The missing resources for domain inbc are:
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:       textures/item/taco.png.png
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: -------------------------
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:     No other errors exist for domain inbc
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: ==================================================
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
[15:25:02] [Realms Notification Availability checker #1/INFO] [mojang/RealmsClient]: Could not authorize you against Realms server: Invalid session id

 

i have no idea what to put here, so i'll just say you can edit your signature at https://www.minecraftforge.net/forum/settings/signature/

Link to post
Share on other sites
7 minutes ago, matthyplayz said:

I did, now i'm getting this. I think the problem is that it is adding another ".png" to the end. 


[15:23:54] [main/INFO] [GradleStart]: Extra: []
[15:23:54] [main/INFO] [GradleStart]: Running with arguments: [--userProperties, {}, --assetsDir, C:/Users/Christian/.gradle/caches/minecraft/assets, --assetIndex, 1.12, --accessToken{REDACTED}, --version, 1.12.2, --tweakClass, net.minecraftforge.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker]
[15:23:54] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
[15:23:55] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
[15:23:55] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker
[15:23:55] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker
[15:23:55] [main/INFO] [FML]: Forge Mod Loader version 14.23.5.2814 for Minecraft 1.12.2 loading
[15:23:55] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_201, running on Windows 10:amd64:10.0, installed at C:\Program Files\Java\jre1.8.0_201
[15:23:55] [main/ERROR] [FML]: Apache Maven library folder was not in the format expected. Using default libraries directory.
[15:23:55] [main/ERROR] [FML]: Full: C:\Users\Christian\.gradle\caches\modules-2\files-2.1\org.apache.maven\maven-artifact\3.5.3\7dc72b6d6d8a6dced3d294ed54c2cc3515ade9f4\maven-artifact-3.5.3.jar
[15:23:55] [main/ERROR] [FML]: Trimmed: c:/users/christian/.gradle/caches/modules-2/files-2.1/org.apache.maven/maven-artifact/3.5.3/
[15:23:55] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
[15:23:55] [main/INFO] [FML]: Detected deobfuscated environment, loading log configs for colored console logs.
2019-03-19 15:23:57,821 main WARN Disabling terminal, you're running in an unsupported environment.
[15:23:57] [main/INFO] [FML]: Ignoring missing certificate for coremod FMLCorePlugin (net.minecraftforge.fml.relauncher.FMLCorePlugin), we are in deobf and it's a forge core plugin
[15:23:57] [main/INFO] [FML]: Ignoring missing certificate for coremod FMLForgePlugin (net.minecraftforge.classloading.FMLForgePlugin), we are in deobf and it's a forge core plugin
[15:23:57] [main/INFO] [FML]: Searching C:\Users\Christian\Desktop\Inbcraft\run\.\mods for mods
[15:23:57] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker
[15:23:57] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.fml.relauncher.FMLCorePlugin
[15:23:57] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin
[15:23:57] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[15:23:57] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
[15:23:57] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[15:23:57] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[15:23:57] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[15:23:57] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
[15:24:01] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
[15:24:01] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
[15:24:01] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
[15:24:01] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[15:24:01] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.TerminalTweaker
[15:24:01] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.TerminalTweaker
[15:24:01] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[15:24:04] [Client thread/INFO] [minecraft/Minecraft]: Setting user: Player896
[15:24:13] [Client thread/WARN] [minecraft/GameSettings]: Skipping bad option: lastServer:
[15:24:13] [Client thread/INFO] [minecraft/Minecraft]: LWJGL Version: 2.9.4
[15:24:15] [Client thread/INFO] [FML]: -- System Details --
Details:
	Minecraft Version: 1.12.2
	Operating System: Windows 10 (amd64) version 10.0
	Java Version: 1.8.0_201, Oracle Corporation
	Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
	Memory: 306223864 bytes (292 MB) / 396886016 bytes (378 MB) up to 1623719936 bytes (1548 MB)
	JVM Flags: 0 total; 
	IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
	FML: 
	Loaded coremods (and transformers): 
	GL info: ' Vendor: 'Intel' Version: '4.0.0 - Build 10.18.10.4252' Renderer: 'Intel(R) HD Graphics 4000'
[15:24:15] [Client thread/INFO] [FML]: MinecraftForge v14.23.5.2814 Initialized
[15:24:15] [Client thread/INFO] [FML]: Starts to replace vanilla recipe ingredients with ore ingredients.
[15:24:15] [Client thread/INFO] [FML]: Replaced 1036 ore ingredients
[15:24:16] [Client thread/INFO] [FML]: Searching C:\Users\Christian\Desktop\Inbcraft\run\.\mods for mods
[15:24:18] [Thread-3/INFO] [FML]: Using sync timing. 200 frames of Display.update took 442362300 nanos
[15:24:20] [Client thread/INFO] [FML]: Forge Mod Loader has identified 5 mods to load
[15:24:20] [Client thread/INFO] [FML]: FML has found a non-mod file inbcraft-1.0.jar in your mods directory. It will now be injected into your classpath. This could severe stability issues, it should be removed if possible.
[15:24:21] [Client thread/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, inbc] at CLIENT
[15:24:21] [Client thread/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, inbc] at SERVER
[15:24:22] [Client thread/INFO] [minecraft/SimpleReloadableResourceManager]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Inbcraft
[15:24:22] [Client thread/INFO] [FML]: Processing ObjectHolder annotations
[15:24:22] [Client thread/INFO] [FML]: Found 1168 ObjectHolder annotations
[15:24:22] [Client thread/INFO] [FML]: Identifying ItemStackHolder annotations
[15:24:22] [Client thread/INFO] [FML]: Found 0 ItemStackHolder annotations
[15:24:23] [Client thread/INFO] [FML]: Configured a dormant chunk cache size of 0
[15:24:23] [Client thread/INFO] [STDOUT]: [com.matthyfamily.Inbcraft:preInit:21]: inbc:preInit
[15:24:23] [Client thread/INFO] [FML]: Applying holder lookups
[15:24:23] [Client thread/INFO] [FML]: Holder lookups applied
[15:24:23] [Client thread/INFO] [FML]: Applying holder lookups
[15:24:23] [Client thread/INFO] [FML]: Holder lookups applied
[15:24:23] [Client thread/INFO] [FML]: Applying holder lookups
[15:24:23] [Forge Version Check/INFO] [forge.VersionCheck]: [forge] Starting version check at http://files.minecraftforge.net/maven/net/minecraftforge/forge/promotions_slim.json
[15:24:23] [Client thread/INFO] [FML]: Holder lookups applied
[15:24:23] [Client thread/INFO] [STDOUT]: [com.matthyfamily.init.ModItems:registerModels:37]: inbc:taco#inventory inbc:taco
[15:24:23] [Forge Version Check/INFO] [forge.VersionCheck]: [forge] Found status: AHEAD Target: null
[15:24:23] [Client thread/INFO] [FML]: Applying holder lookups
[15:24:23] [Client thread/INFO] [FML]: Holder lookups applied
[15:24:23] [Client thread/INFO] [FML]: Injecting itemstacks
[15:24:23] [Client thread/INFO] [FML]: Itemstack injection complete
[15:24:39] [Sound Library Loader/INFO] [minecraft/SoundManager]: Starting up SoundSystem...
[15:24:40] [Thread-5/INFO] [minecraft/SoundManager]: Initializing LWJGL OpenAL
[15:24:40] [Thread-5/INFO] [minecraft/SoundManager]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
[15:24:40] [Thread-5/INFO] [minecraft/SoundManager]: OpenAL initialized.
[15:24:40] [Sound Library Loader/INFO] [minecraft/SoundManager]: Sound engine started
[15:24:54] [Client thread/INFO] [FML]: Max texture size: 8192
[15:24:55] [Client thread/INFO] [minecraft/TextureMap]: Created: 512x512 textures-atlas
[15:24:59] [Client thread/INFO] [FML]: Applying holder lookups
[15:24:59] [Client thread/INFO] [FML]: Holder lookups applied
[15:24:59] [Client thread/INFO] [STDOUT]: [com.matthyfamily.Inbcraft:init:27]: inbc:init
[15:24:59] [Client thread/INFO] [FML]: Injecting itemstacks
[15:24:59] [Client thread/INFO] [FML]: Itemstack injection complete
[15:24:59] [Client thread/INFO] [STDOUT]: [com.matthyfamily.Inbcraft:postInit:32]: inbc:postInit
[15:25:00] [Client thread/INFO] [FML]: Forge Mod Loader has successfully loaded 5 mods
[15:25:00] [Client thread/WARN] [minecraft/GameSettings]: Skipping bad option: lastServer:
[15:25:00] [Client thread/INFO] [mojang/NarratorWindows]: Narrator library for x64 successfully loaded
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: The following texture errors were found.
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: ==================================================
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:   DOMAIN inbc
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: --------------------------------------------------
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:   domain inbc is missing 1 texture
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:     domain inbc has 1 location:
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:       unknown resourcepack type net.minecraft.client.resources.LegacyV2Adapter : FMLFileResourcePack:Inbcraft
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: -------------------------
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:     The missing resources for domain inbc are:
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:       textures/item/taco.png.png
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: -------------------------
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]:     No other errors exist for domain inbc
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: ==================================================
[15:25:00] [Client thread/ERROR] [FML.TEXTURE_ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
[15:25:02] [Realms Notification Availability checker #1/INFO] [mojang/RealmsClient]: Could not authorize you against Realms server: Invalid session id

 

So yeah the problem is in your model file.

 

6 lines (6 sloc) 104 Bytes

 

{

"parent": "item/generated",

"textures": {

"layer0": "inbc:item/taco.png"

}

}

 

you can change ""layer0": "inbc:item/taco.png" into ""layer0": "inbc:item/taco"" you don't need to write ".png" behind the file name.

You can also change your texture name from "taco" to "taco.png"

 

Link to post
Share on other sites
5 minutes ago, Patmobile said:

So yeah the problem is in your model file.

 

6 lines (6 sloc) 104 Bytes

 

{

"parent": "item/generated",

"textures": {

"layer0": "inbc:item/taco.png"

}

}

 

you can change ""layer0": "inbc:item/taco.png" into ""layer0": "inbc:item/taco"" you don't need to write ".png" behind the file name.

You can also change your texture name from "taco" to "taco.png"

 

TYSM! My taco is back!

i have no idea what to put here, so i'll just say you can edit your signature at https://www.minecraftforge.net/forum/settings/signature/

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.