Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Help Creating a Custom Machine [1.12.2]

Distinct Soul

Recommended Posts

52 minutes ago, Distinct Soul said:

[16:54:13] [main/ERROR] [FML.TEXTURE_ERRORS]:   domain soulforgery is missing 1 texture
[16:54:13] [main/ERROR] [FML.TEXTURE_ERRORS]:     domain soulforgery has 1 location:
[16:54:13] [main/ERROR] [FML.TEXTURE_ERRORS]:       mod soulforgery resources at C:\Minecraft\Created Mods\SoulForgery\bin
[16:54:13] [main/ERROR] [FML.TEXTURE_ERRORS]: -------------------------
[16:54:13] [main/ERROR] [FML.TEXTURE_ERRORS]:     The missing resources for domain soulforgery are:
[16:54:13] [main/ERROR] [FML.TEXTURE_ERRORS]:       textures/items/shard_fuser.png

As well as a MissingVariantException:


"active=false, facing=north"

is not the same as



This is why Forge variants exist, but if you're going to use vanilla, you have to match vanilla exactly.

Edited by Draco18s

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.


Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.


DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

Now for some reason Minecraft is looking for my textures in it's domain:

[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]: The following texture errors were found.
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]: ==================================================
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]:   DOMAIN minecraft
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]: --------------------------------------------------
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]:   domain minecraft is missing 2 textures
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]:     domain minecraft has 3 locations:
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]:       unknown resourcepack type net.minecraft.client.resources.DefaultResourcePack : Default
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]:       unknown resourcepack type net.minecraft.client.resources.LegacyV2Adapter : FMLFileResourcePack:Forge Mod Loader
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]:       unknown resourcepack type net.minecraft.client.resources.LegacyV2Adapter : FMLFileResourcePack:Minecraft Forge
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]: -------------------------
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]:     The missing resources for domain minecraft are:
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]:       textures/blocks/shard_fuser_top.png
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]:       textures/blocks/shard_fuser.png
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]: -------------------------
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]:     No other errors exist for domain minecraft
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]: ==================================================
[19:37:25] [main/ERROR] [FML.TEXTURE_ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=


Nvm, just figured out why. My 'shard_fuser_active.json' for my model for some reason was using minecraft to find my shard fuser texture files. Probably did that on accident and never realised until now.

Edited by Distinct Soul
Found the solution
Link to comment
Share on other sites

Well now there's just 2 small problems left. I would like to understand better on how to create the 'cook' progress meter. My 'cook' progress meter isn't appearing at all. I have tried messing around with it for a little bit, and I've also tried comparing the furnace GUI class coordinates with where it is on the furnace GUI texture; but I just can't seem to figure it out at all.


Actually nvm again, it turns out I just forget to add my 'totalFuseTime' case to my getField method. Don't know how I missed that. Well now the only problem I have left with my machine is that when rejoining the world when any of that machine is already placed down, they will automatically set their-selves facing north.


Nvm a third time, I also just fixed that issue. Well, I just want to let everyone know who contributed to fixing the problems with my machine and the base of my mod, that I'm really grateful for it. I've had this idea of making a mod for Mc for a long time now, and whenever I make something that works in-game, I get this sense of accomplishment that makes me happy, and without people like you, none of this would probably have been possible. I know that I'm gonna encounter more problems along the way; but I just wanted to say, thank you all for helping me out.

Edited by Distinct Soul
Found the solution
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.