Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.12.2] Console not working


BerryHeyy
 Share

Recommended Posts

Hey,

 

I added an access transformer to my mod, and now my console isn't working. I'm in IntelliJ and it says this:

 

[21:14:52] [main/INFO]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
[21:14:52] [main/INFO]: Detected deobfuscated environment, loading log configs for colored console logs.
2019-05-26 21:14:53,231 main ERROR Error processing element LoggerNamePatternSelector ([PatternLayout: null]): CLASS_NOT_FOUND
2019-05-26 21:14:53,232 main ERROR Error processing element TerminalConsole ([Appenders: null]): CLASS_NOT_FOUND
2019-05-26 21:14:53,232 main ERROR Error processing element LoggerNamePatternSelector ([PatternLayout: null]): CLASS_NOT_FOUND
2019-05-26 21:14:53,247 main ERROR Unable to locate appender "Console" for logger config "root"
2019-05-26 21:14:53,449 main ERROR Error processing element LoggerNamePatternSelector ([PatternLayout: null]): CLASS_NOT_FOUND
2019-05-26 21:14:53,451 main ERROR Error processing element TerminalConsole ([Appenders: null]): CLASS_NOT_FOUND
2019-05-26 21:14:53,451 main ERROR Error processing element LoggerNamePatternSelector ([PatternLayout: null]): CLASS_NOT_FOUND
2019-05-26 21:14:53,458 main ERROR Unable to locate appender "Console" for logger config "root"

 

This is my AT file:

public net.minecraft.client.gui.FontRenderer field_78303_s #randomStyle
public net.minecraft.client.gui.FontRenderer field_78299_w #strike
public net.minecraft.client.gui.FontRenderer field_78300_v #underline
public net.minecraft.client.gui.FontRenderer field_78301_u #italic
public net.minecraft.client.gui.FontRenderer field_78302_t #bold
public net.minecraft.client.gui.FontRenderer field_78285_g #colorCode
public net.minecraft.client.gui.FontRenderer field_78291_n #red
public net.minecraft.client.gui.FontRenderer field_78292_o #blue
public net.minecraft.client.gui.FontRenderer field_78305_q #alpha
public net.minecraft.client.gui.FontRenderer field_78306_p #green
public net.minecraft.client.gui.FontRenderer field_78304_r #textColor
public net.minecraft.client.gui.FontRenderer field_78293_l #unicodeFlag
public net.minecraft.client.gui.FontRenderer field_78294_m #bidiFlag
public net.minecraft.client.gui.FontRenderer field_111273_g #locationFontTexture
public net.minecraft.client.gui.FontRenderer field_78298_i #renderEngine
public net.minecraft.server.MinecraftServer field_175591_ab #currentTime
public net.minecraft.world.chunk.Chunk field_76652_q #storageArrays
public net.minecraft.world.chunk.Chunk field_76638_b #precipitationHeightMap
public net.minecraft.client.renderer.ActiveRenderInfo field_178813_c #PROJECTION
public net.minecraft.client.renderer.ActiveRenderInfo field_178812_b #MODELVIEW
public net.minecraft.client.renderer.ActiveRenderInfo field_178814_a #VIEWPORT


public net.minecraft.client.gui.FontRenderer func_78272_b(C)Z #isFormatColor
public net.minecraft.client.gui.FontRenderer func_147647_b(Ljava/lang/String;)Ljava/lang/String; # bidiReorder
public net.minecraft.client.gui.FontRenderer func_78265_b()V # resetStyles
public net.minecraft.client.gui.FontRenderer func_181559_a(CZ)F # renderChar
public net.minecraft.client.gui.inventory.GuiContainer func_146977_a(Lnet/minecraft/inventory/Slot;)V #drawSlot
public net.minecraft.client.gui.inventory.GuiContainer func_146981_a(Lnet/minecraft/inventory/Slot;II)Z #isMouseOverSlot


public net.minecraft.client.gui.FontRenderer func_180455_b(Ljava/lang/String;FFIZ)I #renderString
public net.minecraft.client.gui.FontRenderer func_78259_e(Ljava/lang/String;I)I #sizeStringToWidth
public net.minecraft.client.gui.FontRenderer func_78255_a(Ljava/lang/String;Z)V #renderStringAtPos
public net.minecraft.client.gui.FontRenderer func_78280_d(Ljava/lang/String;I)Ljava/lang/String; #wrapFormattedStringToWidth

 

 

The game just works fine, its just the console. I have already run setupDecompWorkspace at the beginning and did it again just to be sure to no avail. I also tried running the game without the access transformer and then it works just fine. My build.gradle is also set up correctly.

 

 

Did I forget something?

 

Thanks for reading my post.

Link to comment
Share on other sites

post your code as a working GitHub repository

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Every time you post you post in the wrong subforum and I have to move your thread. Please take the hint. This is broken. You must not return null from this method. Use NetworkHooks.getEntitySpawningPacket. You must also only spawn your entity and start riding it on the server.
    • Sorry about the wait, I managed to fix the issue by loading in one of my server providers presets and stealing the jar from that. Sorry about wasting your time.
    • The first step to this is to see if you can track down the original author and ask if they still have the source and if so, can you look at it
    • Hi, I'm trying to make a forge server in minecraft 1.16.5 and when i open the .bat file to start the server i have an error and i dont know what is happening so if anyone can help me, thank you.  Version: 1.16.5  Forge version: 1.16.5-36.2.22   Error: 2022-01-19 20:42:25,004 main WARN Advanced terminal features are not available in this environment [20:42:25] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.22, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge] [20:42:25] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 16.0.2 by Oracle Corporation Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0x5e4c8041) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0x5e4c8041         at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:41)         at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95)         at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:41)         at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55)         at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708)         at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52)         at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47)         at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62)         at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55)         at cpw.mods.modlauncher.Launcher.main(Launcher.java:66)         at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63)         at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60)         at net.minecraftforge.server.ServerMain.main(ServerMain.java:57)   Lates LOG:  [19ene.2022 20:42:25.197] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.22, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge] [19ene.2022 20:42:25.201] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 16.0.2 by Oracle Corporation   Debug: [19ene.2022 20:42:25.197] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.22, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge] [19ene.2022 20:42:25.201] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 16.0.2 by Oracle Corporation [19ene.2022 20:42:25.215] [main/DEBUG] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Found launch services [minecraft,testharness,fmlclient,fmlserver]  
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.