Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Crash After Installing Forge On Server [3.3.8.152]


 Share

Recommended Posts

Alright so I was going to play some minecraft with my friend and we decided we wanted mods so I had to install forge on a server right? So I go ahead and do that by downloading the recommended server version for forge and put it inside of the 1.2.5 server .jar folder of minecraft and I run the server and everything seems to have gone perfectly, so I go to join the game (I have the same version as the server does) and then it comes up this giant crash log;

 

 

37 mods loaded

Minecraft Forge 3.3.8.152

FML v2.2.78.153

Forge Mod Loader version 2.2.78.153 for Minecraft 1.2.5

mod_CodeChickenCore : Available (minecraft.jar)

mod_MinecraftForge : Available (minecraft.jar)

mod_NotEnoughItems : Available (minecraft.jar)

mod_IC2 : Available (industrialcraft-2-client_1.97.jar)

mod_AdvancedMachines : Available (AdvancedMachinesClient v1.5.zip)

mod_AdditionalBuildcraftObjects : Available (buildcraft-C-additionalbuildcraftobjects-f301@75bc315-100.zip)

mod_BuildCraftCore : Available (buildcraft-client-A-core-3.1.5.zip)

mod_BuildCraftBuilders : Available (buildcraft-client-B-builders-3.1.5.zip)

mod_BuildCraftEnergy : Available (buildcraft-client-B-energy-3.1.5.zip)

mod_BuildCraftFactory : Available (buildcraft-client-B-factory-3.1.5.zip)

mod_BuildCraftTransport : Available (buildcraft-client-B-transport-3.1.5.zip)

mod_BuildCraftSilicon : Available (buildcraft-client-C-silicon-3.1.5.zip)

mod_AdditionalPipes : Available (buildcraft-client-DA-additionalpipes-3.1.0.zip)

mod_DoggyTalents : Available (DoggyTalents223.zip)

mod_EE : Available (EE2ClientV1.4.6.5.jar)

mod_EnderStorage : Available (EnderStorage-Client 1.1.3.zip)

mod_RedPowerWorld : Available (RedPowerWorld-2.0pr5b2.zip)

mod_Forestry : Available (forestry-client-A-1.4.8.0.jar)

mod_IC2NuclearControl : Available (IC2NuclearControl_client_v1.1.9b.zip)

mod_InvTweaks : Available (InvTweaks-1.41b-1.2.4.zip)

mod_PigbearLaser : Available (Laser Mod 1.5.zip)

mod_LogisticsPipes : Available (LogisticsPipes-BC3-0.2.5B.zip)

mod_CompactSolars : Available (mod_compactsolars-client-2.3.2.10.zip)

mod_IronChest : Available (mod_ironchests-client-3.6.1.34.zip)

mod_PortalGun : Available (portalgun)

mod_Railcraft : Available (Railcraft_Client_5.3.3.zip)

mod_RedPowerControl : Available (RedPowerControl-2.0pr5b2.zip)

mod_RedPowerCore : Available (RedPowerCore-2.0pr5b2.zip)

mod_RedPowerLighting : Available (RedPowerLighting-2.0pr5b2.zip)

mod_RedPowerLogic : Available (RedPowerLogic-2.0pr5b2.zip)

mod_RedPowerMachine : Available (RedPowerMachine-2.0pr5b2.zip)

mod_RedPowerWiring : Available (RedPowerWiring-2.0pr5b2.zip)

mod_SneakyPipes : Available (SneakyPipes-0.1.1.zip)

Steve's Carts : Available (Steves Carts 1.4.4.zip)

mod_WirelessRedstoneCore : Available (WR-CBE Core-Client 1.2.2.1.zip)

mod_WirelessRedstoneAddons : Available (WR-CBE Addons-Client 1.2.2.2.zip)

mod_WirelessRedstoneRedPower : Available (WR-CBE RedPower-Client 1.2.2.1.zip)

 

 

      Minecraft has crashed!     

      ----------------------     

 

Minecraft has stopped running because it encountered a problem.

 

 

 

 

--- BEGIN ERROR REPORT 797274cf --------

Generated 08/07/12 21:28

 

Minecraft: Minecraft 1.2.5

OS: Windows 7 (amd64) version 6.1

Java: 1.6.0_14, Sun Microsystems Inc.

VM: Java HotSpot 64-Bit Server VM (mixed mode), Sun Microsystems Inc.

LWJGL: 2.8.3

OpenGL: ATI Radeon HD 4300/4500 Series version 3.3.11554 Compatibility Profile Context, ATI Technologies Inc.

 

java.lang.RuntimeException: java.lang.RuntimeException: java.lang.NullPointerException

at cpw.mods.fml.common.FMLCommonHandler.raiseException(FMLCommonHandler.java:411)

at ModLoader.throwException(ModLoader.java:787)

at buildcraft.additionalpipes.util.SaveManager.getDataDir(SaveManager.java:115)

at buildcraft.additionalpipes.util.SaveManager.load(SaveManager.java:65)

at buildcraft.additionalpipes.chunkloader.ChunkLoadingHandler.onWorldLoad(ChunkLoadingHandler.java:93)

at forge.ForgeHooks.onWorldLoad(ForgeHooks.java:287)

at xD.<init>(World.java:227)

at je.<init>(SourceFile:32)

at adl.a(NetClientHandler.java:81)

at aec.a(SourceFile:68)

at lg.b(NetworkManager.java:343)

at adl.b(NetClientHandler.java:71)

at ajy.a(SourceFile:45)

at net.minecraft.client.Minecraft.k(Minecraft.java:1572)

at net.minecraft.client.Minecraft.x(Minecraft.java:822)

at net.minecraft.client.Minecraft.run(Minecraft.java:750)

at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.RuntimeException: java.lang.NullPointerException

at cpw.mods.fml.common.ReflectionHelper.getPrivateValue(ReflectionHelper.java:40)

at ModLoader.getPrivateValue(ModLoader.java:387)

at buildcraft.additionalpipes.util.SaveManager.getDataDir(SaveManager.java:110)

... 14 more

Caused by: java.lang.NullPointerException

at sun.reflect.UnsafeFieldAccessorImpl.ensureObj(Unknown Source)

at sun.reflect.UnsafeQualifiedObjectFieldAccessorImpl.get(Unknown Source)

at java.lang.reflect.Field.get(Unknown Source)

at cpw.mods.fml.common.ReflectionHelper.getPrivateValue(ReflectionHelper.java:34)

... 16 more

--- END ERROR REPORT e9028fa8 ----------

 

 

 

Also might I add that there was no mods installed on the server at the time it was just forge installed I decided to test it to make sure it works but obviously the above happened. I hope I can get a good a quick response because we want to play minecraft soon :) Thanks in advance

 

EDIT: This was on a brand new world.

 

Cheers

Link to comment
Share on other sites

Not an error in Forge, it is the buildcraft.additionalpipes mod that is crashing, specifically its buildcraft.additionalpipes.util.SaveManager class.  Might want to ask them.

 

Ok that seems to have fixed it i'll have a look at the author of additional pipes and see whats up. Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.