Jump to content

[Solved]Minecraft Forge Decompile error


balink
 Share

Recommended Posts

I am trying to use the install.cmd in minecraft forge, but I keep getting this error:

 

================ Forge ModLoader Setup Start ===================
Downloaded mcp7.44.zip
Extracting MCP to 'C:\Users\Grey\Documents\Development\MCP\forge\mcp'
Setting up MCP
Backing up commands.py
patching file commands.py
Commands patch applied successfully
Copying FML conf
Creating re-packaged srg
Creating re-packaged exc
Creating re-packaged MCP patches
Fixing MCP Workspace
Downloaded argo-3.2-src.jar
Downloaded guava-14.0-rc3.jar
Downloaded asm-4.1.tar.gz
Downloaded asm-debug-all-4.1.jar
Downloaded bcprov-debug-jdk15on-148.jar
Downloaded bcprov-jdk15on-148-src.zip
Downloaded guava-14.0-rc3-sources.jar
Downloaded lwjgl.jar
Downloaded lwjgl_util.jar
Downloaded jinput.jar
Downloaded windows_natives.jar
    Extracting jinput-dx8.dll
    Extracting jinput-dx8_64.dll
    Extracting jinput-raw.dll
    Extracting jinput-raw_64.dll
    Extracting lwjgl.dll
    Extracting lwjgl64.dll
    Extracting OpenAL32.dll
    Extracting OpenAL64.dll
Downloaded macosx_natives.jar
    Extracting libjinput-osx.jnilib
    Extracting liblwjgl.jnilib
    Extracting libopenal.dylib
    Extracting openal.dylib
Downloaded linux_natives.jar
    Extracting libjinput-linux.so
    Extracting libjinput-linux64.so
    Extracting liblwjgl.so
    Extracting liblwjgl64.so
    Extracting libopenal.so
    Extracting libopenal64.so
Downloaded minecraft.jar
Downloaded minecraft_server.jar
== MCP 7.44 (data: 7.44, client: 1.5.1, server: 1.5.1) ==
> Searching for javac.exe in C:\Program Files
# found ff, ff patches, srgs, name csvs, doc csvs, param csvs, renumber csv, ast
yle, astyle config
> Creating Retroguard config files
== Decompiling client using fernflower ==
> Creating SRGs
> Applying Retroguard
> Compiling AccessTransformer
> Compiling MCPMerger
> Running MCPMerger
Error: Could not find or load main class cpw.mods.fml.common.asm.transformers.MC
PMerger
Decompile Exception: 1
Press any key to continue . . . 

 

I have tried by installing MCP separately and with Forge, I have re-downloaded and extracted the folder many times, but nothing is working.  I am running windows 8 64 bit and the newest version of Java. Here is the MCP.log:

 

15:45:56 - == MCP 7.44 (data: 7.44, client: 1.5.1, server: 1.5.1) ==
15:45:56 - OS : win32
15:45:56 - > Searching for javac.exe in C:\Program Files
15:45:56 - # VERSION INFO
15:45:56 - python: 2.7.3 (default, Apr 10 2012, 23:31:26) [MSC v.1500 32 bit (Intel)]
15:45:56 - platform: Windows-post2008Server-6.2.9200
15:45:56 - # java: '"C:\Program Files\Java\jre7\bin\java" -version'
15:45:56 - java version "1.7.0_10"

Java(TM) SE Runtime Environment (build 1.7.0_10-b18)

Java HotSpot(TM) 64-Bit Server VM (build 23.6-b04, mixed mode)
15:45:56 - # javac: '"C:\Program Files\Java\jre7\bin\javac" -version'
15:45:56 - 
15:45:56 - # javac runtime: '"C:\Program Files\Java\jre7\bin\javac" -J-version'
15:45:56 - 
15:45:56 - # retroguard: 'runtime\bin\retroguard.jar --version'
15:45:56 - RetroGuard MCP v3.6.5
based on RetroGuard v2.3.1 by Retrologic Systems - [url=http://www.retrologic.com]www.retrologic.com[/url]
15:45:56 - # mcinjector: 'runtime\bin\mcinjector.jar --version'
15:45:56 - MCInjector v2.8 by Searge, LexManos, Fesh0r
15:45:56 - # patch: 'runtime\bin\applydiff.exe --version'
15:45:56 - patch 2.5.4
15:45:56 - # astyle: 'runtime\bin\astyle.exe --version'
15:45:56 - Artistic Style Version 2.02.1
15:45:56 - # jadretro: 'runtime\bin\jadretro.jar'
15:45:56 - Error: Unable to access jarfile runtime\bin\jadretro.jar
15:45:56 - # jad: 'runtime\bin\jad.exe'
15:45:56 - # fernflower: 'runtime\bin\fernflower.jar'
15:45:56 - Usage: java ConsoleDecompiler ( -<option>=<value>)* (<source>)+ <destination>
15:45:56 - # found ff, ff patches, srgs, name csvs, doc csvs, param csvs, renumber csv, astyle, astyle config
15:45:56 - Updates disabled
15:45:56 - > Creating Retroguard config files
15:45:56 - client md5: 5c1219d869b87d233de3033688ec7567
15:45:56 - == Decompiling client using fernflower ==
15:45:56 - > Creating SRGs
15:45:56 - > Applying Retroguard
15:45:56 - > Compiling AccessTransformer
15:45:56 - > Compiling MCPMerger
15:45:56 - > Running MCPMerger
15:45:57 - Error: Could not find or load main class cpw.mods.fml.common.asm.transformers.MCPMerger

If anyone knows what the error is, that would be wonderful.

Link to comment
Share on other sites

I can read the error.  I found the class in forge\fml\common\cpw\mods\fml\common\asm\transformers.  Is this where it is supposed to be found?

 

According to your error messages, yes. If you go to your Java settings in your control panel, which Java is checked for your System? (not User)

Yes, my ideas can be naive. But I'm hoping that speaking my mind will inspire those who know what they are doing!

Link to comment
Share on other sites

When I open Java settings in my control panel it pulls up a very simplistic control panel with 4 tabs, General, Java, Security, and Advanced.  Under the Java tab, there is a runtime environment settings dialog box, and under system there is a check next to Java 1.7.0_10, pathed to C:\program files\Java\jre7\bin\javaw.exe

Link to comment
Share on other sites

Unfortunately, the only idea I could come up with was seeing if something was blaringly wrong with your Java settings, which is a problem that I encountered recently. Hopefully someone more knowledgeable about Forge will be able to lend a hand. Good luck!  :P

Yes, my ideas can be naive. But I'm hoping that speaking my mind will inspire those who know what they are doing!

Link to comment
Share on other sites

It's been a while since I have decompiled the source, though once I can get the 1.5.1 jar downloaded plus all the Forge libraries, I will be doing it in the next day or so.

 

With that said, stupid question time!  Are you sure you have the Java Development Kit installed?  The JDK is a whole different animal than the standard JRE that most people have.  Now I understand from the logs you posted that your computer is using the JRE while attempting to decompile.  While I have never tested that, I'm going to go out on a ledge and think it won't work.

 

If you do have the JDK installed, try going to your PATH environment variable and making sure it points to the JDK and not the JRE.  I use Windows 7, so I have no idea if its been moved or not.  If its still in the same location:  Control Panel -> System -> Advanced System Settings (on the left column) -> Environment Variables -> Look under the System Variables group which is under the User Variables.  Scroll down until you see PATH and click Edit.  Use your arrow keys to move all the way to the end and begin to move back to the left slowly until you see anything pertaining to Java.  Change that part to point to the JDK location (take care not to modify anything else there!!).

 

If that doesn't fix your problem, let me know.  I hope to be at my dev computer in the next day or so to setup my own MCP environment.  I'll take a look at the logs I get and see if I can figure out where your issue is.

Link to comment
Share on other sites

Not entirely sure, but it seems like it could be a problem that I don't have anything pertaining to Java in my Path variable?  I'm not sure if I'm looking in the right place, but it says nothing about Java anywhere in it...  This sounds like something I should probably Google to set up?

Link to comment
Share on other sites

I'm not entirely sure you need the JDK to be able to decompile, so not having it in your path may not even be an issue at this point, but might when you go to compile your mod.  Again, I'm not familiar enough with Java to be sure.

 

All I know is that when I first set everything up back in 1.3 with MCP 4.20, I was using Eclipse, and that definately needs the JDK in your path!  But its been a while, and I didn't have any errors with the initial decompile, so I can't recall if that came before or after I set the JDK in my path variable.

 

I did a quick google search and got this post for Windows 8 environment variables: http://www.technoon.com/how-to-add-environment-variables-in-windows-8.html

 

Once you are on that last screen, just move the text cursor to the end, add a semi-colon and then enter the path to your JDK, typically: C:\Program Files\java\<jdk_verision\bin

 

If it doesn't work, at the very least it won't do any harm.  I'm about to get off shift so I can check my old MCP folder to see if I can recreate your problem.

 

EDIT:  Ok, I ran the Forge installer and had no issues.  Apparently it will automatically look for the JDK without needing to have it in the Path... so forget all that (unless you are using Eclipse)

 

I compared my mcp.log to yours and here are the differences:  I manually downloaded mcp744.zip on 4/2/13.  Your log says it downloaded mcp7.44.zip on or about 4/3/13

mine does not have the period between the 7 and the 44.  Not sure what that is all about...

Mine ran AccessTransformer right after running MCPMerger.  I navigated to the folder and found that I have MCPMerger.java created on 3/31/13 at 8:34 AM.  Does the one you have match?

Lastly the only other difference is that I have:

01:34:55 - platform: Windows-7-6.1.7601-SP1
01:34:55 - # java: '"C:\Program Files\Java\jdk1.7.0_17\bin\java" -version'
01:34:55 - java version "1.7.0_17"

Java(TM) SE Runtime Environment (build 1.7.0_17-b02)

Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)
01:34:55 - # javac: '"C:\Program Files\Java\jdk1.7.0_17\bin\javac" -version'
01:34:55 - javac 1.7.0_17
01:34:55 - # javac runtime: '"C:\Program Files\Java\jdk1.7.0_17\bin\javac" -J-version'
01:34:56 - java version "1.7.0_17"

Java(TM) SE Runtime Environment (build 1.7.0_17-b02)

Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)

 

While your log is saying jre7 build 1.7.0_10.  In your original post you said you had the latest java installed, well if you do, its being superseded by an older version.

 

If you notice, my log gives a reply every time the installer checks the versions of the various jave exe's, while yours gives a blank reply.

 

At this point I would recommend removing the JRE and reinstalling the latest JDK from the Oracle website.  Hopefully that may work.

Link to comment
Share on other sites

Thanks!  I completely reinstalled both the JRE and the JDK from scratch, as well as added it to the path variable, and the installer ran without a hickup!  Who know what the problem really was, but I'm just glad it works now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.